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Getting Started

This section includes the following topics:

* “What Is CAGE?” on page 1-2
* “Navigating CAGE” on page 1-4
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What Is CAGE?
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Model-Based Calibration Toolbox contains tools for design of experiment, statistical
modeling, and calibration of complex systems. See “Model-Based Calibration Toolbox
Product Description”. The toolbox has two main user interfaces:

* Model Browser for design of experiment and statistical modeling
* CAGE Browser for analytical calibration

CAGE (CAlibration GEneration) is an easy-to-use graphical interface for calibrating
lookup tables for your electronic control unit (ECU).

As engines get more complicated, and models of engine behavior more intricate, it is
increasingly difficult to rely on intuition alone to calibrate lookup tables. CAGE provides
analytical methods for calibrating lookup tables.

CAGE uses models of the engine control subsystems to calibrate lookup tables. With
CAGE you fill and optimize lookup tables in existing ECU software using models from the
Model Browser part of the Model-Based Calibration Toolbox product. From these models,
CAGE builds steady-state ECU calibrations.

CAGE also compares lookup tables directly to experimental data for validation.
Feature Calibration

A feature calibration compares a model of an estimated signal with a lookup table (or
algebraic collection of tables) that estimates the same signal in the ECU. CAGE finds the
optimum calibration for the lookup table(s).

For example, a typical engine subsystem controls the spark angle to produce the peak
torque; that is, the Maximum Brake Torque (MBT) spark. Using the Model Browser, you
can build a statistically sound model of MBT spark, over a range of engine speeds and
relative air charges, or loads. Use the feature calibration to fill a lookup table by
comparing the table to the model.

Tradeoff Calibration

A tradeoff calibration fills lookup tables by comparing models of different engine
characteristics at key operating points.

For example, there are several models of important engine characteristics, such as torque
and nitrous oxides (NOX) emissions. Both models depend on the spark angle. At a
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particular operating point, a slight reduction of torque can result in a dramatic reduction
of NOX emissions. Thus, the calibrator uses the value of the spark angle that gives this
reduction in NOX emissions instead of the spark angle that generates maximum torque.

Optimization

CAGE can optimize calibrations with reference to models, including single- and multi-
objective optimizations, sum optimizations, user-defined optimizations, and automated
tradeoff.

Comparing Calibrations to Data
You can compare your calibrations to experimental data for validation.

For example, after completing a calibration, you can import experimental data from a
spreadsheet. You can use CAGE to compare your calibration to the data.

Starting the CAGE Browser
To start the application, type
cage

at the MATLAB® command prompt.

1-3
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Navigating CAGE

1-4

In this section...

“How to Select CAGE Views” on page 1-4
“CAGE Views and Processes” on page 1-6

How to Select CAGE Views

The view of CAGE depends on two things:

*  Which button you select in the Processes and Data Objects panes
* The item you highlight in the tree display

When you open CAGE, it looks like this.
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CAGE includes a Processes pane and a Data Objects pane to help you identify the type
of calibration you want to do and the data objects that you intend to use. Use the buttons
in these panes to navigate between the different sections of functionality in CAGE.

CAGE Views and Processes

The Processes pane has three buttons:

» Feature shows the Feature view, with the tables and strategies that are associated
with that feature. See “Working With Features” on page 4-12.

A feature is a strategy (or collection of tables) and a model used to calibrate those
tables. In the Feature view, you can fill tables by comparing a strategy to a model. See
“Feature Calibration”. You can import existing strategies or construct new ones using
Simulink® software from the feature view.

From the feature node in the tree display, you can access the Surface Viewer to
examine the strategy or model or both. See “The Surface Viewer in CAGE” on page 10-
2.

* Tradeoff shows the Tradeoff view, with a list of the tables and models to display. Here
you can see graphically the effects of manually altering variables to trade off different
objectives (such as maximizing torque while minimizing emissions). At the tradeoff
node, you can calibrate table values to achieve the best compromise between
competing objectives. You can calibrate using single or multimodel tradeoffs. See
“Tradeoff Calibration”. You can also use the optimization functionality of CAGE to run
automated tradeoffs, described in the Optimization section (see below).

* Optimization shows the Optimization view. From here you can set up and run
optimizations, including automated tradeoffs. There are standard routines available
and also templates provided so you can write your own optimization routines. You can
find full instructions in “Optimization Setup”.

You can reach the Calibration Manager from the Feature and Tradeoff process views,
and from the Tables view, but not Optimization. In the Calibration Manager you can

set up the size and contents of tables (manually or using existing calibration files) and
edit the precision used for values (to match the kind of electronic control unit you are

going to use). See “Calibration Manager” on page 3-27.
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Processes

Feature

U0
AL

The Data Objects pane has four buttons:

Variable Dictionary stores all the variables, constants, and formulas in your session.
Here you can view, add, and edit any variables in any part of your session. See
“Setting Up Variable Items” on page 2-8.

Tables enables you to see all the tables and normalizers in your session. You can also
calibrate tables manually here if you want. You can add and delete tables from the
project. From any table display (here, or in other views) you can access the History
Display to manage changes in your tables and normalizers. You can use the History
Display to reverse changes. See “Setting Up Tables” on page 3-2.

Models stores all the models in your session. Here you can view a graphical display of
these models, including a diagram of the model's input structure. This is useful
because a model can have other models as inputs. You can change the inputs here. For
example, you can change your model's input Spark to be connected to a model for
Spark rather than to the variable Spark. You can also access the surface viewer here
to examine models. See “Setting Up Models” on page 2-16 and “The Surface Viewer

in CAGE” on page 10-2.

Data Sets enables you to evaluate your models and features over a custom set of
input values. Here you can create and edit a set of input values and view several
models or features evaluated at these points. You can compare your tables and models
with experimental data to validate your calibrations. You can also fill tables directly
from experimental data by loading the experimental data as a new data set. See “Use
Data Sets Views” on page 9-2.

1-7
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Variables and Models

The following sections describe how to set up variables and models before performing
calibrations.

“Set Up Calibrations, Resume Work, or Find Calibration Examples” on page 2-2
“Import Models and Calibration Items Using CAGE Import Tool” on page 2-5
“Setting Up Variable Items” on page 2-8

“Setting Up Models” on page 2-16

“Creating and Viewing Composite Models in CAGE” on page 2-26

“Model Properties” on page 2-33

“Specifying Locations of Files” on page 2-38



2 Variables and Models

Set Up Calibrations, Resume Work, or Find Calibration
Examples

2-2

When you open MBC Optimization app, the home page helps you get started or resume
work faster by accessing frequent tasks, recent projects, and featured examples.

* Get started by using the buttons in the right pane for common calibration tasks:
import models; set up optimizations, tables, feature strategies, or data sets;. or export
tables

* Resume work by opening projects from the Recent projects list.
* Open case study examples from the Case Studies list.
* View a summary of items in your project. To open other views, click Browse Project.

* From other calibration views, to return to the home page, click the Home toolbar
button or select File > Home.
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See Also

Related Examples
“Import Models and Calibration Items Using CAGE Import Tool” on page 2-5

“Create an Optimization” on page 6-8
“Creating Tables from a Model” on page 3-4
“Setting Up Models” on page 2-16
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. “Set Up a Feature Calibration” on page 4-11
. “Set Up Designs and Models, Resume Work, or Find Engine Modeling Examples”
. “Engine Calibration Applications”

2-4



Import Models and Calibration Items Using CAGE Import Tool

Import Models and Calibration Items Using CAGE Import

Tool

You can use the CAGE Import Tool to select items to import from any Model-Based
Calibration Toolbox project file produced in CAGE or the Model Browser (.mat or . cag).
This can greatly simplify setting up new projects, and also making changes to existing
projects, for example to make use of new models in an existing optimization and
calibration.

You can import Model Browser models from any project file or direct from the Model
Browser when it is open. You can import the following CAGE items from any CAGE
project: models (including feature and function models), variables, normalizers, tables,
features, optimizations, datasets and tradeoffs.

You can replace suitable items in your current CAGE project with imported items. You can
see if an item is replaceable in the Import dialog, where the Replace action becomes
available.

Note that Model Browser models (but not CAGE models) must have exactly the same
input names as the CAGE model you want to replace. You can replace models, variables,
normalizers, tables and features. You cannot replace optimizations, datasets or tradeoffs.
You cannot replace tables used in tradeoffs with tables of a different size.

To use the CAGE Import Tool:

1  On the CAGE home page, click Import Models. Alternatively, select File > Import
From Project.

+ Ifitis not already open, the Model Browser opens. Use the Model browser to open
a project.

The CAGE Import Tool appears.
2 You can choose a project file or import directly from the Model Browser if it is open.

+ If the Model Browser is open, the list is automatically populated with a list of
available items in the open project.

* To import from a file, click the Import from project file button.

A file browser dialog opens. Locate the desired file and click Open.
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3 The CAGE Import Tool displays the available items. Select the items you want to
import from the list. Press Ctrl+A to select all items, or Ctrl+click or Shift+click to

select multiple items in the list.

B caGE Import Tool =0 = T
Current project: C\Work\IMBC\mbctraining\Gasoline_project. mat
Find: Type: Al -
D Match case
Name Type Location
BT Response Gasoline_project/DIVCR/BTO -
EXTEMP Response Gasoling_project/DIVCR/EXTEMP
‘ RESIDFRAC Response Gasoline_projectDIVCP/RESIDFRAC
“: BTQ Point-by-Point Gasoline_projectDIVCR/BTQ/PS22
Q EXTEMP Point-by-Point Gasoline_projectDINVCR/EXTEMP/POLY2
% RESIDFRAC Point-by-Point Gasaline_project/DIVCP/RESIDFRAC/P. . =
Gasoline_projectDIVCRBTAPSZ22/knot
Ik knot Response Feature Gasoline_project/DIVCR/BTA/PSZ2/knot
< max Response Feature Gasoline_project/DIVCP/BTQ/PS22/max
<\ Bhigh_2 Response Feature Gasoline_project/DIVCP/BTQ/PSZ2/BhI.. &
i Blow_2 Response Feature Gasoline_projectDIVCP/BTQ/PS22/BIo.

Gasoline_projectDWVCREXTEMP/POL...
Gasoline_projectDNVCP/EXTEMP/POL...

Response Feature
Response Feature

Impert Selected tems.

You can use the Find and Type controls to filter the item list:

If you are importing from a Model Browser project you can select Response,
Point-by-point, Datum or Response Feature from the Type list to display a
single model type only.

If you are importing from a CAGE project you can select Variable, Model,
Normalizer, Table, Feature, Optimization, Dataset, or Tradeoff from the
CAGE items in the Type list. For models the Subtype column displays whether a
model item is an MBC model, function model or feature model.

Enter text in the Find edit box to find particular item names. You can also select
the box to Match case

Click the Import Selected Items button.
5 The CAGE Browser opens displaying the imported models.



See Also

|| CAGE Browser - Untitled

File Edit View Model Tools Window Help

B »
@ Lcd X WFra ke " ak® oy E
Processes Models
Name Type Inputs Lower Output Limit| Upper Output Limit | Description
4 EXTEMP MBC model S, N, L, ICP, ECP -Inf| Inf| Created by on 10-May-2017.
v‘ knot MBC model N, L, ICP, ECP -Inf| Inf| Created by on 10-May-2017.
- Fx 0 MBC model N, L, ICP, ECP -Inf| Inf| Created by on 10-May-2017.

6 When you have finished importing items, in the CAGE Import Tool, click Close..

See also:

* “Importing and Exporting a Variable Dictionary” on page 2-10
* “Import Exported Models File” on page 2-19

See Also

Related Examples
. “Set Up Calibrations, Resume Work, or Find Calibration Examples” on page 2-2
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Setting Up Variable Items

2-8

In this section...

“Introducing the Variable Dictionary View” on page 2-8
“Importing and Exporting a Variable Dictionary” on page 2-10
“Adding and Editing Variable Items” on page 2-11

“Using the Variable Menu” on page 2-13

“Using Aliases” on page 2-14

Introducing the Variable Dictionary View

The Variable Dictionary is a store for all the variables, constants, and formulae in your
session.

To view or edit the items in the Variable Dictionary, click the button, shown, in the Data
Objects pane.

Selecting the Variable Dictionary view displays the variables, constants, and formulae in
the current project.

Note that if you have existing CAGE projects you can use the “Import Models and
Calibration Items Using CAGE Import Tool” on page 2-5 to import variable items and
other CAGE items directly from other projects.

Following is an example of the Variable Dictionary view.
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List of all the constants, variables, and formulas in the project

) cacoromser -unted | TP
File. Edit Variable Tools Wifdow Help

[Ded | x|#% 2 DR
Processes Var_i,a‘ble-ch‘:{iOha_:y |

Name || Tvpe | Alias | Minimum | Magimum | Set Point | Fomula |

XN * Variable engine_speed 500 6500 2500

Xk Yariable load, Load 01 1 0.4
Feature xA Variable  afr, AFR 11 17 1435
k stoich  Constant 14.35
X SPK Varable S, s, spark -10 60 225
ftx)lambda Formula 075 1.25 1 Afstoich
Calibration
A
m Y Alias: | afr, AFR
HA B |
Tradant? Description: I Air-fuel ratio (ratio)

n_, . Minimum: I 11 _—;:l M aximunm: I 17 :;—J
pm | etpare [ 143 2

Formtda: |

Variable
Dictionary

Edit boxes to change the settings of the
selected constant, variable, or formula
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The upper pane shows a list of all the current variables, constants, and formulas. The
lower pane displays edit boxes so you can specify the settings of the selected variable,
constant, or formula.

Different Variable Dictionary Items

* Variables — standard items that feed into models, strategies and tables, and define
ranges for these items

* Constant — used for inputs that you do not want to change

* Formulae — used when you want a variable item to depend on another

Importing and Exporting a Variable Dictionary

A variable dictionary contains all the variable items for your calibrations. You can set up
your variable dictionary once, and use it in many calibrations.

If you import a model, it has variables associated with it, in which case you might not
have to import a variable dictionary.

Importing a Variable Dictionary

To import a dictionary of variables from an .xm1 file,

1 Select File > Import > Variable Dictionary.
2 Select the correct dictionary file.

Note you can also import variable items directly from other CAGE projects using the
“Import Models and Calibration Items Using CAGE Import Tool” on page 2-5.

Exporting a Variable Dictionary

After setting up a variable dictionary, you can save the dictionary for use in many
different calibrations.

To export a dictionary of variables to an .xml file,

1 Select File > Export > Variable Dictionary.
2  Select a suitable name for the dictionary file.
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See Also

» “Setting Up Variable Items” on page 2-8
* “Adding and Editing Variable Items” on page 2-11

Adding and Editing Variable Items

To add variable items you can use the Variable Dictionary toolbar, shown, or you can
select items from the File -> New -> Variable Items menu.

(G ?}
Add a variable Add a variable Add a variable

Adding a Variable

To add a variable,

1 Select File > New > Variable Item > Variable.

A new variable is added to the variable dictionary.
Select Edit > Rename to alter the name of the variable.

3  Specify the Minimum and Maximum values of the variable in the edit boxes in the
lower pane.

4  Specify the value of the Set Point in the edit box.

Using Set Points in the Variable Dictionary

The set point of a variable is a point that is of particular interest in the range of the
variable. You can edit set points in the variable dictionary or the models view.

For example, for the air/fuel ratio variable, AFR, the range of values is typically 11 to 17.
However, whenever only one value of AFR is required, it is preferable to choose 14.3, the
stoichiometric constant, over any other value. So enter 14. 3 as the Set Point.

CAGE uses the set point as the default value of the variable wherever one value from the

variable range is required. For instance, CAGE uses the set point when evaluating a
model over the range of a different variable.

2-11
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For example, a simple model for torque depends on AFR, engine speed, and relative air
charge. CAGE uses the set point of AFR when it calculates the values of the model over
the ranges of the engine speed and relative air charge.

Adding a Constant
To add a constant,
1 Select File > New > Variable Item > Constant.

A new constant is added to the variable dictionary.
Select Edit > Rename to alter the name of the constant.
Specify the value of the constant in the Set Point edit box, in the lower pane.

Adding Formulas

afr

You might want to add a formula to your session. For example, the formula A = wich
stoic

where afr is the air/fuel ratio and stoich is the stoichiometric constant.
To add a formula,
1 Select File > New > Variable Item > Formula.

The Add Formula dialog box appears.

2 Inthe dialog, enter the right side of the formula, as in this example afr/stoich.
Note it is normal to create inputs to a formula first. If you do not use pre-existing
variable names then those inputs are created, so be careful to get input names
exactly correct. Follow these requirements for a valid formula string:

* A formula can only have exactly one variable input
* No formulae as inputs

* Not circular (i.e. self referencing)

* Must not error when evaluated

* Must produce a vector for a vector input

* Must be invertible

Click OK and a new formula is added to the variable dictionary.
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3

Select Edit -> Rename to alter the name of the formula.

See Also

“Setting Up Variable Items” on page 2-8
“Adding and Editing Variable Items” on page 2-11

Using the Variable Menu

The Variable menu in the variable dictionary enables you to alter variable items. These
choices are also available in the right-click context menu on the list view.

Change item to:

Alias

Changes the selected item to be an alias of another item in the current project. For
example, if you have two variables, engine speed and n, you can change n to be an
alias of engine speed, with its maximum and minimum values. For more
information, see the next section, “Using Aliases” on page 2-14.

Formula

Changes a variable or constant into a formula. You have to define the right side of the
formula, and you can select the check box to calculate the range.

Constant

Changes a variable or formula into a constant. The value of the constant is the set
point of the old item.

Variable

Changes a constant or formula into a variable. The range is from 0 to twice the
constant's value (negative values have a maximum of 0).

See Also

“Setting Up Variable Items” on page 2-8
“Using Aliases” on page 2-14
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Using Aliases

The variable dictionary enables you to use the same set of variables, constants, and
formulas with many different models and calibrations.

Why Use Aliases?

It is possible that in one model or strategy the engine speed has been defined as N, and in
another it has been defined as rpm. The alias function enables you to automatically link
inputs with various names to a single CAGE variable when you import models and
strategies.

Creating an Alias

For example, in a variable dictionary there are two variables:
* N, with a range of 500 to 6500

* rpm, with a range of 2500 to 3500

To set rpm to be an alias of N,

1 Highlight the variable rpm.
2 Select Variable > Change item to > Alias.
3 In the dialog, choose N from the list.

This eliminates the variable rpm from your variable dictionary, and every model and
calibration that refers to rpm now refers to N instead.

Note If N is made an alias of rpm in the preceding example, the range of N is restricted to
the range of rpm, 2500 to 3500.

You can also add aliases to existing items by entering a list of names in the Alias edit box.
See Also

* “Setting Up Variable Items” on page 2-8



See Also

See Also

Related Examples
. “Set Up Calibrations, Resume Work, or Find Calibration Examples” on page 2-2
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In this section...

“Introducing the Models View” on page 2-16
“Importing Models” on page 2-19

“Adding New Function Models” on page 2-21
“Renaming and Editing Models” on page 2-22

Introducing the Models View

CAGE generally calibrates lookup tables by reference to models.

To import models, see “Import Models and Calibration Items Using CAGE Import Tool” on
page 2-5.

The Models view is a storage place for all the models in your session.

To view and edit the models in your session, select Models by clicking the button shown
in the Data Objects pane.

The Models view displays the following:

* Alist of all the models in the current project.

* The model connections. That is, which constants, variables, and models are inputs to
the selected model. You can use the View menu or the right-click context menu on the
graph to zoom in and out, zoom to fit, and reset.

* An image of the response surface of the selected model; you can select factors to
display. Use the View menu to choose between:
* No Constraint Display — Shows entire model surface.

* Show Constraint — Areas outside the boundary constraint model (if any) are
yellow.
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* Clip to Constraint — The surface is only shown within the boundary constraint
model.

View > Edit Input Set Points opens a dialog box where you can edit the set points of
your model variables. This setting alters the model display and also any calculations
involving the set points throughout CAGE. Altering this setting is the same as altering
the set points in the Variable Dictionary, see “Using Set Points in the Variable
Dictionary” on page 2-11.

Following is an example of the Models display.
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List of the current models

). CAGE Browser - tradeoffInit.cag 1 = IEIL&I

File Edit WView Model Tools Window Help B
D@ dE|X|# > &%y B
Processes Models ]
Name l Type l Ihputs l Law
<\ T0_Model MBC model SPK.L.N.AE
<\ NOXFLOW_Model MBC model SPK.L.N.AE
Feature
LN < | Ll
‘a L‘ Connections TG _Model I
XD =

Tradeoff

BV

-axis: IN 'I Yeaxis: IN vI
|

Model connections display Model display

4 ¥

)

The icons in the Models list indicate the type of model, as listed in the Type column. As
shown in the following illustration, a model can be a Model Browser statistical model, the
boundary of a model, the prediction error variance (PEV) of a model, a user-defined
function model, or a feature model (converted from a feature).
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-k Statz_model

ﬁ Boundary_maodel
ik Function_model
- PEY_model

%l Feature_model

You can use the “Model Properties” on page 2-33 dialog to switch a model output
between the model value and the boundary or PEV of the model. For function models see
“Adding New Function Models” on page 2-21. You can convert a feature to a model by
selecting Feature > Convert to Model.

Importing Models

CAGE enables you to calibrate lookup tables by referring to models constructed in the
Model Browser.

CAGE can only open Model-Based Calibration Toolbox model files. You can import models
from project files (.mat, . cag) and from exported model files (. exm).

Import Models From Project

You can use the CAGE Import Tool to select models to import from any Model-Based
Calibration Toolbox project file produced in CAGE or the Model Browser (.mat or . cag).
You can replace suitable models in your current CAGE project (note that Model Browser
models must have exactly the same input names as the CAGE model you are replacing).

See “Import Models and Calibration Items Using CAGE Import Tool” on page 2-5 for
instructions.

Import Exported Models File
To import models from a Model Browser exported models file (. exm):

Select File > Import > Model.

2 Afile browser dialog opens. Locate the desired file or files. You can select multiple
files. Examples can be found in matlab/toolbox/mbc/mbctraining. You can
select MBC Model (*.exm) to filter for .exm files.

Click to select the model file, then click Open .
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This opens the Model Import Wizard.

3  Select the models that you want to import by highlighting the models from the list, or
click Select All if you want every model.

4  Either:

* Select the check box Automatically assign/create inputs, then you can click
Finish.

* Alternatively to match inputs up manually, instead click Next .
5 Associate the model factors with the available inputs in your session.

For example, to associate the model factor spark with the variable spk in your

Session,
) Model Import Wizard =10 x|
Azzign Cage tems to use as the model inputs:
Model Input Azsigned Input Available Inputs
A X A spark
L XL XN
M XN XL
spark spark X A

iy

il o1

Cancel | = Back | [Ext= | Finizh |

a Highlight a Model Input, spark, in the list on the left and the corresponding
variable, spark, in the list of Available Inputs on the right.

b  Click the Assign Input button.
¢ Repeat a and b for all the model factors.
6 Click Finish to close the wizard and return to the Models view.

Note You can skip steps 5 and 6 by selecting the Automatically assign/create
inputs box at step 6.

You can now see a display of the model surface and the model connections (inputs).
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See Also

* “Setting Up Models” on page 2-16
* “Adding New Function Models” on page 2-21
* “Renaming and Editing Models” on page 2-22

Adding New Function Models

A function model is a model that is expressed algebraically. The function can be any
MATLAB function (including user-defined functions). The only restriction is that the
function must be vectorized, that is, take in column vectors and return a column vector of
the same size, as in this example:

function y = foo(x1l, x2)
y = x1 .* x2;

Once you have a function like this, you can create a function model applying it to any
models or variables in your session, like the following example.

foo (NOX, SPK)

For example, you might want to view the behavior of torque efficiency. So you create a
function model of torque efficiency = torque/peak torque.

To add a function model to your session,
1 Select File > New > Function Model.

This opens the Function Model Wizard.

2 In the dialog box, enter the formula for your function model. For example, enter
torque_efficiency=torque/peak torque.

3 Press Enter. CAGE checks that the function is recognized; if so, you can click Next.
If the function is incorrectly entered, you cannot click Next.

Select the models that you want to import by highlighting the models from the list.
5 Click Next.
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) Function Model ¥Wizard 3 =10/ ]

Select models:

lodel Mame Input= Dezcription
torgue_efficiency | peak_torgue, torgue torgueipeak_torgue

Select All | [~ Automstically assignicreste inputs

Cancel | = Back | Fimizh

6 You can select the check box to Automatically assign/create inputs and click
Finish to close the wizard and return you to the Models view, or you can click Next
and go to the next screen. Here you can manually associate the model factors with
the available inputs as follows:

a Highlight a Model Input, e.g., peak torque, in the list on the left and the
corresponding model, peak torque, in the Available Inputs list on the right.

b  Click the Assign input button.

Repeat a and b for all the model factors. Click Finish to close the wizard and return
you to the Models view.

You can now see a display of the model and its connections (inputs).
See Also

+ “Setting Up Models” on page 2-16

* “Importing Models” on page 2-19

* “Renaming and Editing Models” on page 2-22

Renaming and Editing Models

Renaming Models

To rename a model,
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1 Highlight the model that you want to rename.
2 Select Edit > Rename.
3 Enter the new name for the model and press Enter.

You can also rename the model by selecting a model and clicking the name, or pressing
F2.

Editing Model Inputs

You can adjust a model so that variables, formulas, or other models are the factors of the
model. For example, a model of torque depends on the spark angle. In place of the spark
angle variable, you can use a model of the maximum brake torque (MBT) as the spark
input.

To edit the inputs of a model,

1 Highlight the model.
2 Select Model > Edit Inputs.

This opens the Edit Inputs dialog box, shown.
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Highlight the model input

that you want to change. Highlight the new input.
) edit Inpute JR[=TE
Assign Cage tems to use as the model inputs:
Model Input \ Assigned Inpt Available Inputs
X spark
N X N X N
L X L 5 X L
ExXH X ECP X A
INT X ICP ‘ X ICP
X X ECP
Pt
o1
LMt
B i m 4
Cance| | = Back | Mext = | Finish
\
Click Assign Input. Click
Finish
3 Highlight the Model Input that you want to edit, in the list on the left.
4 Highlight the new input for that factor, in the Available Inputs list on the right.
5 Click the Assign Input button.
6 To close the dialog box, click Finish.

Note If you want to change the range of a variable in the session, change the range in

the variable dictionary. For more information, see “Using the Variable Menu” on page 2-
13.
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See Also

Related Examples
. “Set Up Calibrations, Resume Work, or Find Calibration Examples” on page 2-2
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Creating and Viewing Composite Models in CAGE

2-26

In this section...

“What Are Composite Models?” on page 2-26
“Importing from the Model Browser” on page 2-26
“Combining Existing CAGE Models” on page 2-29

“Viewing Composite Model Properties” on page 2-30

What Are Composite Models?

The composite model type allows you to combine a number of models to represent engine
responses under different operating modes. You can use the composite model in CAGE to
produce optimal calibrations for engines with multiple operating modes. Use composite
models for calibration problems where the goal is to fill a single table for all modes or to
fill a table for each mode, such as:

* Multi-injection diesel engine
* Inclusion of startup conditions in drive cycles
* Rich and stoich regions for engines

You can create a composite model using either of the following approaches:

* Importing into CAGE from the Model Browser and combining suitable responses from
different test plans

* Combining existing models in CAGE

The composite model comprises a collection of models with an extra mode input. The

mode input is an index into the list of models. The component models can have different

sets of inputs. CAGE uses symbol names and not signal names to determine inputs. Make
sure the symbol names match for the same inputs.

Importing from the Model Browser
To import and combine models in the Model Browser into a single composite model:

1 Open the Model Browser, and load the project you want to import composite models
from.
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2 In CAGE, select File > Import > Composite Model.

The Import Composite Model wizard appears.
3 Select the test plans from which you want to import models, and then click Next.

)} Import Composite Model g -0l x|

Test plan selection
Select test plans to creste composite models from.

Te=t plan Input=

i dcyl-onecp 5N LICPECP

£ scyrnivee 5,N,LICP,ECP

Total selected: 2 Total responses: 3

Inputs: 5L JCPECP

Cancel Next = Finigh

4  Select the responses to combine into a composite model. You can only select
responses that are common to all selected test plans. If you do not want a boundary
model included, clear the Include Boundary check box.

Note Using composite models can result in very large CAGE project files when you
combine point-by-point test plans with a large number of responses. To reduce the
size of project files, exclude boundary models from response models that you do not
want to use as optimization objectives.
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) Import Composite Model i ] B4

Response selection
Select responzes to impart. Response models must exist in each test plan to be
available for import.

Responzes Include Boundary
v k510 |
¥ o\ exTEmP [
¥\ RESIDFRAC v

Responzes selected: 3

Cancel < Back Fimigh

After making your selections, click Next.

5 Optional — Edit the name for your mode variable and the names of your operating
modes.

If you have point-by-point models, you can edit the input tolerances to merge close
operating points.
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) Import Composite Model o =10l x|

Composite Mode Information
Edit mode variable name and names for operating modes . If you have point-by-point
models, you can edit operating point tolerances to merge nearby operating points.

hode Yariable:  |CvlinderMode
hodes:
Mode | Name T

1| 4cyl-DNCP I
2| cyl-DNCP l

Operating point tolerances:

Input Tolerance

Cancel | = Back | P oNext= ! Finizh

6 Click Finish to import your new composite model.

Combining Existing CAGE Models

To combine existing CAGE models into a single composite model:
1 Select File > New > Composite Model (or use the toolbar button).

The New Composite Model wizard appears.

2 Select the models to combine into a composite model. The combined inputs are listed
for your selected models. You can combine additional models with existing composite
models as needed. Click Next.
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) New Composite Model

Cage model selection

=101 %]

Zelect cage models to create composite models from.

Model Rezponze Input=
|l BTQ BTQ S, N,LICPECP CylinderMode
|l EXTEMP EXTEMP S.N,LICPECP CylinderMode
O RESIDFRAC RESIDFRAC S N,LICPECP CylinderMode
'ﬂ knot4 knot ML ICPECP
o\ knot3
VBl SEleEEE - Select similan responses |
Input=; MWL ICP ECP
Cancel < Hack Next = Eini=h |

3 Optional — Edit the name for your mode variable and the names of your operating

modes.

If you have point-by-point models, you can edit the input tolerances to merge close

operating points.

4  Click Finish to create your new composite model.

Viewing Composite Model Properties

Select a composite model in the Models view, and select Model > Properties.

In the Composite Model Properties dialog box, click the Model tab to view information

about the model modes and inputs, as the following figure shows.
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) Composite Model Properties _' =10 x|

eneral | Inputz Mol Inf-:urmatiu:unl

Response narme: BTG
hode input: Cylindertode
Modes:
Mode | Mame Inputs Model
1| 4cyl-ONCP SN,LICPECP fi[S],g([M, L ICP,ECP}}
2| Beyl-DNVCP SNLICPECP fi[S],g([M, L ICP,ECP))

0K Cancel Help

For composite models created by combining point-by-point models, use the Composite
Model Properties dialog box to view which modes are available for each operating point,

as shown in the next figure.
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) Composite Model Properties : =10 x|

eneral | Inputz  Moclel Inf-:urmatiu:unl

Response name: B=FC
hode it hode
Modes:
Mode | Name Inputz
1| Low EGR MAINSO| FUELPRESS VGTPOS
2| High EGR MAINSO| FUELPRESS VGTPOS
Ciperating points:
SPEED BTQ | Mode
1800 Tra 1,2
1800 1163 1,2
1600 1550| 2
2200 12612
2200 632 1,2
2200 047|112
2200 126312
0K Cancel Help
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In this section...

“How To Open The Model Properties Dialog Box” on page 2-33
“Model Properties: General” on page 2-34

“Model Properties: Inputs” on page 2-35

“Model Properties: Model” on page 2-36

“Model Properties: Information” on page 2-37

How To Open The Model Properties Dialog Box

Select Model > Properties (or right-click) to view information about the selected model.
This opens the Model Properties dialog box where you can see the model type, definition,
inputs, availability of PEV and constraints, creation date, user name, and toolbox version
on the following tabs: General, Inputs, Model, and Information.
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Model Properties: General

) MBC Model Properties =10 x|

General I Inpts I Madel | Imfortration

) BTG

Type: MEC model
Mumber of inputs: 4
Constraints: Available

Prediction errar variance:  Awailable

Output saturation limits: | anf = | Inf =

Outtput ciuistity: % Model value
= Prediction error vatiahce of model

" Boundary constraint of model

Ok I Cancel | Help |

Here you can see the model type (such as MBC model or function model), the number of
inputs, and the availability of constraints and Prediction Error.

You can use the radio buttons to select the Output Quantity to be the

* Model Value
¢ Prediction error variance of model

* Boundary constraint of model

The Output Quantity is the model value used everywhere in CAGE (surface plots,
optimization objectives or constraints, tradeoff, etc.).

Choose one of the last two options if you want to use a model's prediction error variance

(PEV) or boundary as a switching input to a function model. You can duplicate the original
model, choose the PEV output quantity, and feed it in to your switch function.
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The option Boundary constraint of model evaluates only the boundary of the model
output. Any boundary information from the inputs is ignored (e.g., if inputs are also
models with boundary models).

You can enter values in the Output saturation limits edit boxes to set bounds on the
model output values.

Model Properties: Inputs

Model Properties x|

General  Inputs I tadel | Infarmation I

Immediate inputs:

Item | Tupe |
BT MBC model

X LOAD Yariable

x EMGSPEED W ariable

X A Wariable

X E aniable

Al varishle dependencies:

Item | Type |
x EMGSPEED Wariable
X LOAD ariable
X INTCAM Wariable
X EXHCAM aniable
XA ariable
X E Yariable

Ok I Cancel |

Here you can view all the immediate inputs and variable dependencies of your model. For
some models the two lists will be the same; in the example shown one of the inputs is
another model (MBT) so the variable dependencies list also shows the variable inputs for
that model. This information is shown graphically in the Connections pane.

2-35



2 Variables and Models

Model Properties: Model

Model Properties x|

General | Imputs Model I Infartration |

Model project file:  Unknown Load Madel |

Mol path: testgraZtg modelsTo

dodel defintion:

Model for TQ =
Coding

SPH: [-14.95 55.72] —» SPK: [-14.86,55.72]

L [020&1] =L [1,1]

M: [750,6500] = M: [-1.1]

A 17 B = A [-11]

E [0,12] = E [-11]
T[SPKLO([LH.AE]}

Local: f(1Z41%)

DatumType: Maximum

Global Models

knet 1L 0P, 4% E%: = s

hios=2) [
o of
Ok I Cancel |

Here you can view the model definition, the project file, and the model path. Function
model definitions are shown here. For MBC models the model definition (showing the
parameters and coefficients of the model formula) is the same information you would see
in the Model Browser part of the toolbox when selecting View > Model Definition.
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Model Properties: Information

) MBC Model Properties _|o] x|
Generall Inputs I Model  Infarmation I
Field Wallue
Lzer Unknioswt
Date 27-Sep-2005
WEC Yersion 24.3
Ok I Cancel | Help |

Here you can see the user name associated with the model, the date of creation and the
version number of the Model-Based Calibration Toolbox product used to create the model.
If you added any comments to the export information in the Model Browser Export

Models dialog this information also appears here.

2-37



2 Variables and Models

Specifying Locations of Files

2-38

You can specify preferred locations of project and data files, using File > Preferences.
Project files have the file extension . cag and store entire CAGE sessions.

Data files are the files that form part of the CAGE session. For example, the following is a
list of some of the data files used in CAGE:

¢ Simulink models

* Experimental data (.x1s, .csv, or .mat)
* Variable dictionaries (. xm1l)

e Models (.exm)

To specify preferred locations for files,

1 Select File > Preferences. This opens the dialog box shown.

). CAGE Preferences o ] |

File Locations I IJ=zer Information I Optimization I

Projects: I EI
Data files: | g
Model files: | E”'l
Strategy files: I g

QK I Cancel |

2 Enter the directory or directories where your CAGE files are stored. Alternatively,

click 2| to browse for a directory. You can specify directories for projects, data files,
model files and strategy files.

3 Click OK.



Tables

This section includes the following topics:

» “Setting Up Tables” on page 3-2

* “Creating Tables from a Model” on page 3-4

* “Adding, Duplicating and Deleting Tables” on page 3-9
+ “Editing Tables” on page 3-12

* “Filling a Single Table From a Model” on page 3-20

* “Using the History Display” on page 3-23

* “Calibration Manager” on page 3-27

* “Table Properties” on page 3-32

* “Table Normalizers” on page 3-39

* “Inverting a Table” on page 3-47

* “Importing and Exporting Calibrations” on page 3-52
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Setting Up Tables

Select the Tables view by clicking the Tables button. It opens automatically if you add a
table using the File > New > Table menu items.

Tables

The Tables view lists all the tables and normalizers in the current CAGE session.

Here you can add or delete tables and normalizers, and you can calibrate them manually.
Once you have added new tables you can also fill them using experimental data by going
to the Data Sets view.

The next sections cover:

* “Creating Tables from a Model” on page 3-4

Use this wizard to quickly create a set of tables with the same axes for all the inputs of
a model, and the model response, and any other responses that share the same inputs.
You can choose which of these tables to create, and select the values for the axes (or

normalizers) that all tables will share. You can also add all the new tables to a tradeoff.

* “Adding, Duplicating and Deleting Tables” on page 3-9
How to create tables manually, and duplicate and delete tables.

+ “Editing Tables” on page 3-12

Information on using the table view functionality once you have added tables to your
project

* “Filling a Single Table From a Model” on page 3-20
Use this wizard to fill a table with values from a model evaluated at the table
breakpoints.

* “Using the History Display” on page 3-23

You can use the History display (from any other table or normalizer view in CAGE) to
view and reverse changes and revert to previous versions of your tables.
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* “Calibration Manager” on page 3-27

Use the Calibration Manager to set up tables manually or from calibration files.
* “About Normalizers” on page 3-39

Normalizers are the axes or breakpoints of tables.
* “Importing and Exporting Calibrations” on page 3-52

How to get table calibration information into and out of CAGE in various formats.

See also
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Creating Tables from a Model

You can access the table creation wizard by menu or toolbar, from any view in CAGE. The
wizard helps you quickly create a set of tables with the same axes for all the inputs of a
model, and the model response, and any other responses that share the same inputs. You
can choose which of these tables to create, and select the values for the axes (or
normalizers) that all tables will share. You can also add all the new tables to a tradeoff.

This wizard can be useful when creating tables for an optimization, to use when filling
tables with optimization results, and for investigating results in the tradeoff views.

To create tables (and optionally a tradeoff) from a model,
1 Select Tools > Create Tables From Model (or use the toolbar button).

The Create Tables From Model Wizard appears.

2 Select a model to base the new tables on.
If you are viewing a model, then the wizard automatically selects the current model.
If you are viewing an optimization or an optimization output node, then the wizard

automatically selects the model in the first objective. You can use this to create tables
for the selected optimization.

If you have selected a point-by-point model, you can optionally select the check box to
Create operating point data set.

3-4



Creating Tables from a Model

3

Model
Select a model to base the new tables on.

Model Type ariable Inputs
BENOX Point-by-point mo... | MAINSOI, FUELPRESS, WGT...
AFR Point-by-point mo... | MAINSOI, FUELPRESS, WGT...
EGRMF Point-by-point mo... | MAINSOI, FUELPRESS, WGT...
PEAKPRESS Point-by-point mo... | MAINSOI, FUELPRESS, WGT...
VGTSPEED Point-by-point mo... | MAINSOI, FUELPRESS, WGT...
MAINFUEL Point-by-point mo... | MAINSOI, FUELPRESS, WGT...

E| Create operating point data set

’ Cancel H < Back H MNext = H Finizh |

Click Next.

Select table axes input variables and set up the normalizers to use for the new tables.
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B Create Tables M@lﬂu

Table Inputs

Select the table inputs and set up the normalizers to use for all the new tables.

|:| Use model operating points

Y-axig input: SPEED - _' X-axiz input: BTC - _'
MNormalizer: <Mew> =i Mormalizer: <MNew:> w1
Table rows: Fi : Table columns: 7 : 1
SPEED normalizer: BTQ normalizer:
Input Cutput Input Cutput
1600 0f = 0 0 =~
1700 1 266 667 1
1200 2= 533.333 2| =
1900 3 200 3
2000 4 1066.667 4
2100 gl T 1333.333 gl ¥
’ Cancel ] ’ < Back ] ’ MWext = ] Finizh

If you have selected a point-by-point model, CAGE automatically selects the check
box to Use model operating points for the table normalizers. You can clear the
check box if you want to select different normalizers.

* Select inputs. For the X- and Y-axis inputs, you can select any input variable for
your selected model, or the model response.

* Select normalizers. You can select existing normalizers in your project or create
new ones. If creating new normalizers you can edit the numbers of Table rows
and Table columns, and edit values in the Input columns. By default CAGE
initializes normalizers with equally-spaced points across variable ranges, unless
you select the response model as a table input.

If you choose a response model input, you must specify the breakpoints. Click the
button to Edit breakpoints, then enter a number of points and the range to
space the breakpoints over. If you do not do this, model inputs are spaced over
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0-1, because CAGE cannot determine the range automatically as happens with
variables. After you create your tables with a model input, in your Variable

Dictionary you can view a new variable named modelname input with the range
you specified. CAGE uses this input variable to match to model names when you

fill tables from optimization results. See “Table Filling When Optimization

Operating Point Inputs Differ from Table Inputs” on page 7-13.

Click Next.

Select check boxes to specify which variables and responses to create tables for. You

can create tables for other responses with exactly the same inputs as the primary
model (and the same operating points for point-by-point models).

By default you will also create a tradeoff containing all of the new tables. The tradeoff
can be very useful for investigating optimization results. See “Performing a Tradeoff

Calibration” on page 5-2. If you do not want to create the tradeoff, clear the check

box.

) Create Tables from Model
Tables and Tradeoff

[

=101 x|

Select the tems to create tables for. Tahles are intislized with values from their

aszociated tem.

ltem Takle Mame Takle Bounds
W xs %5 Table [0,50]

V¥ xicp % |CP_Table [-5,50]

V¥ x ECcP % ECP_Table [-5,50]

vV -dBT0 % 5TQ_Table [-Inf Inf]

¥ % ExTEMP 1% EXTEMP_Takle [Inf Inf]

¥ <\ RESIDFRAC % RESIDFRAC_Table [-Inf Inf]

¥ Create a tradeoff containing all the tables

Cancel = Back

Finish
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Click Finish to create the tables and tradeoff.

You see a dialog listing all the items you have created, and you can choose which (if any)
of the items to view next.
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Adding, Duplicating and Deleting Tables

In this section...

“Adding Tables” on page 3-9
“Duplicating Tables” on page 3-10

“Deleting Tables” on page 3-10

Adding Tables

To quickly create tables from a model, use the table creation wizard. See “Creating Tables
from a Model” on page 3-4.

Otherwise you can add a table using the File > New menu items, as described below.

To add tables, you can first select the Tables view, or CAGE automatically switches to this
view if you add a table using the File > New menu items.

The Tables view lists all the tables and normalizers in the current CAGE session.
To add a table to a session,
1 Decide whether you want to add a one- or a two-dimensional table.

For example if you want to add a modifier table to account for the variation in
exhaust gas recirculation, add a one-dimensional table (which has one input). If,
however, you want to add a table with speed and load as its normalizer inputs, then
add a two-dimensional table.

2 Select File > New > 1D Table or File > New > 2D Table as appropriate.

Adding new tables automatically switches you to the Tables view.

3 In the Table Setup dialog you can enter the table name, number of rows and columns
and initial value, and select the input variable (or variables) from the drop-down
menus.
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4  Click OK to add the new table. CAGE automatically initializes the normalizers of the
table by spacing the breakpoints evenly over the ranges of the selected input
variables.

Note You can also select Tools > Calibration Manager to change the size of a
table. For information, see “Setting Up Tables” on page 3-2.

You can rename tables by first selecting the table, then

e Press F2, or
* Select Edit > Rename.

You can manually calibrate by entering values in any table. You can also fill tables using
experimental data or optimization output by going to the Data Sets view; see “Fill Tables
from Data”, “Compare Calibrations To Data”, and “Filling Tables from Optimization
Results” on page 7-9.

Duplicating Tables

To copy a table or a normalizer from a session,

1  Select the Tables view.
2 Highlight the required table or normalizer.

3 Select Edit > Duplicate table name ( table name' is the currently selected table).

See also “Import Models and Calibration Items Using CAGE Import Tool” on page 2-5 to
add existing tables from other CAGE project files.

Deleting Tables

When you are calibrating a collection of tables using either Feature or Tradeoff
calibrations, you cannot easily delete tables without affecting the entire calibration. When
deleting items, you must delete from the highest level down. For example, you cannot
delete a table that is part of a feature; you must delete the feature first.

To delete a table or a normalizer from a session,

1 Select Tables view.
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2 Highlight the required table or normalizer.

Click ﬂ or press Delete; or select Edit > Delete table name ("table name' is the
currently selected table).
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Editing Tables

3-12

In this section...

“About CAGE Tables” on page 3-12

“Viewing and Editing a Table” on page 3-13

“Filling a Table From a Model” on page 3-14

“Filling a Table by Extrapolation” on page 3-15
“Locking Table Values” on page 3-16

“Editing the Graph of the Table” on page 3-17
“Arithmetic Operations On Table Values” on page 3-17

About CAGE Tables

When you select a table in the tree (under feature or tables), you see the Table view.

Note For feature calibration (filling and optimizing table values by comparing a strategy
or collection of tables with a model), see “About Feature Calibrations” on page 4-2. To

fill a single table with model values, see “Filling a Single Table From a Model” on page 3-
20.

In CAGE, a table is defined to be either a one-dimensional or a two-dimensional lookup

table. One-dimensional tables are sometimes known as characteristic lines or functions.
Two-dimensional tables are also known as characteristic maps or tables. CAGE regards
them both as similar objects.

Each lookup table has either one or two axes associated with it. These axes are
normalizers. See “About Normalizers” on page 3-39.

For example, a simple MBT feature has two tables:

* A two-dimensional table with speed and relative air charge as its normalizers
* A one-dimensional table with AFR as its normalizer
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Viewing and Editing a Table

BB CAGE Browse: - Gasolineoptimizaion.cag oo =
File Edit View Table Tools Window Help
¥ roCA
DA% WP 7|k F|EEEEFEF |
Processes Tables L Table Details
G line_optimizat Table MBT_Start
L{ HMNormalizer Size 10x10
-4/ LNormalizer Bounds [0,50]
Fesature |-l MBT_Base ¥ Normalizer... |LNormalizer(L)
T Il--j-@ MBT_Intake X Mormalizer ...|NNormalizer(N)
LN H-dg MBT_Exhaust Last Modified |22-May-2007 11:05:57

A

Trz

- A MBT_Dual

- 1% MBT_Start
0% 5 Table

-1 ECP_Table
-1 ICP_Table
0-1% BTQ_Table
A% EXTEMP_Table

Last Change: Extrapolated

View History...

-4 RESIDFRAC_Te Used in

tem

|Tyne |

Y3 MBT_Start_Feature

| Feature |

o

Data Objects
S0 —
40 —
30—
20— 0.
0.z

[E—

a00

1000 1500 2pop

2500 zg00 3500

M

4000 4500 sp0p

In the Table view:

1 To edit a value in the table, double-click the cell, then enter a value. You can right-
click to Copy or Paste values. You can also edit table values using the table graph.
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To apply arithmetic operations to selected cell values or whole tables, see “Filling a
Table by Extrapolation” on page 3-15, and “Arithmetic Operations On Table Values”
on page 3-17.

You can lock cell values. See “Locking Table Values” on page 3-16.

2 The 2D table is shaded to help you relate the table values to surface plots. Table cells
background color matches the corresponding surface plot color. Toggle table shading
with View > Shade Table (also in the plot context menu).

3 The graph of the 2D table pane displays a surface plot of the table values. The default
plot orientation is Y/X to match engineering convention. To match the orientation of
the numerical table, transpose the plot axes by right-clicking and selecting 2D
Orientation X/Y. Switch back with 2D Orientation Y/X (also in the View menu).
You can switch mouse mode between rotating and editing the table surface, see
“Editing the Graph of the Table” on page 3-17.

4 View the table size, bounds, normalizers, inputs and last change history in the Table
Details pane. To view and revert table changes, click View History (also in the View
menu). Any locked cells and extrapolation mask cells are saved with table history. For
details, see “Using the History Display” on page 3-23.

5 Under Table Details, the Used in pane displays what CAGE items use the current
table (e.g., optimizations, tradeoffs, features). Double-click items in the list to change
view to those items.

The table displays the values of your lookup table and displays the breakpoints of the
normalizers.

The table breakpoint values are not necessarily identical to the normalizer breakpoints.
When you create a table the breakpoint values are the same as the normalizer values. If
you delete breakpoints from the normalizers the table size does not change, so the table
column and row breakpoint values are interpolated between the remaining normalizer
breakpoints.

Note You can revert table changes in the History display. Click View History in the Table
Details pane. See “Using the History Display” on page 3-23.

Filling a Table From a Model

To fill a single table with model values, see “Filling a Single Table From a Model” on page
3-20.
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You can also select Table > Convert to Model to convert a table directly to a model.

Filling a Table by Extrapolation

Filling a table by extrapolation fills the table with values based on the values already
placed in the extrapolation mask.

To fill a table by extrapolating over a preselected mask, click ““ or select Table >
Extrapolate.

This extrapolation does one of the following:

» If the extrapolation mask has points on a line, then CAGE performs linear
extrapolation on points projected on to that line. The simplest case of this is when you
try to fill a 2D table using data from a single row or column.

» If the extrapolation mask has points on a plane, then CAGE uses the plane for
extrapolation. The simplest case of this is when the mask has three points and the
points are not on a line.

» If the extrapolation mask has four or more ordered cells in a grid, then CAGE uses
bilinear extrapolation.

» If the extrapolation mask has four or more cells not on a grid, CAGE uses a thin plate
spline (a type of radial basis function) to extrapolate the table values.

To ensure that tables extrapolate smoothly to locked cell values, CAGE includes the
locked cells in the extrapolation even if the cells are not part of the extrapolation mask.

Using the Extrapolation Mask
The extrapolation mask defines a set of cells that form the basis of any extrapolation.

For example, a speed-load (or relative air charge) table has values in the following ranges
that you consider to be accurate:

* Speed 3000 to 5000 rpm
* Load 0.4 t0 0.6

You can define an extrapolation mask to include all the cells in these ranges. You can then
fill the rest of your table based on these values.

To add or remove a cell from the extrapolation mask,
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Right-click the table.

Select Add To Extrapolation Mask or Remove From Extrapolation Mask from
the menu.

Alternatively, select Copy Mask from to copy a mask from another table.

Cells included in the extrapolation mask are colored blue.

Cells that are locked and in the extrapolation mask are blue and have a padlock icon.

Use the Table menu for these options:

* Extrapolation Mask (the following items are also in the table context menu)

Add Selection — Adds selected cells to the extrapolation mask.

Remove Selection — Removes selected cells from the extrapolation mask.

Clear Mask — This ensures that none of the cells are in the extrapolation mask.
Copy Mask from — Copy a mask from another table.

Convert Mask to Locks — Convert mask cells to locked cells.

Generate From PEV — Generate extrapolation mask depending on the value of
prediction error (PEV). A dialog opens where you can specify the threshold value of
PEV below which you want to include cells in the mask. The dialog contains

information about the range and mean of prediction error for the model to help you
select a threshold.

Generate From Boundary Model — Generate extrapolation mask to include only
cells within the boundary model.

* Extrapolate — Extrapolates values from the cells in the extrapolation mask to fill the
whole table. Also in the toolbar.

All the toolbar button functions are also found in the table menu: Initialize, Fill,
Extrapolate, Fill by Inversion. For information on these see “Optimize Table Values”
on page 4-24.

Locking Table Values

When you are satisfied with an area of the table, you might want to lock the cell values, to
ensure that those values do not change.
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To lock or unlock a cell value, right-click the cell and select from the menu. Locked cells
have a padlock icon in the display. You can also lock an entire table or copy locks from
other tables.

Use the Table menu for these options:

Table Cell Locks The following items are also in the table context menu:

* Lock Selection — Locks the selected cells and a padlock icon appears.
* TUnlock Selection — Unlocks the selected cells.

* Lock Entire Table — Locks every cell in the current table.

* Clear All Locks — Unlocks all cells in the table.

* Copy Locks from — Copy locks from another table.

* Convert Locks to Mask — Convert locked cells to mask cells.

Properties. This opens the Table Properties dialog where you can set the precision
type of the table data. See “Table Properties” on page 3-32.

Editing the Graph of the Table

The table view displays both the table values and a graph of the table. This gives a useful
display of the table's behavior.

For 1D tables, you can edit the table from the plot by clicking and dragging.

For 2D tables, in the default mode, you can rotate the graph of the table by clicking
and dragging the axes.

Select View > Edit Table Surface to alter values in the 2D table by clicking and
dragging vertically any point. In this mode, when you click a point, a blue line
indicates the selected point in the table. To return to table rotation mode without
altering table values, select View > Rotate Table Surface.

Note When editing the table surface you may drag a value unintentionally - to return
to previous table values, use the History display. Click View History in the Table
Details pane. See “Using the History Display” on page 3-23.

Arithmetic Operations On Table Values

The Table menu item Adjust Cell Values (also a right-click context menu item) opens a
dialog where you can specify an arithmetic operation to apply to either the whole table or
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only the cells currently selected. Arguments to operations can be numeric (plus 10) or
percentages (minus 5%). You can set the selected cells to a value or to the mean. You can
also apply user-defined functions.

1

Right-click the table or select Table > Adjust Cell Values. The Adjust Cell Values
dialog box appears.

Select the operation to apply from the list - plus, minus, times, divide, set to value, set
to mean, or custom operation. Use the custom operation to specify your own function
in a file.

Use the Value edit box to enter an argument. All operators accept a numeric
argument (e.g. operator = plus, value = 10). You can also enter a percentage for the
operators plus, minus, and set to value (e.g. ‘minus' "1%').

Select the radio buttons to apply the operation to either the whole table or only the
cells currently selected, and click OK.

You can use the custom operation option to apply user-defined functions.

The custom function is called in this way:

newvalues = customfcn( currentvalue, selectedregion )

Where currentvalue is the matrix of table values and selectedregion is a logical
matrix the same size as the table, that is "true" where a cell is selected by the user, and
false otherwise.

The newvalues matrix should be the same size as currentvalue, and these numbers
are put straight into the table.

EXAMPLES:

function table = addOne( table, region )
table(region) = table(region) + 1;
return;

function table = randomtable( table, region )
table( region ) = rand( nnz( region ), 1 );

function table = saturate( table, region )
maxValueAllowed = 150;

table( region & table>maxValueAllowed ) = maxValueAllowed;
minValueAllowed = 100;

table( region & table<minValueAllowed )

minValueAllowed ;

return
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As an illustration, to use the saturate example:

Save the function text in a file named saturate.m.
Click and drag to select a region of cells in a CAGE table.
Right-click and select Adjust Cell Values.

In the dialog:

A W N -

* Select custom operation from the Operation list

* Enter saturate in the Value edit box (the first function of that name found on
the MATLAB path will be used), or click the browse button to locate the file.

* Select the radio button to Apply to selected table cells, and click OK.

The selected table cells are saturated between the ranges specified in the function file
(between 100-150).
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Filling a Single Table From a Model

To fill a table with values from a model evaluated at the table breakpoints:

1 Open the Table Fill Wizard.

* With the table selected in the Tables view, select Table > Fill.

Alternatively, click the Fill toolbar button ( < ).
The Table Fill Wizard opens.

) Table Fill Wizard for MBT_Table i [=] ]

Choose Models and Links
et the model to fill the tables frot and optionally st & constraint model and link inputs to other tems from the project.

Model: =none= Select Maodel...

L

Caonstrairt: =none=

Select Constraint...l Deselect Constraint
Sariakles: Links:
“ariable Linked ta Link | Mame Type ¢
N ha10 Mol =]
L Unlirke | -\ EXTEMP Madel
dhMET Madel
4P.-1EITw'rthSpeedLoad... Maclel
ﬂ RESIDFRAC Malel
ﬂ RESIDFRACatMBT Madlel
i ExHCAM Table
T e ana T ﬂ
Cancel | = Back | Mext = | Finish |

2 Select a model by clicking the Select Model button.

The Select Model dialog box opens.
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) Select Model o [l

Select & model far the festure:
-\ EBTQ

-\ EXTEMP

~f\ RESIDFRAC

-k MBT

4 RESIDFRA CatMBT

MBTwithSpeedl oadBoundary

OK I Cancel | Help

Select the model you want to fill the table with, and click OK. You return to the Table
Fill Wizard.

Note The subsequent screens of the Table Fill Wizard are identical to steps 2-4 of
the Feature Fill Wizard. See “Filling and Optimizing Table Values” on page 4-24 for
details. This following procedure describes small differences in usage for the Table
Fill Wizard.

(Optional) Change constraint, create links, or both. For table fill, you cannot use
gradient constraints.

Click Next.

(Optional) Change variable values from the defaults. By default the table's normalizer
breakpoints and the set points of other variables are selected, so the number of grid
points equals the number of table cells.

Click Next.

Click the Fill Tables button. The Progress graph shows the change in RMSE as the
optimization progresses.

* Smoothing does not affect table filling (no gradient constraints with Table Fill),
and the surface plot check boxes are not enabled.
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* The table Bounds (specified in the Table Properties) constrain table values. The
toolbox clears any previous extrapolation mask and automatically extrapolates the
new table. When using the Feature Fill Wizard, you can control these options on
the first screen of the wizard. With the Table Fill Wizard, you cannot control these
options as you start on screen 2.

Click Finish to exit the wizard.

After you exit the wizard, the plots with selected check boxes appear. You can then view
your filled table values and surface plot in the Tables view of the CAGE Browser.
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Using the History Display

In this section...

“Introducing the History Display” on page 3-23
“Resetting to Previous Table Versions” on page 3-24
“Comparing Versions” on page 3-25

Introducing the History Display

The History display enables you to view the history of any table or normalizer in a CAGE
session.

The History display lets you

* Revert to previous versions of tables and normalizers (See “Resetting to Previous
Table Versions” on page 3-24). Any locked cells and extrapolation mask cells are
saved with table history. Reverting to a version includes reverting to that version's
mask and locks (except any table history from release earlier than R2014a.

» Compare different versions of tables and normalizers (See “Comparing Versions” on
page 3-25.)

You can view the History display of a table or normalizer by selecting View > History, or
clicking View History in the Table Details pane.
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B History for 5_Table E=8(E=ES
Version | Comment / Action Date and Time
3| Extrapolated 28-Nov-2013 16:44:46
2| Values filled from optimization output Sum_BTQ_Optimization_Output ... | 30-Apr-2009 13:26:01
1| Table for "5 30-Apr-2009 11:55:38
Clear
[7] Reset normalizer
N 1'L L 0.1 02 0.3 04 0.5 06 0.7 03 0.9

500 50| 50 43.342 32.187] 22 027 14.352] 3.736 4078 0
1000 50 50 42778 30.019) 19.344] 13.031 B8.356 5184 1.393
1500 50| 50 41.521 26.556 17.573] 13.37 10.3587| 7.355 3.891
2000 50 50 37 955 20313 20754 16.188) 13.318| 10.455] 7.052
2500 50| 50 45834 33.352 21.953) 18.844] 16.342] 13.904/ 10.481
3000 50 50 47 556 35.499 27 272 21643 18.652] 17.135] 13.567|
3500 50| 50 41.359) 36.953) 31.989| 25.381 21.795] 19.327] 15.834]
4000 50 50 46 355 40,014 35531 20,021 24 804 21693 17 604
4500 50| 50 50| 44142 38.539| 32.176] 27.253] 23.548 15.001
5000 50 50 50 45352 40 657 34 287 23 749 24 085 19 674

4 [ | P

[ Clozse ” Help l

The upper pane of the History display lists all the versions of the highlighted object.

The lower pane displays the normalizer or table of the highlighted version.

Resetting to Previous Table Versions

To reset the normalizer or table to a previous version, select View > History to open the
History display.

1 Highlight the previous version that you want to revert to.

2 Tables are independent of normalizers, so if you reset a table to a previous version
you must also reset the normalizers to that version (if they have changed). To reset
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normalizers to match the reverted table version, select the Reset normalizers check
box.

Click Reset.
4 Click Close to see the updated table view.
To remove previous versions of the object or comments,
1 Highlight the version that you want to remove.
2  Click Remove.
Click Clear to remove all table history.
Adding and Editing Comments About Versions

To add comments,

1 Click Add.
2 In the dialog box enter your comment.
3 Click OK. A new History set point is added when you add a comment.

To edit comments,

1 Select the comment that you want to edit.
2 (Click Edit comment.

3 In the dialog box, edit the comment.

4 Click OK.

Comparing Versions

To compare two different versions of a normalizer or table, highlight the two versions
using Ctrl+click. Note the following:

* The lower pane shows the difference between the later and the earlier versions.

» Cells that have no entries have no difference.

* Cells that have red entries have a higher value in the later version.

» Cells that have blue entries have a lower value in the earlier version.
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Version | Comment ! Action Date and Time
3 Extrapolated 20-Mowv-2013 16:44:46
2| Values filled from optimization output Sum_BTQ_Optimization_Output ... | 30-Apr-2009 13.28:

1| Table for 'S’ 30-Apr-2009 11:55:38

Reset normalizer

N\ L 0.1 0.2 03 0.4 05 06 07 03 08

500 -1.792 -0.365

1000 -0.306 2812 -0.491 -1.36
1500 -0.609) -2.996 -0.718 -1.876
2000 2341 -1.135 -2 686
2500 -3.648 -1,997| -3.88
3000 2346 0.087| -0.788 -0.087| -0.534 -3.429 5163
3500 5752 1.432 -1.457| -0.7 -1.77 -4.093 -5.918
4000 2961 1.191 -1.688 —1.424 2649 4317 -£.309
4500 -0.308 -1.855 -1,947| -2.932 -4.91 -6.086
5000 -3.082 —1.444 -1 659 2317 -3.637| 5,169

' m | 3
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Calibration Manager

In this section...

“Introducing the Calibration Manager” on page 3-27
“Setting Up Tables from a Calibration File” on page 3-27
“Setting Up Tables Manually” on page 3-30

“Copying Table Data from Other Sources” on page 3-30

Introducing the Calibration Manager

To change the size of tables in CAGE, you use the Calibration Manager dialog box. Open
this tool by selecting a table, then selecting Tools > Calibration Manager or by clicking

the Calibration Manager button ﬂ on the toolbar.

You can either set up your tables manually or from a calibration file. You can also copy
table data from other sources.

You can enter the required inputs, number of rows and columns and an initial value for
table cells when you add a new table. Use the File > New menu items to make new
tables. See “Adding, Duplicating and Deleting Tables” on page 3-9. You can use the
Calibration Manager to change the sizes, values and precision of tables.

Setting Up Tables from a Calibration File

Setting up tables with a calibration file involves two steps:

* “Importing Calibration Files into the Calibration Manager” on page 3-27

* “Importing Calibration File Values into a Table” on page 3-28
Importing Calibration Files into the Calibration Manager

You can import calibration files from the CAGE Browser by selecting Select File >
Import > Calibration . Your selected file opens in the Calibration Manager.

You can also open the Calibration Manager and import calibration files from within the
Calibration Manager window by using the following procedure:
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1

2

In the Calibration Manager, open the file by clicking the Open Calibration File button
ﬂ in the toolbar.

The Import Calibration Data dialog box opens.
Browse to the calibration file, select it, and click Open.

In the Calibration Manager, review the files you have imported:

Your imported calibration file items appear in the Calibration File Contents pane at
the top right.

The tables, normalizers, and other items in your project appear on the left in the
Project Calibration Items pane.

The values of the currently selected item appear in the lower pane, so you can inspect
the values in your calibration file and current project tables. Because the import
process filters out empty data, any empty variables will not appear.

Note You can find an example calibration file, tutorialcal.mat, in the mbctraining
folder.

Importing Calibration File Values into a Table

To import the data in your calibration file into a table in your project:

1

Click to select both the table in the Calibration File Contents pane and the table in
the Project Calibration Items pane with which you want to associate it.

From Selected Calibration File Item”). The values in the calibration file load into the
table. You can inspect the values in the lower pane by clicking to select the table in
the Project Calibration Items pane.

To associate all the items listed in the Project Calibration Items pane with items
that have the same names listed in the Calibration File Contents pane, click the

Auto button &I (with tool tip “Set Up All Matching Calibration File Items”).

To find particular names in a large calibration file, you can click the Calibration File
Contents list and type the first few letters of the item that you want to find. The
cursor moves to the letters specified as you type.



Calibration Manager

3

Check the display of your table, and then click Close.

When you close the Calibration Manager you can view your updated tables in CAGE. If
you want to compare or revert to an earlier version of your table, select View > History.
See “Using the History Display” on page 3-23.

The following figure shows the Calibration Manager.

Manually
set up the
table or
normalizer.

Select the axis or table
to be calibrated.

DS @® o

?

Association buttons

Contents of
calibration file

X|

Calibration File Contents

i

3 J A Name Size
i i{' NNormaliser - \
4/ LNomaliser j EGSE
Z - 7 FS Calibration File Information
Rowys: I 10 El Value: I 65 _;_' R U —
= - Calibration file
Colum.. I 7 E' Apply Total number of tems
Precision: |IEEE Double :z:z:: 2: 12[0) ::ﬁ:zz
Precision Ediit Precision... 5
Mumber of scalar tems
Project item: New_2D_Table
LN 500 1000 1500 2000 2500 3000
0.1 11.877 13675 15.092 15.067 14 13.445 -
0.2 23.277 25.356 27 .264 2712 25463 24 971
0.3 34519 36.827 39.377 39188 37181 36675
0.4 45578 47 954 51.103 516837 4945 43.611
05 56.592 58.551 61.514 62 667 61.08 60.425
0.6 67.9438 69679 71.413 70922 69.04 71172
07 78.313 79.754 81.558 8016 75.789 80.902 =
< >
(10 x 7) 2D table Close |

Check the display of your table
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Note You can add additional file formats to configure CAGE to work with your processes.

Contact MathWorks for details about adding file formats at https://
www . mathworks.com/products/mbc/.

Setting Up Tables Manually

1  Select the normalizer or table to set up from the list on the left.

2  Enter the number of rows and columns in the edit boxes on the left and select initial
values for each cell in the table.

3 Click Apply.

Rows: mil e I ES%I
Colurn.. [ 7 2] Apply |

Note When initializing tables for a feature calibration (comparing a model to a
strategy) you should think about your strategy. CAGE cannot fill those tables if you
try to divide by zero. Modifier tables should be initialized with a value of 1 for all cells
if they are multipliers, and a value of 0 if they are to be added to other tables. See
“Initializing Table Values” on page 4-36.

4 Check the display of your table, then click Close.

Copying Table Data from Other Sources

You can paste table values from other applications, such as Excel, by copying the array in

the other application and clicking Paste B in the Calibration Manager:

1 Open the desired file and copy the array that you want to import.
In the Calibration Manager dialog box, click Paste & .

You can also set up a table from a text file:

Click Set Up From ASCII File %% in the toolbar.
2 Select the desired file, then click Open.


https://www.mathworks.com/products/mbc/
https://www.mathworks.com/products/mbc/

Calibration Manager

Note If the size of the table is different from the file that you are copying, CAGE
changes the size of the table in the session.
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Table
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Properties

In this section...

“Opening the Table Properties Dialog Box” on page 3-32
“Table Properties: General Tab” on page 3-32
“Table Properties: Table Values Precision Tab” on page 3-32

“Table Properties: Inputs Tab” on page 3-38

Opening the Table Properties Dialog Box

In the Tables view, to reach the Table Properties dialog,

* Right-click a table node and select Properties.
* Select a table, then select Table > Properties

Table Properties: General Tab
The selected table name, type and number of inputs are displayed.

Use the Table value limits edit boxes to set a range of values restricting the values in
the table.

When you are done, click OK.

Table Properties: Table Values Precision Tab

The Table Values Precision tab contains the same settings as the Edit Precision dialog box
(reached by clicking the Edit Precision button in the Calibration Manager dialog box).

These settings allows you to edit the precision of the number in selected tables and
normalizers according to the way tables are implemented in the electronic control unit
(ECU). The ECU designer chooses the type of precision for each element to make best use
of available memory or processor power.

To edit the precision of a table or normalizer,

1 Clear the Read-only check box to make the precision writable.




Table Properties

2 Select the Precision type you require for the table:

* Floating Point (See “Floating-Point Precision” on page 3-33.)

* Polynomial Ratio, Fixed Point (See “Polynomial Ratio, Fixed Point” on
page 3-34.)

* Lookup Table, Fixed Point (See “Lookup Table, Fixed Point” on page 3-37.)

Floating-Point Precision

The advantage of using floating-point precision is the large range of numbers that you can
use, but that makes the computation slower.

There are three types of floating-point precision that you can choose from:

* IEEE double precision (64 bit)
+ IEEE single precision (32 bit)
* Custom precision

If you choose Custom precision, you must specify the following:

e Number of mantissa bits
* Number of exponent bits
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.} 2D Table Properties =10l x|

General  Table Yalues Precision I ImpLts |

Precision type: IFIDating Poirt j I Read-only

{* |EEE double precision
™ IEEE single precision

™ Custom precision

[Hurmket of bits far mantissa: I 52 il
[dumber of/ bits far exponent: I 11 il

Ok I Cancel =

See Also

* For more information on IEEE double precision in MATLAB, see Moler, C., Floating
Points: IEEE Standard Unifies Arithmetic Model, The MathWorks Company
Newsletter, 1996.

Polynomial Ratio, Fixed Point

The advantage of using fixed-point precision is the reduction in computation needed for
such numbers. However, it restricts the numbers available to the user.

For example, the polynomial ratio is of the form (see the ratio shown)
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Table Properties

,_50x+0
Y= 0+285

To edit the polynomial ratio,

1

Select the Numerator Coefficients edit box and enter the coefficients. In the
preceding example, enter 500.

The number of coefficients determines the order of the polynomial, and the
coefficients are ordered from greatest to least.

Select the Denominator Coefficients edit box and enter the coefficients. In the
preceding example, enter 0255.

To edit the size of the precision, choose from

* BYTE (8 bits)

* WORD (16 bits)

* LONG (32 bits)

* CUSTOM (Enter the number of bits in the edit box)

Select the Signed check box if you want the numbers to be negative and positive.
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)} 2D Table Properties

General  Table Yalues Precision I ImpLts |

Precizion type:

Palynaomizl Ratio, Fixed Point H [~ Read-only

=10l x|

50

¥=5

Resalved values

— Paolynomial mapping

30

40 50

Mumerstor coefficients:

I

Denominator coefficients: I o1

— Fixed paint storage

Murmber of bits:

Fized poirt position:
[+ Signed

" Byte (8 bits)
 Wiord (16 bits)
+ Long (32 hits)
= Custom:

=

=3

QK I Cancel

Helg




Table Properties

Lookup Table, Fixed Point

). 2D Table Properties 10l =l

General  Table Values Precision I Inputs I

Precizion type: ILookup Tahble, Fized Poirt d [~ Read-only

a0

¥=x
Resalved values

— Look-up table data

Physical data; | 050

Hardvwware data: I 0a

— Fixed point storage

Mumber of bits:

" Wiord (16 bits)
" Long (32 hits)

 Custom: I 8 il
Fixed point position; I 1 il

¥ Signed

[o]% I Cancel | Helpr

The advantage of using fixed-point precision is the reduction in computation needed for
such numbers. However, it restricts the numbers available to the user.

For example, consider using a lookup table for the physical quantity spark advance for
maximum brake torque (MBT spark). Typically, the range of values of MBT spark is 0 to
50 degrees. This is the physical data. The ECU can only store bytes of information and
you want to restrict the hardware store to a range of 0 to 8, with at most one decimal
place stored.

To adjust the fixed-point precision of the lookup table:
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Select the Physical Data edit box and enter the range of the physical data.
Select the Hardware Data and enter the range to store.
To edit the size of the precision, choose from

* BYTE (8 bits)
* WORD (16 bits)
* LONG (32 bits)
* CUSTOM (Enter the number of bits in the edit box)
4  Select the Signed check box if you want the numbers to be negative and positive.

In the example shown, the hardware is restricted to 8 bytes and to one decimal place.

Table Properties: Inputs Tab

This tab displays the inputs and variable dependencies for the selected table.
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Table Normalizers

In this section...

“About Normalizers” on page 3-39

“Introducing the Normalizer View” on page 3-40
“Editing Breakpoints” on page 3-42
“Input/Output Display” on page 3-43
“Normalizer Display” on page 3-43

“Breakpoint Spacing Display” on page 3-44

About Normalizers

What are normalizers? A normalizer is the axis of your lookup table. It is the same as the
collection of the breakpoints in your table.

CAGE distinguishes between the normalizers and the tables that they belong to. Using
models to calibrate lookup tables enables you to perform analysis of the models to
determine where to place the breakpoints in a normalizer. This is a very powerful
analytical process.

Note For information on optimizing breakpoints with reference to a model (in feature
calibration), see “Optimize Normalizer Breakpoints” on page 4-38.

It is important to stress that in CAGE a lookup table can be either one-dimensional or two
dimensional. One-dimensional tables are sometimes known as characteristic lines or
functions. Two-dimensional tables are also known as characteristic maps or tables. This is
important because normalizers are very similar to characteristic lines.

For example, a simple strategy to calibrate the behavior of torque in an engine might
have a two-dimensional table in speed and relative air charge (a measure of the load).
Additionally, this strategy might take into account the factors of air/fuel ratio (AFR) and
spark angle. Each of these compensating factors is accounted for by the use of a simple
characteristic line. In CAGE, these characteristic lines are one-dimensional tables. In the
example strategy, there are the following tables and normalizers:

* One characteristic map: the torque table
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» Six characteristic lines:

* Two tables: one for AFR and one for spark angle
» Four normalizer functions: speed, load, AFR, and spark angle

Notice also that a breakpoint is a point on the normalizer where you set values for the
lookup table.

Thus, when you calibrate a normalizer you place the individual breakpoints over the
range of the table's axis.

Introducing the Normalizer View

The normalizer node shows the Normalizer view, which displays

* One normalizer if the table selected is one-dimensional
* Both normalizers if the table is two-dimensional

Note If the table has two normalizers, both are displayed, the normalizer for the table
columns at the top, the normalizer for the table rows below. This is true whichever
normalizer on the tree is highlighted.

See “Editing Breakpoints” on page 3-42.
The parts of the display as shown in the example below are:

* “Input/Output Display” on page 3-43. This shows the breakpoints of the normalizer.

* “Normalizer Display” on page 3-43. This is a graphical representation of the Input
Output display.

* “Breakpoint Spacing Display” on page 3-44. This shows a slice of the model (in
feature calibration) over the range of the breakpoints.

* The comparison pane (for feature calibration with reference to a model). For
information, see “Viewing the Normalizer Comparison Pane” on page 4-43.
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Selected node

1. Inout output display

2. Normalizer display

3. Breakpoint spacing display
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Editing Breakpoints
To edit breakpoints:

* Double-click on a cell in the Input or Qutput column and edit the value.

* Click and drag a breakpoint in the Normalizer Display graph or the Breakpoint
Spacing display.

To view the history of the normalizer function, select View > History from the menu. This
opens the History dialog box where you can view and revert to previous versions. For a
more detailed description of the History dialog box, see “Using the History Display” on
page 3-23.

Locking and Unlocking Breakpoints

Locking breakpoints ensures that the locked breakpoint does not alter. You might want to
lock a breakpoint when you are satisfied that it has the correct value.

To lock a breakpoint, do one of the following:

* Right-click the selected breakpoint in the Input/Output display and select Lock.
Locked breakpoint cells have padlock icons.

* Right-click the selected breakpoint in the Normalizer Display or Breakpoint
Spacing display and select Lock Breakpoint. Locked breakpoints are black.

Similarly use the right-click context menus to unlock breakpoints.
Deleting Breakpoints

Deleting breakpoints removes them from the normalizer table. There are still table values
for the deleted breakpoints: CAGE determines the positions of the deleted breakpoints by
spacing them linearly by interpolation between the nondeleted breakpoints.

Deleting breakpoints frees ECU memory. For example, a speed normalizer runs from 500
to 5500 rpm. Six breakpoints are spaced evenly over the range of speed, that is, at 500,
1500, 2500, 3500, 4500, and 5500 rpm. If you delete all the breakpoints except the
endpoints, 500 and 5500 rpm, you reduce the amount stored in the ECU memory. The
ECU calculates where to place the breakpoints by linearly spacing the breakpoints
between the 500 rpm breakpoint and the 5500 rpm breakpoint.

To delete a breakpoint, right-click the breakpoint and select Delete Breakpoint.



Table Normalizers

Deleted breakpoints are green in the Breakpoint Spacing display. You can restore them
by right-clicking and selecting Add Breakpoint.

Input/Output Display

Input Dutput
A00 I

1055
1609
2164
2718
3273
3828
4332
4836
5391
AB895
G500

IR L= Ri==h e RR=R A RS TR RN

—_ =

The table consists of the breakpoints of the normalizer function.
The table has inputs and outputs:

* The inputs are the values of the breakpoints.
* The outputs refer to the row/column indices of the attached table.

To change values of the normalizers in the Input Output display, double-click a cell in
the Input column and change its value.

Normalizer Display

This displays the values of the breakpoints plotted against the marker numbers of the
table (that is, the inputs against the outputs).

Click and drag the breakpoints to move them.
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MNormalizer Display

Locked breakpoint

Breakpoint

o

02 ,04 06 08 1
L
Values of the /

breakpoints

Breakpoint Spacing Display
The Breakpoint Spacing display shows

* Aslice through the model in blue (when feature calibrating with reference to a model)

* The breakpoints in red

To move breakpoints, click and drag.
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Breakpoint Spacing
52

LT ; .
50 1 ) <, A slice through the model: blue

48
46
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42
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40

" Breakpoint: red

Locked breakpoint: black
38 \ . / P

-}

1] 2000\ 4000 6000
N
Deleted breakpoint: green

Show the Model's Curvature

You might want to view the curvature of the model to manually move breakpoints to
where the model's curvature is greatest.

To display the model slice as its second-order derivative, the curvature of the model,

» Right-click the model in the Breakpoint Spacing display and select Display > Model
Curvature..

You can revert to displaying the model by selecting Display > Modelfrom the right-click
menu.

Multiple Slice View

By default the Breakpoint Spacing display shows one slice through the model, shown.
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Slice Through a Model
Surface

Viewing many slices of the model gives a better impression of the curvature of the model.
For example, see the following figure.

Many Slices Through a Model
Surface

To view multiple slices through the model,

Right-click the model slice in the Breakpoint Spacing display and select Number of
Lines and choose the number of slices that you want to view from the list.
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Inverting a Table

In this section...

“Overview of Inverting Tables” on page 3-47
“Inverting One-Dimensional Tables” on page 3-49
“Inverting Two-Dimensional Tables” on page 3-50

Overview of Inverting Tables

You can use CAGE to produce a table that is the inverse of another table. This involves
swapping a table input with a table output, and you can invert 1-D or 2-D tables.

Tamue Lond

- }
Lood Tarue

Inverting a table allows you to link a forward strategy to a backward strategy; that is,
swapping inputs and outputs. This process is desirable when you have a "forward"
strategy, for example predicting torque as a function of speed and load, and you want to
reverse this relationship in a "backward strategy" to find out what value of load would
give a particular torque at a certain speed.

Normally you fill tables in CAGE by comparing with data or models. Ideally you want to
fill using the correct strategy, but that might not be possible to find or measure. If you
only have a forward strategy but want a backward one, you can fill using the forward
strategy (tables or model) and then invert the table.

For example, to fill a table normally from a model, you need the model response to be the
table output, and the model inputs to be a function of the table inputs (or it should be
possible to derive the input -- for example, air mass from manifold pressure). If the
available model is “inverted” (the model response is a table input and the table output is a
model input) and you cannot change the model, you can invert the table in CAGE.
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Tarque Spark

Load Load

Spark Tarque

Made! Table o fill

In the diagram of a table shown, the x- and y-axes represent the normalizers (which you
want to be spark and load) and the z-axis is the output at each breakpoint (torque). To fill
this table correctly from the model is a two-step process. First you need to fill a table that
has the same input and output as the model, and then fill a second table by inversion.

For the inversion to be deterministic and accurate, the table to be inverted must be
monotonic; that is, always increasing or decreasing. This requirement is explained by the
following one-dimensional example. Every point on the y-axis must correspond to a
unique point on the x-axis. The same problem applies also to two-dimensional tables: for
any given output in the first table there must be a unique input condition; that is, every
point on the z-axis should correspond to a unique point in the x-y plane. Some table
inversions have multiple values and so do not meet this requirement, just as the square
root function can take either positive or negative values. You can use the inversion wizard
in CAGE to handle this problem; you can control the inversion process and determine
what to do in these cases.

The following example illustrates a table with multiple values. There are two solutions for
a single value of torque. CAGE has a table inversion tool that can help overcome this
problem. You can specify whether you want to use the upper or lower values for filling
certain parts of the table; this allows you to successfully invert a multiple-valued function.
See the inversion instructions for 1-D and 2-D tables in the next sections.
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Tanque
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Load
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Load
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process of inverting a one-dimensional table is different from the process of inverting
o-dimensional table.

Inverting One-Dimensional Tables

To invert a one-dimensional table,

1

Ensure that your session contains two tables:

a The first 1D table that you want to invert, filled.

b  Another 1D table with a different input, which you want to fill with the inverted
table.

Highlight the table that you want to invert.
Click F or select Table > Invert.

The Table Inversion dialog box appears.

CAGE selects a suitable table in the Table to fill list. Check that this is the table that
you want to fill, or select another.

The next control, Resolve non unique inverses with, specifies what CAGE should
do if it encounters multiple values. To minimize the error, leave the default, Least
squares. The options are:

* Least squares selects the range that produces the least error (see below; the
last page of the wizard plots the error metric).

3-49



3 Tables

3-50

* Minimum selects the lower of the two if a given number has two possible inverses
(like selecting the negative square root of a number).

* Maximum selects the uppermost range if a given number has two possible inverses
(like selecting the positive square root of a number).

* Intermediate selects the middle range if a given number has more than two
possible inverses.

For example, the function y =x? is impossible to invert over the range -1 to 1. You can
specify to invert the range from 0 to 1, sacrificing the inversion in the lower range, or
the reverse. To select the range from 0 to 1, highlight Maximum.

The display shows a comparison between the table (green) and the function

x = fH(fx).

The lower pane of the dialog box has a plot that shows the inversion error. If desired,
you can change the plot type to view Input and Output. If your forward function is y =
f(x), and your inverse function is x = g(y), then, combining these, in an ideal world,
you should have x = g(f(x)). The plot then displays a line showing x against x and a
line showing x against g(f(x)). The closeness of these two lines indicates how good the
inversion has been: a perfect inverse would show the lines exactly on top of each
other.

The plot can show you which part of your table has not successfully inverted and
where you should try a different routine.

Note The least squares inversion routine tries to minimize the total distance
between these lines. This can sometimes lead to unexpected results. For example,
given the function f(x) = x~2 between -1 and 1, if you select either positive or
negative square root as the inverse, this induces a large error in the combined
inverse. If you choose g(y) = sqrt(y), then g(f(-1)) = 1, an error of 2. To minimize this,
the least squares routine might choose to send everything to zero and accept a
medium error over the whole range rather than a large error over half the range. Use
knowledge of the form of the table you are inverting to help you choose which routine
to select.

Click OK to accept the inversion or Cancel to ignore the result and return to the
original table.

Inverting Two-Dimensional Tables

To invert a two-dimensional table,



Inverting a Table

Ensure that your session contains two tables:

a  The first table you want to invert.

b A second table with exactly one of the same inputs, which you want to fill with
the inverted table.

Highlight the table you want to invert.
Click T or select Table > Invert.

The Table Inversion dialog box appears.

CAGE selects a suitable table in the Table to fill list. Check that this is the table that
you want to fill, or select another.

The next control, Resolve non unique inverses with, specifies what CAGE should
do if it encounters multiple values. To minimize the error, leave the default, Least
squares. See inverting a 1D table for the other options.

The lower pane of the dialog box has a plot that shows the inversion error. If desired,
you can change the plot type to view the Input and Output. If the forward function is
z = f(x,y), and the inverse function is x = g(y,z), then, combining these, in an ideal
world you should have x = g(y,f(x,y)). The plot then displays a plane showing x plotted
against x and y, and a colored surface showing g(y,f(x,y)) plotted against x and y. The
closeness of these two planes indicates how good the inversion is. If you want to
improve the inversion in some areas, try other settings in Resolve non unique
inverses with.

Click OK to accept the result or Cancel to ignore the result and return to the original
table.
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Importing and Exporting Calibrations

In this section...

“Formats” on page 3-52
“Importing Calibrations” on page 3-52

“Exporting Calibrations” on page 3-52

Formats

You can import and export calibrations in various formats.

* ATI Vision MAT file

+ INCA DCM file

* Matrix MAT file

* Simulink Model Workspace
* Simple CSV file

* Structure MAT file

* Simple MATLAB file

Importing Calibrations

1  Select a table.
Select File > Import > Calibration .
3 Ifimporting a file, a file browser dialog opens.

a  Select the type of file you want from the Files of type drop-down list, or leave
the default ALl files (*.*) and CAGE will try to load the file based on the
file extension.

b  Browse to the file and click Open to import.

Exporting Calibrations

To export your calibration data,
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1

Select File > Export > Calibration > Selected Item or All Items, or use the

toolbar button to export all calibration items.

The Export Calibration Data dialog appears, for example:

Y Export Calibration Data

lkem

BSFC_Table
ECP_Table
ICP_Table
LAM_Table
1 LoAD norm
MAP_Table
SA_Table
Speed_norm
TEXH_Table
TPP_Table
Torgue_Table
WAP Table

Select all by type:
20 tables

Mormalizers

Export to: ATl Vision MAT file

Calibration tems in the CAGE project gazolineCneStage:

Type

2D table
20 table
20 table
20 table
Mormalizer
20 table
20 table
MNormalizer
2D table
20 table
20 table
20 table

Cancel

Select the check boxes of the calibration items you want to export.

You can select all items of a single type by using the check boxes under the list — for
example select the 2D tables check box to select the check boxes of all 2D Tables in

the list.
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If you chose to export All Items, all tables, normalizers, curves and constants in the
project are available in the list of calibration items.

If you chose to export Selected Item, the list items depend on which tree node you
have selected. For a table node, the list contains the table and its normalizers. For a
Feature or Tradeoff node, the list includes the whole feature or tradeoff (all tables,
normalizers, curves and constants). For an optimization node, the list contains any
tables filled from the optimization results.

Ue the Export to parameter to specify the format. Click OK.
* Ifyouselect Simulink Model Workspace, CAGE prompts you to open a
Simulink model.

* Ifyouselect Matrix MAT file, the table data format is compatible with
Simulink lookup tables.
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This section includes the following topics:

* “About Feature Calibrations” on page 4-2

» “Set Up a Feature Calibration” on page 4-11

* “Import a Strategy from Simulink” on page 4-15

* “Optimize Table Values” on page 4-24

» “Initialize Tables and Normalizers” on page 4-34

* “Optimize Normalizer Breakpoints” on page 4-38

* “Compare the Strategy and the Model” on page 4-46
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In this section...

“What Are Feature Calibrations?” on page 4-2
“Procedure for Feature Calibration” on page 4-2
“How CAGE Optimizes Normalizer Breakpoints” on page 4-5

“How CAGE Optimizes Table Values” on page 4-9

What Are Feature Calibrations?

kS

Feature

A 'feature' calibration is the process of calibrating lookup tables and their normalizers by
comparing an ECU strategy (represented by a Simulink diagram) to a model.

The strategy is an algebraic collection of lookup tables. It is used to estimate signals in
the engine that cannot be measured and that are important for engine control.

CAGE calibrates an electronic control unit (ECU) subsystem by directly comparing it with
a plant model of the same feature.

There are advantages to feature calibration compared with simply calibrating using
experimental data. Data is noisy (that is, there is measurement error) and this can be
smoothed by modeling; also models can make predictions for areas where you have no
data. This means you can calibrate more accurately while reducing the time and effort
required for gathering experimental data.

Procedure for Feature Calibration

The basic procedure for performing feature calibrations is as follows:

1  Set up the variables and constants. (See “Setting Up Variable Items” on page 2-8.)
2 Set up the model or models. (See “Setting Up Models” on page 2-16.)
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1. Set up the variables.
T / —egroTTTTEStEd and parsed _

Data Obiecij/ Retmove '
.

Variable
Dictionary

| | 2

Details:

Kl [
|Reacly |
—— 2. Set up the models.
3 Set up the feature calibration. (See “Set Up a Feature Calibration” on page 4-11.)
4 Initialize the feature. See “Initialize Tables and Normalizers” on page 4-34
5 Calibrate the normalizers. (See “Optimize Normalizer Breakpoints” on page 4-38.)
6 Calibrate the entire feature and view the results. Optionally you can calibrate the

tables individually. (See “Optimize Table Values” on page 4-24.)

7 Export the normalizers, tables, and features. (See “Importing and Exporting
Calibrations” on page 3-52.)
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7. Export the 3. Set up the feature 6. Calibrate

calibration. r calibration. the feature.

). CAGE Browser yifeattut.cag /.
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5. Calibrate the tables. — 4. Calibrate the normalizers.

The normalizers, tables, and features form a hierarchy of nodes, each with its own view
and toolbar. The feature view is shown.

Working With Feature Tables

After you set up your session and your tables, you can calibrate your tables.

Highlight a table in the tree display to see the Table view. For more information about the

Table view, see “Editing Tables” on page 3-12.

In CAGE, a table is defined to be either a one-dimensional or a two-dimensional lookup
table. One-dimensional tables are sometimes known as characteristic lines or functions.
Two-dimensional tables are also known as characteristic maps or tables.

Each lookup table has either one or two axes associated with it. These axes are
normalizers. See “About Normalizers” on page 3-39 for more information.

For example, a simple MBT feature has two tables:
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* A two-dimensional table with speed and relative air charge as its normalizer inputs
* A one-dimensional table with AFR as its normalizer input

Before you can calibrate your tables, you must calibrate your normalizers. For
information, see “Optimize Normalizer Breakpoints” on page 4-38.

This section describes how you can use CAGE to fill your lookup tables by reference to a
model.

o)

K

A

— =4
=ELEF *, or select

To fill the table values, either click the buttons in the toolbar,
from the following options in the Table menu:

* Initialize Table
Sets each cell in the lookup table to a specified value. For information, see “Initializing
Table Values” on page 4-36.

+ Fill Table
Fills and optimizes the table values by reference to the model. For information, see
“Filling and Optimizing Table Values” on page 4-24.

* Fill by Inversion
Fills the table by creating an inversion of another table. For information, see
“Inverting a Table” on page 3-47.

* Fill by Extrapolation
Fills the table values based on the cells specified in the extrapolation mask. You can
choose values in cells that you trust to define the extrapolation mask and fill the rest

of the table using only those cells for extrapolation. For information, see “Filling
Tables by Extrapolation” on page 4-32.

How CAGE Optimizes Normalizer Breakpoints

Optimizing breakpoints alters the position of the table normalizers so that the total
square error between the model and the table is reduced.

This routine improves the fit between your strategy and your model. The following
illustration shows how the optimization of breakpoint positions can reduce the difference
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4-6

between the model and the table. The breakpoints are moved to reduce the peak error
between breakpoints. In CAGE this happens in two dimensions across a table.

The green shaded oreos show the error
between the interpoluted tuble volues
ond the model using the initiol
brenkpoints.

Torque

Optimizing the position of the
hrenkpoints cun greotly reduce the error
hetween the interpoloted toble volues
and the model.

Torque

Engine speed

To see the difference between optimizing breakpoints and optimizing table values,
compare with the illustration in “How CAGE Optimizes Table Values” on page 4-9.

See “Filling Methods” on page 4-6 for details on how the optimal breakpoint spacing is
calculated.

Filling Methods

This section describes in detail the methods for spacing the breakpoints of your
normalizers in CAGE.

* For one-dimensional tables, the two fill methods are

* ReduceError on page 4-7
* ShareAveCurv on page 4-7
* For two-dimensional tables, the two fill methods are

* ShareAveCurv on page 4-7
* ShareCurvThenAve on page 4-7
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ReduceError

Spacing breakpoints using ReduceError uses a greedy algorithm:

1 CAGE locks two breakpoints at the extremities of the range of values.
2 Then CAGE interpolates the function between these two breakpoints.

3 CAGE calculates the maximum error between the model and the interpolated
function.

4 CAGE places a breakpoint where the error is maximum.
Steps 2, 3, and 4 are repeated.
6 The algorithm ends when CAGE locates all the breakpoints.

ShareAveCurv and ShareCurvThenAve

Consider calibrating the normalizers for speed, N, and relative air-charge, L, in the
preceding MBT model.

In both cases, CAGE approximates the MBT,y(N, L) model, in this case using a fine mesh.

The breakpoints of each normalizer are calibrated in turn. In this example, these routines
calibrate the normalizer in N first.

Spacing breakpoints using ShareAveCurv or ShareCurvThenAve calculates the
curvature, K, of the model MBT,y(N, L),

fine mesh
K= Y (MBT " (N.Ly'”
1=1

as an approximation for
6000

E =
J?ﬁﬂ

Both routines calculate the curvature for a number of slices of the model at various values
of L. For example, the figure shown has a number of slices of a model at various values of
L.

MBT ,"(N.L)["*dN
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Model Slices at Various Values of L

Then

* ShareAveCurv averages the curvature over the range of L, then spaces the
breakpoints by placing the it" breakpoint according to the following rule.

« ShareCurvThenAve places the it" breakpoint according to the rule, then finds the
average position of each breakpoint.

Rule for Placing Breakpoints

If j breakpoints need to be placed, the i breakpoint, N;, is placed where the average
curvature so far is

N. _
[ |MBT 4" (N. L)["dN = ;:—::LLXK
50

Essentially this condition spaces out the breakpoints so that an equal amount of curvature
(in an appropriate metric) occurs in each breakpoint interval. The breakpoint placement
is optimal in the sense that the maximum error between the lookup table estimate and the
model decreases with the optimal convergence rate of O(N). This compares with an
order of O(N"!2) for equally spaced breakpoints.

The theorem for determining the position of the unequally spaced breakpoints is from the
field of Approximation Theory — page 46 of the following reference: de Boor, C., A
Practical Guide to Splines, New York, Springer-Verlag, 1978.
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How CAGE Optimizes Table Values

The Feature Fill Wizard optimizes the table values to minimize the current total square
error between the feature values and the model.

This routine optimizes the fit between your strategy and your model. Using Fill places
values into your table. The optimization process shifts the cell values up and down to
minimize the overall error between the interpolation between the model and the strategy.

This process is illustrated by the following example; the green shaded areas show the
error between the mesh model (evaluated at the number of grid points you choose) and
the table values.

This shows the error
when filling the
table using

breakpoints.

Torgue

This shows the reduced
error after optimizing
table values using input
values between

the breakpoints.

Torque

Engine Speed

To see the difference between optimizing table values and optimizing the positions of
breakpoints, compare with the illustration in “How CAGE Optimizes Normalizer
Breakpoints” on page 4-5.

CAGE evaluates the model over the number of grid points specified in the Feature Fill
Wizard, then calculates the total square error between this mesh model and the feature
values. CAGE adjusts the table values until this error is minimized, using lsqnonlin if
there are no gradient constraints, otherwise fmincon is used with linear constraints to
specify the gradient of the table at each cell.
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See Also

* Reference page for Lsqnonlin
* “Optimize Table Values” on page 4-24
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Set Up a Feature Calibration

In this section...

“Procedure Overview” on page 4-11
“Adding a Feature” on page 4-12
“What Is a Strategy?” on page 4-12

“Working With Features” on page 4-12

Procedure Overview

A feature calibration is the process of calibrating lookup tables and their normalizers by
comparing a collection of lookup tables to a model. The collection of lookup tables is
determined by a strategy.

A feature refers to the object that contains the model and the collection of lookup tables.
For example, a simple feature for calibrating the lookup tables for the maximum brake
torque (MBT) consists of

* A model of MBT

» A strategy that adds the two following tables:

* A speed (N), load (L) table
* A table to account for the behavior of the air/fuel ratio (4)

Having already set up your variable items and models, you can follow the procedure
below to set up your feature calibration:

1 Add a feature. This is described in the next section, “Adding a Feature” on page 4-
12.

2 Set up your strategy. See “Import a Strategy from Simulink” on page 4-15.
Initialize tables. See “Initialize Tables and Normalizers” on page 4-34

Optimize normalizer breakpoints. See “Optimize Normalizer Breakpoints” on page 4-
38.

5 Fill the feature. See “Optimize Table Values” on page 4-24
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Adding a Feature
A feature consists of a model and a collection of lookup tables, organized in a strategy.

To add a feature to your session, select File -> New -> Feature. This automatically
switches you to the Feature view and adds an empty feature to your session.

An incomplete feature is a feature that does not contain both an assigned model and a
strategy. If a feature is incomplete, it is displayed as¥- in the tree display. If a feature is
complete, it is displayed as¥- in the tree display.

What Is a Strategy?

A strategy is an algebraic collection of tables, and forms the structure of the feature.
For example, a simple strategy to calibrate a feature for MBT adds two tables:

» A table ranging over the variables speed and load
* A table to account for the behavior of the model as the AFR varies

To evaluate the feature side by side with the model, you need to have a strategy that
takes some or all of the same variables as the model. The strategy is expressed using
Simulink diagrams. You can either import a strategy or you can construct a strategy.

For details on importing, constructing and exporting strategies with CAGE, see “Import a
Strategy from Simulink” on page 4-15.

Working With Features

After you import a strategy, you can use the Feature view to calibrate the entire feature,
that is, fill all the table values by referring to a model.

The parts of the Feature view include
1 The Strategy for the selected feature. This is the algebraic collection of the tables

and inputs that you are using to calibrate the selected feature.

2 The Feature Fill Settings pane, where you can run and manage saved fill settings
from previous feature filling.

3 The Feature Tables pane, where you can view and open all the tables in your
feature. Double-click a table to change the view to that table.
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4 The Feature History pane, which displays the history of the feature.

’a CAGE Browser - MBTSparkFeatureFilled.cag
File Edit View Feature Tools Window Help
EFEFIE L EIEE |
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Ready

Use the Feature menu to control your strategy and initialize and fill the tables in your
strategy:

* Select Filling Item

You can use this to select the correct model or data for your feature, or you can set
this up during the Feature Fill Wizard steps if you select Feature > Fill.

¢ Convert to Model
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Takes the current feature and converts it to a model, which you can view by clicking
the Model button.

* Graphical Strategy Editor

Opens your current strategy for editing. For more information, see “What Is a
Strategy?” on page 4-12.

* Parse Strategy Diagram

Performs the same function as double-clicking the blue outport of your strategy
diagram. For more information, see “What Is a Strategy?” on page 4-12.

* Clear Strategy

Clears the current strategy from your feature.
* Initialize

Initializes the feature; also in the toolbar. See “Initialize Tables and Normalizers” on
page 4-34 for details.

+ Fill

Fills and optimizes the feature; also in the toolbar. See “Filling and Optimizing Table
Values” on page 4-24 for details.

* Use the Fill Settings items to control your saved fill settings from previous feature
filling. You can run your existing fill settings, duplicate and create new fill settings,
and delete fill settings. You can also use the buttons in the Feature Fill Settings pane
to manage your fill settings. See “Saving and Reusing Feature Fill Settings” on page 4-
31.
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Import a Strategy from Simulink

In this section...

“Import a Strategy” on page 4-15

“Model Structure and Strategy Hierarchy” on page 4-16
“Tables, Normalizers, and Constants” on page 4-16
“Block Support” on page 4-18

“Loop Handling” on page 4-19

“Importing Older Strategies” on page 4-19
“Constructing a Strategy” on page 4-20

“Exporting Strategies” on page 4-23

Import a Strategy

Highlight the top feature node in the tree display.
Select File > Import > Strategy.
Select the appropriate Simulink model file. CAGE checks the strategy.

If there is a single outer outport, CAGE automatically imports the strategy.
4 If there are multiple outer outports, CAGE prompts you to either:

* Import all outports into separate features.

* Manually select a single outport. Outport blocks are highlighted in blue. Double-
click the outport to import.

5 If there are problems importing the strategy, CAGE reports them. If possible, CAGE
asks what you want to do. For examples, see “Names and Reuse of Tables,
Normalizers, and Constants” on page 4-16.

If parsing the Simulink diagram fails and you see an error message, then any changes
in the current CAGE project are discarded. You can then correct the Simulink
diagram and reparse it.

To view a text representation of your strategy, select the Feature node. Your strategy is
represented in the Strategy pane. Select View > Full Strategy Display to switch
between the full description and the simplified expression. You can select and copy the
strategy equation to the Clipboard.
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For information about using Simulink to amend strategies, see “Constructing a Strategy”
on page 4-20.

The following sections describe the rules for CAGE parsing Simulink models to create
features.

Model Structure and Strategy Hierarchy

* CAGE uses the Subsystem hierarchy in the Simulink model to generate subfeatures in
CAGE. This makes it easier to understand the structure of the strategy and relate it to
the Simulink model. However, be aware how CAGE creates subfeatures from Simulink
models:

*  When a subsystem has more than one outport, CAGE adds the outport name to the
subsystem for the subfeature name. Rename an outport before importing if you
want a particular name for the CAGE subfeature. CAGE creates unique names.

* CAGE creates a subfeature from outports in subsystems. CAGE works backwards
from outports and includes all input blocks to the outport in the subfeature. This
can include blocks outside the subsystem. Subfeatures are not identical to Simulink
subsystems.

* CAGE shows the subfeature hierarchy in the Feature tree. Each subfeature is also
visible at the top level of the tree.

Tables, Normalizers, and Constants

* “Names and Reuse of Tables, Normalizers, and Constants” on page 4-16
* “Table and Normalizer Structure” on page 4-17
* “Data Import” on page 4-17

Names and Reuse of Tables, Normalizers, and Constants

* CAGE determines table and normalizer names from parameter variable names rather
than the block name, provided the Simulink parameter is a valid variable name and
not a MATLAB expression. This supports table reuse and avoids the need for explicit
normalizer blocks.

» For constants, CAGE uses the block name or constant variable name if defined.

Constants are reused if they have the same name as an existing constant and the value
is the same.
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If a table of the same name already exists in the project and the input expressions for
these tables are the same, then the table is automatically reused. Similarly,
normalizers are reused if they have the same inputs as the existing normalizer.

If a table of the same name already exists in project and the new table has different
inputs, then CAGE asks what option you want:
* Create a new table with a different name (suffix 1).

* Reconnect the table inputs using the current Simulink block connections. This
changes all other instances of the table.

¢ Cancel. You can then edit the model to resolve differences if desired.

Table and Normalizer Structure

Shared normalizers can be used as inputs to multiple tables. You can view shared
normalizers at the top of the CAGE Table tree.

You can create 1D tables with or without normalizers. If you add a CAGE Function
block from cgeqlib with no normalizer, a 1D lookup table with an internal normalizer
is created on parsing. If the Function block has a normalizer as its input, then you can
use shared normalizers (from the list of available normalizers in CAGE). After creation,
you cannot change from using shared normalizers to internal normalizers.

2D lookup tables always have shared normalizers. If the input to the Table block is not
a normalizer, then CAGE creates a normalizer when the strategy is parsed.

CAGE assigns normalizer names using the lookup table breakpoint (or row/column
index) variable names if available. If the breakpoints are defined by an expression and
not a variable, then CAGE names normalizers using the form tablename normY or
tablename normX.

If you change the name of inports, table or normalizer blocks for blocks associated
with existing CAGE items, then the CAGE item’s name is changed. The name is unique
for the current CAGE project (suffixes 1 are added if necessary to create a unique
name).

Prelookup tables must feed into an Interpolation block using a Prelookup block.
Normalizer blocks, if used, must be inputs to tables.

Data Import

Table and normalizer data is imported from Simulink.
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You must be able to run Update Diagram on the Simulink model and the data must
have a single source (base workspace, model workspace, mask workspace for a single
block). Otherwise, table data is left empty and you must set up the tables, normalizers,
and constants using the Calibration Manager.

Constant data is read from Constant or Gain blocks.

For data export, see “Exporting Strategies” on page 4-23.

Block Support

Math Operations library: CAGE supports a subset of Simulink blocks. Open the
cgeqlib library to view the supported blocks.

Switch blocks: CAGE can import the Simulink Switch block and MultiportSwitch block.
Note that when you import the Switch block, CAGE converts it to a CAGE block called
IfExpr. You can view this block in the cgeqlib library.

Logic and Boolean expressions: CAGE can import the Logical Operator and Relational
Operator blocks.

Polynomial expressions: CAGE builds polynomial expressions using Horner’s form
(product and sum blocks).

Dot Product block. This allows the implementation of weighted sum expressions.

Interpreted MATLAB Function block. You can use this to implement more general
functions in CAGE features. The function must be vectorized. That is, it must accept
matrix inputs of the form ([ul,u2,u3,..,un]).

Fcn block: CAGE converts the expression to a MATLAB vectorized form. You can use
() or[ ] indexing of input.

Signal conditioning blocks are ignored. Several standard Simulink blocks are for
conditioning signals, but these can be ignored for the purposes of steady state analysis
in CAGE. These blocks include the signal conversion, rate transition, data type
conversion and initial condition block. CAGE ignores them, making it easier to import
existing strategy diagrams.

Merge and If blocks: CAGE supports Merge blocks fed by enabled or If/Elself/Else
subsystems, that are quite common in industry models.

Only scalar inputs are supported except for the following blocks. The Fcn, Dot Product,
Polynomial, and Interpreted MATLAB Function blocks all accept multiple inputs as inputs
to the expression (e.g., u(1)+u(2)).
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Loop Handling

CAGE cannot handle expressions with loops. If CAGE detects a loop, then CAGE asks if
you want to break the loop by introducing a variable called previousOutportName.
CAGE needs to do this to import the strategy and enable feature filling. If possible, CAGE
tries to break loops at a feature boundary (e.g., a top level or subsystem output).

If you decide not to break the loop, the error message then informs you which blocks are
involved in the loop.

CAGE ignores delay blocks and resettable delay blocks to facilitate loop parsing.

Importing Older Strategies

If you need to parse strategies from previous releases, you can use the function
cgStrategyTables to set the style for strategy parser behavior. Use this function if you
need to import any older strategies saved as Simulink model files.

» For strategies in R2013a or later, CAGE interprets the first input to a 2D lookup table
as 'Y (rows). Previously, CAGE parsed the first input as columns and the second as
rows. Use the cgStrategyTables backward compatibility modes if needed for
previously saved strategies.

» For strategies from R2008a to R2012b, lookup table blocks are always interpreted as
lookup tables, because there are separate lookup and normalizer blocks. In R2008a, a
normalizer block was added to the cgeqlib library.

Set the parser style to R2008a as follows:

cgStrategyTables('R2008a')

» For strategies older than R2008a, CAGE interprets 1D tables as normalizers if they
feed into a lookup table.

If you need to parse pre-R2008a strategies, use the function as follows:
cgStrategyTables('Pre-R2008a"')

This reverts the parser behavior to the pre-R2008a interpretation of 1D lookup
tables.CAGE issues a warning when converting a 1D table to a normalizer. You can
turn the warning off as follows:

warning off mbc:cgslparser:0bsoleteNormalizer
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» Ifyou need to reset the parser style to R2013a and later, use:

cgStrategyTables('R2013a')
* To query the current strategy table style, enter:

Style = cgStrategyTables

Constructing a Strategy

To construct a strategy from CAGE rather than import an existing model:

Highlight the correct feature by selecting the Feature node.
2  Select Feature > Graphical Strategy Editor or press Ctrl+E.

Three Simulink windows open:

* The strategy window for editing your strategy.
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File Edit View Display Diagram Simulation Analysis Code Tools Help
| | i = bid
b - mO-EH-4@P = ©- wo » @ | G -
: Turque_Output .
@ |[*a|Torque_Output A
®‘ Reference signals Model build ares
B o
— L
N .
—<__ & ]
A
@ > SPK Torque Output
SPK .
»
Ready 100% oded5

* Alibrary window, cgeqlib, with all the blocks available for building a strategy.
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* A library window with all existing blocks in your CAGE project, organized in

libraries. The blocks are From blocks referencing the CAGE items such as tables
and normalizers.
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3 In the strategy window, build your strategy using the blocks in the library windows.
To perform a feature calibration, the strategy and the model must have some
variables in common.

4 Double-click the blue outport circle to parse the strategy into the CAGE session.

Note This closes all three Simulink windows and parses your strategy into the
feature.

The cgeqlib library contains all the blocks available for building a strategy.
Block Highlighting

CAGE highlights blocks as follows while you construct a strategy, and when you open the
graphical strategy editor after importing a strategy. You also see this highlighting if you
export a strategy. Tables in the current CAGE session are dark green. Subfeatures are
bright green. A black table block signifies that CAGE does not yet know about it — either
a new table will be created in CAGE on import, or an existing table can be reused. See
“Names and Reuse of Tables, Normalizers, and Constants” on page 4-16. If you copy a
CAGE table block, the new block color changes to black.

Normalizers in the current CAGE session are light blue. A black Normalizer block
signifies that CAGE does not yet know about it, like black table blocks.
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Simple Strategy Example

In the matlab\toolbox\mbc\mbctraining folder, there is a Simulink model file called
tutorial. Create a new feature, then import the example strategy by selecting File >
Import > Strategy.

View the strategy by selecting Feature > Graphical Strategy Editor. The diagram
opens.

Exporting Strategies

Simulink strategies can be exported. For example, you might want to:

* Include a strategy in a Simulink vehicle model.
* Compile the strategy using Simulink Coder™ to produce C code.
» Evaluate the strategy using Simulink.

To export a strategy from CAGE:

1 Highlight the Feature node that contains the strategy that you want to save.
Select File > Export > Strategy.
3 Assign a name for your strategy.

The strategy is saved as a Simulink model file.

On export, table data is stored in variables. Indices are written to Simulink parameters
using colon expressions.

* 0:size (Table,1)-1, 0:size (Table,2)-1, TableName for 2D lookup tables.

* 0:length (Table)-1, TableName for 1D lookup tables with shared normalizers.

* NormalizerName and TableName for 1D lookup tables.

* NormalizerName, 0:length(Normalizer)-1

The data is stored in the model workspace. The model workspace data is copied to the
new model when you copy the strategy block. You must be able to run Update Diagram
on the Simulink model or the copy process will not work. A Model-Based Calibration

Toolbox function is used for copying data which means that the toolbox is required to
make a copy of the strategy model.
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Optimize Table Values

In this section...

“Filling and Optimizing Table Values” on page 4-24
“Saving and Reusing Feature Fill Settings” on page 4-31
“Filling Tables by Extrapolation” on page 4-32

Filling and Optimizing Table Values

Use the Feature Fill Wizard to fill and optimize the values in tables by reference to the
model or data. You can fill multiple tables at once using the wizard, and you can Fill from
the top feature node or from any table node in a feature. Use Fill at the top feature node
to calibrate the entire feature, that is, fill all the table values by referring to a model.

Before using the Feature Fill Wizard,

* Your project must contain a feature and a model.

* You need to initialize your tables, unless you imported your strategy with tables
already initialized. See “Initialize Tables and Normalizers” on page 4-34.

* Ifyou want to optimize the breakpoints for the normalizers, you should do this before
optimizing table values using the Feature Fill Wizard. See “Optimize Normalizer
Breakpoints” on page 4-38.

When filling with reference to a model, the Feature Fill Wizard optimizes the table values
to minimize the current total square error between the feature values and the model. This
routine optimizes the fit between your strategy and your model. Using Fill places values
into your table. The optimization process shifts the cell values up and down to minimize
the overall error between the interpolation between the model and the strategy. To learn
more about the filling processes, see “How CAGE Optimizes Table Values” on page 4-9.

CAGE projects store last-used feature filling settings for tables, models, data, and
optimizations. This can save time if you need to use the Feature Filling Wizard repeatedly
with slightly different settings. You can remove saved fill settings by selecting Feature >
Reset Fill Settings.

To fill feature tables, perform the following steps:

Click 3 or select Table > Fill. This opens the Feature Fill Wizard.
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) Feature Fill Wizard 101 =i
Choose Tables to Fill

Choos=e the tables you want to fill and =&t options on how each table ghould be filled.

Table Name Clear Mask |Extrapolate | Table Boundz Row Gradient Bo... | Column Gradient ...
MBT_Base [0,50] [-Inf, Inf] [-Inf, Inf]
MET_Intake [-10,601] [-Inf, Inf] [-Inf, Inf]
MBT_Exhaust [-10,80] [-Inf, Inf] [-Inf, Inf]
MET_Dual [-10,60] [-Inf, Inf] [-Inf, Inf]

Cancel < Back Next » Finizh

Screen 1: Select tables to fill.

Select the check boxes of the tables you want to fill. For each table you can set the
following options:

* Clear Mask — select this check box to clear any table mask and fill all unlocked
table cells (locked cells are never altered). Clear this check box to fill unlocked
cells in the current extrapolation mask only, or all unlocked cells if there is no
mask.

* Extrapolate — select this to extrapolate across the whole table after filling cells.
The extrapolation is based on the filled cells in the mask and any locked cells.

* Table Bounds — enter values here to set bounds on the table values

* Gradient Bounds — enter values here to set bounds on the gradient (slope)
between rows (left edit box) and between columns (right edit box). For example,
entering @ Inf in the left edit box imposes the constraint that the gradient must
be positive (increasing) between successive rows.

When you have selected filling options for each table, click Next.

Choose filling items and links.
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) Feature Fill Wizard . 101 =l
Choose Filling ltem and Links
Select the item to fill the tablez from. Optionally, 2elect a constraint model, and link inputs to other tems from the
project.
Filled by: MBT
Constraint: Boundary constraint of
Dezelect
MBTwithSpeedLoadBoundary
Variables: Links:
Variable Linked to Link | Name Type ¢
N L2, Exhaust CAM Feature -
L Unlink | 3, Intake_CAM Featurs
ECP L2, Exhaust CAM ¥ MBT Start Feature | Feature
ICP ?{} Intake_CAM ﬂ BTQ Model
Exhaust_On -ﬂ.MBTwﬂhSpeedLuad... Model
Intake_On ‘ﬂ EXTEMP Model
-\ RESIDFRAC Model
A HMoT Madal LI
Cancel | < Back | Next = Finizh |

Click the top Select to choose an item to fill the tables from. A dialog box opens
where you can select a model or variable. You can only choose a variable if you
have a suitable data set available containing some of the inputs to the feature.

The feature filler adjusts the table cells so that the value of the feature across the
range of inputs best matches the value of the filling item (model or data).

Click the Constraint Select to choose a constraint to use in the filling process. You
can use Linear, 1-D table, 2-D table, ellipsoid and model constraints (see “Edit
Constraint” on page 6-54). The feature filler limits its activity to within this
constraint, for example, the boundary constraint of a model. While boundary
models are often used as model constraints in this setting you can use any model.
For example, you can use a function that returns a logical output (true for valid,
false for invalid) by setting up the model constraint >=0.5.

Click Link to associate a model, feature or table (selected on the right side) with a
variable (selected on the left side). Linking replaces the variable inputs to any
relevant models and features with the linked item. This enables useful operations
such as feeding a table into a model, for example, an optimal cam schedule into a
torque model, without needing to make a separate function model. Click Unlink
to disassociate any pair.
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Click Next.

Set variable values. Select Data source: Grid or Data set. The data set option is
only available if there is a suitable data set available containing some of the inputs to

the feature.

When filling from a model, you can use a Grid or Data set for the data source.

When filling from a variable, you must fill from a Data set, so you cannot choose

Grid.

* Grid settings

You can define your own grid, use table normalizers, or use normalizers as a
starting point and choose to interleave values between breakpoints.

By default the wizard selects the table's normalizer breakpoints and the set points
of other variables, so the number of grid points is the number of table cells. To
increase the grid size you can enter more points for variables by editing the Value
fields, or you can interleave values between breakpoints (see below). Increasing
the number of grid points increases the quality of the approximation and
minimizes interpolation error, but also increases the computation time.

) Feature Fill Wizard

Set Variable Values
Set the values you want to use to optimize over. Fill from gridded data or a data set.

=10l ]

Data source:

L

Value

500:500:5000

0.1:0.1:1

Exhaust_On

[01]

Intake_On

[0 1]

Initialize from Nermalizer... |

Cancel = Back MNext =

Finizh |
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You can edit grid variable values manually, or you can click the Initialize
From Normalizer button to use breakpoints of normalizers as a variable's
value. In the dialog box where you can select normalizers, you can also choose
to interleave values between breakpoints. Interleaving values can minimize
interpolation error by adding values between each normalizer value. In this
way you can create a grid of more points than table cells to optimize over.
Select normalizers in the dialog box to use those breakpoints as a variable's
value.

In this dialog box, you can enter a value in the Number of values between
breakpoints edit box to add values between breakpoints. By default, the
feature filler compares the feature and model at the table breakpoints. Choose
a positive value to compare the feature and model on a finer grid. A positive
value further enhances the comparison between feature and model to account
also for errors introduced by linear interpolation in the table (see “How CAGE
Optimizes Table Values” on page 4-9). A value of 1 inserts one grid point
between each pair of breakpoints, and so on. Click OK to return to the Feature
Fill Wizard.

Edit set point values in the Value fields to optimize over a range rather than at
a single point. If you choose a range of values the table will be filled using the
average model value at each cell. For example, if you enter -5:5:50 for the
variable spark, the optimization of table values will be carried out at values of
spark between -5 and 50 in steps of 5 degrees.

Data Set settings.

If you have multiple data sets, select the filling data set from the Data set drop
down list.

When filling from a Data Set, the wizard displays the values in your selected
data set, and the set points of any other required variables. You cannot edit the
variable values.
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) Feature Fill Wizard

Set Variable Values

Set the values you want to use to optimize over. Fill from gridded data or a data =&t

=0l x|

Diata source: Data set H
Data =&t IExperiment‘lZData j
N L| Exhaust_...| Intake_On 5
1000 0.4 1 1 32.128| -
1500 0.3 1 1 40384/
1500 0.4 1 1 27 639
1500 0.5 1 1 17.575
2000 0.3 1 1 32 459
2000 0.4 1 1 30.372
2000 0.5 1 1 20.783| LI
Cancel Next = Finigh |
Click Next.

Fill Tables. Click Fill Tables to fill the tables.

CAGE evaluates the model over the number of grid points specified, then calculates

the total square error between this mesh model and the feature values. CAGE adjusts
the table values until this error is minimized, using Lsqnonlin if there are no
gradient constraints, otherwise fmincon is used with linear constraints to specify the
gradient of the table at each cell.

The graph shows the change in RMSE as the optimization progresses.
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<) Feature Fill Wizard o [=] S

Fill Tables
Press 'Fill Takles' to fill the tables based on the settings on the previous panes.

Tolerance: &-006

Srroathing: h

RMSE = 4.9174e-009.

Fill Tables 3
Etop [~ Feature madel
[~ Fill model with links

o 1 [~ Plat
[ Plat errar
0 5 10 5 20 [~ Surface

[~ Surface error

Cancel = Back ezt = Finish

You can enter a value in the Smoothing edit box to apply a smoothing penalty to
the optimization. The Smoothness penalty uses the second derivative to avoid
steep jumps between adjacent table values. There is a penalty as smoothing
trades smoother tables for increased error. Enter a smoothing factor (0-Inf) and
click Fill Tables to observe the difference in the resulting RMSE and the table
shape. Keep increasing the value until you reach the required smoothness. If you
go too far the results will be a flat plane.

Select the Create dataset check box to create a dataset containing the output
values at each specified grid point.

Select the Feature model check box to create a feature model (on finishing the
feature fill wizard) that is a static snapshot of the feature with its links included
inside the feature model. If these links are features then the link is bundled up
within the feature model of the feature being filled.

Select the Fill model with links check box to create a model (on finishing the
feature fill wizard) that is a static snapshot of the fill model with its links
connected to the model inputs (visible in the Connections diagram, in the Models
view).
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* Select the remaining check boxes to display plots when you close the Wizard. You
can see plots of error against all the variables (Plot), error between feature and
model (Error), table surface and error surface.

You can click Back to return to previous screens and fill more tables, or you can click
Finish. When you click Finish to dismiss the wizard, the plots with selected check
boxes appear.

When you have completed a calibration, you can export your feature. For information, see
“Importing and Exporting Calibrations” on page 3-52.

Saving and Reusing Feature Fill Settings

After feature filling, your settings are remembered by the Feature Fill Wizard and saved
in the Feature Fill Settings pane in the Feature view. You can run and manage your saved
fill settings from the Feature Fill Settings pane.

* The Feature Fill Settings table displays all saved fill settings for the selected feature.

* Ifyou select Feature > Fill Feature (or the toolbar button) and there are no saved
settings, after you run the wizard a new fill settings row appears in the table.

» If you select Feature > Fill Feature (or the toolbar button) and you have selected a
saved fill setting, you open the Feature Fill wizard with those settings.

» To define new fill settings starting from the defaults, select Feature > New Fill
Setting or click the New button next to the table in the Feature Fill Settings pane.
This opens the Feature Fill Wizard with no saved settings, and creates a new saved fill
setting in the table.

* Torerun a particular saved setting, double-click the item in the Feature Fill Settings
pane. The Feature Fill Wizard opens with your saved settings selected, so you can click
Next to reach the Fill Tables screen and fill the tables again.

» Torerun all saved fill settings in your feature, select Feature > Run All Fill Settings.

* To copy and modify some saved settings, select the row in the Feature Fill Settings
and select Feature > Duplicate Selected Fill Setting or click the Duplicate button
next to the table. Double-click the new settings to open the Feature Fill Wizard and
make any desired changes in the wizard screens.

* To delete all saved fill settings for the selected feature, select FeatureClear All Fill
Settings.
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Filling Tables by Extrapolation

Filling a table by extrapolation fills the table with values based on the values already
placed in the extrapolation mask. The extrapolation mask on page 4-32 is described
below. You can also choose to extrapolate automatically after filling cells in the mask in
the “Filling and Optimizing Table Values” on page 4-24.

To fill a table by extrapolating over a preselected mask, click ““ or select Table >
Extrapolate .

This extrapolation does one of the following:
+ If the extrapolation mask has only one value, all the cell values change to the value of

the cell in the mask.

« If the extrapolation mask has two or more colinear values, the cell values change to
create a plane parallel to the line of values in the mask.

» If the extrapolation mask has three or more coplanar values, the cell values change to
create that plane.

+ If the extrapolation mask has four or more ordered cells (in a grid), the extrapolation
routine fills the cells by a grid extrapolation.

» If the extrapolation mask has four or more unordered (scattered) cells, the
extrapolation routine fills the cell values using a thin plate spline interpolant (a type of
radial basis function).

Using the Extrapolation Mask

The extrapolation mask defines a set of cells that form the basis of any extrapolation.

For example, a speed-load (or relative air charge) table has values in the following ranges
that you consider to be accurate:

* Speed 3000 to 5000 rpm
* Load 0.4 t0 0.6

You can define an extrapolation mask to include all the cells in these ranges. You can then
fill the rest of your table based on these values.

To add or remove a cell from the extrapolation mask,
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1 Right-click the table.

2 Select Add To Extrapolation Mask or Remove From Extrapolation Mask from
the menu.

Cells included in the extrapolation mask are colored yellow.
Creating a Mask from the Boundary Model or Predicted Error

You can automatically generate an extrapolation mask based on the boundary model or
prediction error. Prediction error (PE) is the standard deviation of the error between the
model and the data used to create the model.

To generate a mask automatically,

1 Select Table > Extrapolation Mask > Generate From Boundary Model or
Generate From PE

2 Ifyou select PE, a dialog appears where you must set the PE threshold to apply, and
click OK.

The cells in the table either within the boundary model or where the prediction error is
within the threshold now form the extrapolation mask, and thus are colored yellow.
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Initialize Tables and Normalizers

4-34

In this section...

“Initializing a Feature” on page 4-34
“Initializing Breakpoints” on page 4-36
“Initializing Table Values” on page 4-36

Initializing a Feature

Note You might not need to initialize your tables if you imported your strategy with
tables already initialized. If so, proceed to the Feature Fill Wizard to fill your tables. See
“Optimize Table Values” on page 4-24. If you want to initialize, continue reading the
current page.

You can initialize a feature to set the values of the normalizers over the range of each
variable and put specified values into each cell of the tables. A table that is already
initialized provides a useful starting point for a more detailed calibration.

For example, a simple feature for maximum brake torque (MBT) consists of the following
tables:

* A speed (N), load (L) table
* A table to account for the behavior of air/fuel ratio (A4)

Initializing this feature sets the values of the normalizers for speed, load, and AFR over
the range of each variable and put specified values into each cell of the two tables.

To initialize the feature, perform the following steps:

Click E . This opens the Feature Initialization Options dialog box, as shown.
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Enter the ranges for the breakpoints in your normalizers. In the preceding example,
these are the breakpoint ranges:

L hasrange 0.2 0.811.
N has range 750 6500.
A hasrange 11 17.6.

Enter the initial table value for each cell in each table. Above, the cell values are

Table NL has initial value 0.
Fn A has initial value 0.

Click OK to initialize the feature.
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Note The default values in this dialog box are taken from the variable dictionary. If
you clear any Enable box, the associated table or normalizer is left unchanged.

Initializing Breakpoints

You can initialize normalizer breakpoints individually if desired, or initialize the whole
feature (see “Initializing a Feature” on page 4-34). Initializing the breakpoints places the
breakpoints at even intervals along the range of the variable defined for the normalizer.
When you add a table and specify the inputs in the Table Setup dialog, CAGE
automatically initializes the normalizers of the table by spacing the breakpoints evenly
over the ranges of the selected input variables. If you have edited breakpoints you can
return to even spacing by using the Initialize function.

To space the breakpoints evenly,

1 Clicklll on the toolbar or select Normalizer > Initialize.

2 In the dialog box, enter the range of values for the normalizer.
3 Click OK.

For example, for a torque table with two normalizers of engine speed and load, you can
evenly space the breakpoints of both normalizers over the range 500 rpm to 6500 rpm
for speed and 0.1 to 1 for the relative air charge. To do this, in the dialog box you enter
500 6500 for the speed normalizer, N, ,and 0.1 1 for the load normalizer, L.

Initializing Table Values

You can initialize tables individually if desired, or initialize the whole feature (see
“Initializing a Feature” on page 4-34). Initializing table values sets the value of every cell
in the selected table to a constant. You can do this when you set up a table (see “Adding,
Duplicating and Deleting Tables” on page 3-9) or later.

To initialize the values of the table,

1 Click E or select Table > Initialize.

2 In the dialog box that appears, select the constant value that you want to insert into
each cell.

When initializing tables, you should think about your strategy. Filling with zeros can cause
a problem for some strategies using "modifier" tables. For example, your strategy might
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use several speed-load tables for different values of AFR, or you might use an AFR table
as a "modifier" to add to a single speed-load table to adjust for the effects of different AFR
levels on your torque output.

Be careful not to initialize modifier tables with 0 if they are multipliers in your strategy. In
this case, solving results in trying to divide by zero. This operation will fail. If your table is
a modifier that is added to other tables, you should initially fill it with zeros; if it is a
modifier that multiplies other tables, you should fill it with 1s.
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Optimize Normalizer Breakpoints

4-38

In this section...

“Overview of Calibrating Normalizers” on page 4-38
“Optimizing Breakpoints” on page 4-39

“Example of Breakpoint Optimization” on page 4-41
“Viewing the Normalizer Comparison Pane” on page 4-43

Overview of Calibrating Normalizers

Note If you want to optimize the breakpoints for the normalizers, you should do this
before optimizing table values using the Feature Fill Wizard.

Select a normalizer in the tree display. This displays the Normalizer view, where you can
calibrate the normalizers.

This section describes how you can use CAGE to space the breakpoints over the range of
the normalizers.

P R

1. Initialize 2. Fill 3. Optimize

To space the breakpoints, either click the buttons on the toolbar or select from the
following options on the Normalizer menu:

* Initialize
This spaces the breakpoints evenly along the normalizer. For more information, see
“Initializing Breakpoints” on page 4-36.

+ Fill
This spaces the breakpoints by reference to the model. For example, you can place

more breakpoints where the model curvature is greatest. For more information, see
“Optimizing Breakpoints” on page 4-39.
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* Optimize

This moves the breakpoints to minimize the least square error over the range of the
axis. To optimize normalizers, each normalizer must have a single variable input that
is an input to the model (and must be different from the input to the other normalizer
for 2D tables).

For more information, see “How CAGE Optimizes Normalizer Breakpoints” on page 4-
5.

Note Fill and Optimize are only available when you are calibrating with reference to a
model, when you are performing Feature calibrations.

For more information about the Normalizer view controls, see “Table Normalizers” on
page 3-39.
Optimizing Breakpoints

Optimizing breakpoints spaces the breakpoints by reference to the model. For example,
one method places the majority of the breakpoints where the curvature of the model is
greatest. This option is only available when you are performing Feature calibrations. To
learn more, see “How CAGE Optimizes Normalizer Breakpoints” on page 4-5.

For example, a model of the spark angle that produces the maximum brake torque (MBT)
has the following inputs: engine speed N, relative air charge L, and air/fuel ratio A. You
can space the breakpoints for engine speed and relative air charge over the range of
these variables by referring to the model.

To space the breakpoints based on model curvature, perform the following steps:

Click L= or select Normalizer > Fill.

The Breakpoint Fill Options dialog box opens.
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<) Breakpoint Fill Options =101 =]
E]:Fi"E P_Tahle ML
Fill method: [sharedweCurv =]
Range L: IW
Range M: IW
£

|:F|ange: I 1117
Murmber of points: I 2

QK. | Cancel |

Choose the appropriate method to space your breakpoints, from the drop-down menu
in the dialog box.

The preceding example shows ShareAveCurv. For more information about the
methods for spacing the breakpoints, see “Filling Methods” on page 4-6.

Enter the ranges of the values for the normalizers.

The preceding example shows Range N 500 6500, and Range L, 0.1 1.
Enter the ranges of the other model variables.

CAGE spaces the breakpoints by reference to the model. It does this at selected
points of the other model variables. The example shows 11 17 for the Range of A
and 2 for the Number of points. This takes two slices through the model at A = 11
and A = 17. Each slice is a surface in N and L. That is, MBT(N, L, 11) and MBT(N, L,
17).

CAGE computes the average value of these two surfaces to give an average model
MBTy(N, L).

If you set Number of points to one, and specify a range, then the mean of the range
is chosen as the evaluation point.

Click OK.

Note If any of the breakpoints is locked, each group of unlocked breakpoints is
independently spaced according to the selected algorithm.




Optimize Normalizer Breakpoints

If you increase the number of slices through the model, you increase the computing time
required to calculate where to place the breakpoints.

After optimizing breakpoints, you can optimize table values. See “Optimize Table Values”
on page 4-24.

Example of Breakpoint Optimization

For an example of breakpoint optimization, say you have a model of the spark angle that
produces the MBT (maximum brake torque). The model has the following inputs: engine
speed, N, relative air charge, L, and air/fuel ratio, A. You can optimize the breakpoints for
N and L over the ranges of these variables.

To optimize the breakpoints, perform the following steps:

1 Ensure that the optimization routine works over reasonable values for the table by
choosing one of these methods:

a Select Normalizer > Initialize.
b  Select Normalizer > Fill.

Click @ on the toolbar or select Normalizer > Optimize.

This opens the following dialog box.
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=} Breakpoint Optimization @ . 10O x|

EI:EI ptBP_Table ML

BHL
—Hange: I 02 08
—Murnber of paints: I 36

=M
—Hange: Iw
—Murnber of paints: ISE—
=]

—Hange: 14.3

—Murnber of paints: I 1

FRearder Deleted Breakpaints [

2k, Cancel

3  Enter the ranges for the normalizers.

The example shows 0.2 0.811 for the Range of L, and 750 6500 for N.
4 Enter the appropriate number of grid points for the optimization.
This defines a grid over which the optimization works. In the preceding example, the

number of grid points is 36 for both L and N. This mesh is combined using cubic
splines to approximate the model.

5 Enter ranges and numbers of points for the other model variables.

The example shows a Range of A of 14. 3 and the Number of points is 1.
6 Decide whether or not to reorder deleted breakpoints, by clicking the radio button.
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If you choose to reorder deleted breakpoints, the optimization process might
redistribute them between other nondeleted breakpoints (if they are more useful in a
different position).

For information about deleting breakpoints, see “Editing Breakpoints” on page 3-42.
7 Click OK.

CAGE calculates the table filled with the mesh at the current breakpoints. Then CAGE
calculates the total square error between the table values and the mesh model.

The breakpoints are adjusted until this error is minimized, using nonlinear least squares
optimization (See the reference page for Lsqnonlin).

When optimizing the breakpoints, it is worth noting the following:

* The default range for the normalizer variable is the range of the variable.
* The default value for all other model variables is the set point of the variable.
* The default number of grid points is three times the number of breakpoints.

Viewing the Normalizer Comparison Pane

To view or hide the comparison pane, click i«--a;, the “snapper point” at the bottom of
the normalizer display panes.

[ b i}
Plot type: IFeature (blue) & Model =
Festure and Madel [nputs
0.2 to 0.8, 20 poirts
n 1000 ta 5000, 20 poirits
afr 14,535
spk 2551
Error Statistics for Graph
Maimum shsolute errar 4875
Mean sguare efrar 11 .36 loacd 0.2 n
Total zquare error 4543
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The comparison pane displays a comparison between the following:

» A full factorial grid filled using these breakpoints
* The model

Note This is not a comparison between the current table values and the model. To
compare the current table values and the model, see “Compare the Strategy and the
Model” on page 4-46.

To make full use of the comparison pane,

Adjust the ranges of the variables that are common to the model and table.
2 Adjust the values selected for any variables in the model that are not in the selected
table.

The default for this is the set point of the variable, as specified in the variable
dictionary. For more information, see “Using Set Points in the Variable Dictionary” on
page 2-11.

3 Check the number of points at which the display is calculated.
Check the comparison between the table and the model.

Right-click the comparison graph to view the error display on page 4-44.

5 Check some of the error statistics for the comparison, and use the comparison to
locate where improvements can be made.

Error Display

The comparison pane can also be used to display the error between the model and the
'generated table' (grid filled using these breakpoints).



Optimize Normalizer Breakpoints

Error Display in the
Comparison Pane

QoS g .o

pozd.

0015 K &

0.01 4

0.005 -

06 5000

4000

3000

o2 qpop 2000

To display the error, select one of the Error items from the Plot type drop-down list.

This changes the graph to display the error between the model and the table values at
these breakpoints.

You can display the error data in one of the following ways:

Error (Table—Model). This is the difference between the feature and the model.
Squared Error. This is the error squared.

Absolute Error. This is the absolute value of the error.

Relative Error. This is the error as a percentage of the value of the table.
Absolute Relative Error (%). This is the absolute value of the relative error.

See Also

“Compare the Strategy and the Model” on page 4-46

This describes the comparison made when a table node is selected in the tree display.
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Compare the Strategy and the Model

4-46

In this section...

“Display the Strategy and the Model” on page 4-46
“Display the Error Between the Strategy and the Model” on page 4-48

Display the Strategy and the Model

Note The Feature/Model Comparison is only useful for simple filling strategies. For
this reason the pane is collapsed by default. To view the comparison pane, Click ra-a,
the “snapper point” at the bottom of the table display panes.

When you calibrate a strategy, or collection of tables, by reference to a model, it is useful
to compare the strategy and the model. When viewing your feature tables, use the lower
comparison pane to graphically investigate your strategy compared with the model, as
shown in the following example. To view or hide the comparison pane, select View >
Feature/Model Comparison.

Note In a table view you see a comparison between the current strategy values and the
model, unlike the comparison pane from the normalizer node, which compares the model
and a full factorial grid filled using the breakpoints. See “Viewing the Normalizer
Comparison Pane” on page 4-43.




Compare the Strategy and the Model

The ranges of the common variables

/— Number of points in the comparison display

\
Plot type\l Festure (blue) & Model -/
Feature and \odel Inputs /
MName Yalue /
N \ | 500t 6500, 20 poirts
L 0.1to1, 20 points
A, 14.35
SPK / 25
Error statistics /
haximum error / 24.45 =
Mean square error / 9.961 -
Total square error 39684 L‘

Variables in the model,
not in the table

Error between the

Comparison of the strategy
strategy and the model and the model

To make full use of the comparison-of-results pane,

1

Check the ranges of the variables that are common to the model and table. For each
variable check the number of points at which the display is calculated. Double-click
to edit any variable range or number of points.

Check the values selected for any variables in the model that are not in the selected
table. The default for this is the set point of the variable's range. Double-click to edit.

Check the comparison between the table and the model. You can rotate this
comparison by clicking and dragging, so that you can view all parts of the
comparison easily.

Use the Plot Type drop-down menu to display the error statistics for the comparison.
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Note Use the comparison pane for a quick visual check of your strategy results
compared to the model. For more flexibility to view your feature, select Tools > Surface
Viewer. See “Viewing a Model or Strategy” on page 10-3.

The comparison pane does not change as you change table, because it displays a
comparison between the whole feature and the model, not individual tables. Note if you
use links the comparison pane is not showing a true comparison. For example, in the MBT
Spark Estimator Problem in the Gasoline Engine Calibration case study, the cam inputs
are not constant, but the comparison pane shows the comparison using constant values
for the cam timings.

Display the Error Between the Strategy and the Model

The comparison-of-results pane can also be used to display the error between the model
and the strategy.

To display the error, select one of the Error options from the Plot Type drop-down
menu. This changes the graph to display the error between the model and the strategy.

You can display the error data in one of the following ways:

* Error (Feature-Model). This is the difference between the feature and the model.
* Squared Error. This is the error squared.

* Absolute Error. This is the absolute value of the error.

* Relative Error (%). This is the error as a percentage of the value of the model.

* Absolute Relative Error (%). This is the absolute value of the relative error.
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When you have completed a calibration, you can export your feature. For information, see
“Exporting Calibrations” on page 3-52.
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* “Performing a Tradeoff Calibration” on page 5-2

» “Setting Up a Tradeoff Calibration” on page 5-7

* “Filling Tables in a Tradeoff Calibration” on page 5-12

* “Setting Values of Variables” on page 5-14

* “Choosing a Table Value at a Specific Operating Point” on page 5-16
* “Controlling Table Extrapolation Regions” on page 5-23

* “Point-by-Point Model Tradeoffs” on page 5-25
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Performing a Tradeoff Calibration

5-2

In this section...

“Procedure for Filling Tables in a Tradeoff Calibration” on page 5-2
“Automated Tradeoff” on page 5-3

Procedure for Filling Tables in a Tradeoff Calibration

LN
AL

Tradeaff

A tradeoff calibration is the process of calibrating lookup tables by adjusting the control
variables to result in table values that achieve some desired aim.

For example, you might want to set the spark angle and the air/fuel ratio (AFR) to achieve
the following objectives:

* Maximize torque
* Restrict CO emissions
The data in the tradeoff is presented in such a way as to aid the calibrator in making the

correct choices. For example, sometimes the model is such that only a slight reduction in
torque results in a dramatic reduction in CO emissions.

The basic procedure for performing tradeoff calibrations is as follows:

Set up the variables and constants. See “Setting Up Variable Items” on page 2-8.
Set up the model or models. See “Setting Up Models” on page 2-16.

Set up the tradeoff calibration. See “Setting Up a Tradeoff Calibration” on page 5-
7.

Calibrate the tables. See “Filling Tables in a Tradeoff Calibration” on page 5-12.
5 Export the normalizers, tables, and tradeoffs. See “Exporting Calibrations” on page 3-
52.

You can also use regions to enhance your calibration. See “Controlling Table
Extrapolation Regions” on page 5-23.




Performing a Tradeoff Calibration

See also
* “Tradeoff Calibration” for an example.

This is a tutorial giving an example of how to set up and complete a simple tradeoff
calibration.

* “Automated Tradeoff” on page 5-3 is a guide to using the optimization functionality
in CAGE for tradeoffs.

The normalizers, tables, and tradeoff form a hierarchy of nodes, each with its own view
and toolbar.

Automated Tradeoff

* “Using Automated Tradeoff” on page 5-3
* “What Are Appropriate Optimizations for Automated Tradeoff?” on page 5-5

Using Automated Tradeoff

The easiest way to automate trading off competing objectives is to use CAGE’s
optimization features and then use the results to update tradeoff tables using the Fill
Tables From Optimization Results wizard. To learn more, see “Filling Tables from
Optimization Results” on page 7-9.

You can also use a limited subset of optimization features directly in your tradeoff view, to
run an optimization routine and fill your tradeoff tables. Once you have set up an
optimization and a tradeoff, you can run an automated tradeoff. As with any other tradeoff
you need at least one table. You can apply an optimization to a cell or region of a tradeoff
table, or the whole table, and the tradeoff values found are used to fill the selected cells.
If only filling selected cells you can then fill the entire table by extrapolation.

You must first set up an optimization to use automated tradeoff.

There is an example automated tradeoff in the optimization tutorial example,
“Optimization and Automated Tradeoff”.

1  You need a CAGE session with some models and a tradeoff containing some tables.

* See “Performing a Tradeoff Calibration” on page 5-2 for instructions on setting up
a tradeoff. You could use the tradeoff tutorial to generate a suitable example
session (see the example “Tradeoff Calibration”).
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You also need to set up an optimization before you can run an automated tradeoff.
Objectives and constraints must be set up.

* For an example work through the step-by-step tutorial to set up some
optimizations and then apply them to a tradeoff table. See “Optimization and
Automated Tradeoff”.

Go to the tradeoff table you want to automate. You can select some table cells to
apply the optimization to, or use the whole table, or fill only previously saved tradeoff
points. Note that if you define a large region with many cells or a whole table it can
take a long time to complete the optimization. You can select individual cells, or click
and drag to select a rectangle of cells. The selected cells do not have to be adjacent.
Try a small region (say up to six cells) to begin with. Right-click selected cells and
select Extrapolation Regions -> Add Selection or use the toolbar button (to add
selection to extrapolation regions).

To apply optimization: click in the toolbar, or select Inputs -> Automated
Tradeoff.

* A dialog appears that allows an appropriate (defined below) optimization to be
selected from the current project.

Note You must set up an optimization to run before you can perform an
automated tradeoff. You do this in the Optimization view. See also “Setting Up
Optimizations” on page 6-8.

The set of cells in the region you have selected becomes the operating point set for
the optimization. The cell/region breakpoint values are used to replace the fixed
variable values in the selected optimization. Note that the existing fixed variable
values are reset to their previous state at the end of the automated tradeoff.

If previous tradeoff values have been applied to a cell, those values are used for free
variable initial values and non-table-axis fixed variables; otherwise the set points are
used.

The optimization is run as if you were clicking Run from the Optimization view. See
“Run Optimizations” on page 6-59.

Results are placed in the tradeoff object, that is, values for the tables involving the
free variables or values for the tables for constraint or objective models. If the
routine applied gives more than one solution, for example, an NBI optimization, then
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a solution which tries to trade off all objectives is placed in the tradeoff tables. Every
cell in the defined region is filled.

The cells of the region become part of the extrapolation mask (as if apply point has
been applied); so if you want you can then click Extrapolate in the toolbar to fill the
rest of the table from your optimized automated tradeoff.

What Are Appropriate Optimizations for Automated Tradeoff?

The list of all optimizations in the project is filtered. To be eligible for selection,

The optimization must be ready to run (toolbar button enabled).

The variables in the axes of the tradeoff tables must not be free variables in the
optimization. For example, if one of the axes is speed, then speed cannot be a free
variable.

The fixed variables must be a subset of the variables in the axes of the tradeoff tables.
For example, if the optimization requires variables Speed and Load, then these must
be the axes variables in the tradeoff table.

The optimization must either have N runs with all variables of length 1, or a single run
with all variables of length N.

Multimodel Tradeoff

For a multimodel tradeoff, things work slightly differently. The multimodel is only defined
for certain cells in the tradeoff tables. These are the operating points that were modeled
using the Model Browser part of the toolbox. Such cells are marked with a model icon as
shown in the example, and you should select these for running the automated tradeoff.
You can select any region, but the optimization can only find values for the operating
points defined by the multimodel.
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Setting Up a Tradeoff Calibration

In this section...

“Overview of Setting Up a Tradeoff” on page 5-7
“Adding a Tradeoff” on page 5-8
“Adding Tables to a Tradeoff” on page 5-8

“Displaying Models in Tradeoff” on page 5-10

Overview of Setting Up a Tradeoff

A tradeoff calibration is the process of filling lookup tables by balancing different
objectives.

Typically there are many different and conflicting objectives. For example, a calibrator
might want to maximize torque while restricting nitrogen oxides (NOX) emissions. It is
not possible to achieve maximum torque and minimum NOX together, but it is possible to
trade off a slight reduction in torque for a reduction of NOX emissions. Thus, a calibrator
chooses the values of the input variables that produce this slight loss in torque instead of
the values that produce the maximum value of torque.

A tradeoff also refers to the object that contains the models and tables. Thus, a simple
tradeoff can involve balancing the torque output while restricting NOX emissions.

After you set up your variable items and models, you can follow the procedure below to
set up your tradeoff calibration:

1 Add a tradeoff. This is described in the next section, “Adding a Tradeoff” on page 5-

8.

2 Add tables to the tradeoff. This is described in “Adding Tables to a Tradeoff” on page
5-8.

3 Display the models. This is described in “Displaying Models in Tradeoff” on page 5-
10.

This section describes steps 1, 2, and 3 in turn.

When you finish these steps, you are ready to calibrate the tables.
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Adding a Tradeoff

To add a tradeoff to your session, select File > New > Tradeoff. This automatically
switches you to the Tradeoff view and adds an empty tradeoff to your session.

An incomplete tradeoff is a tradeoff that does not contain any tables. If a tradeoff is
incomplete, it is displayed as @@ in the tree display. If a tradeoff is complete, it is displayed
as =& in the tree display.

After you add a tradeoff you must add tables to your tradeoff.

Adding Tables to a Tradeoff

1

Add a table by selecting Tradeoff -> Add New Table or click E in the toolbar. You
can also add existing tables from your CAGE session; see “Adding Existing Tables” on
page 5-10.

Note that you must select the top tradeoff node in the tree display to use the
Tradeoff menu. This is automatically selected if your tradeoff has no tables yet (it is
the only node). You must also add at least three variables (in the variable dictionary)
to your project before you can add a table, because CAGE needs a variable to fill the
table and two more variables to define each of the two normalizers.

A dialog box opens.
Rk

Mame: INew_QD_TabIe

Rowys: N input: -
-

W input: IN I

Select... |
Clear |

Cancel | Help |

Columns:

| 10 E|:

| 10 E|:

Imitial vl I ] EI:
(039 |

Fill tahle swyith:

Enter the name for the table.

If your tradeoff already contains one or more tables, when you add additional tables
they must be the same size and have the same inputs (and therefore have the same
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normalizers). So if your tradeoff has existing tables, you can only enter the new table
name and the initial value.

For the first table in a tradeoff, you must set the normalizer inputs and sizes:

a Edit the names for the X and Y normalizer inputs (the first two variables in the
current variable dictionary are automatically selected here).

b  Enter sizes for each of the normalizers (Y input = rows, X input = columns)

Enter an initial value to fill the table cells, or leave this at zero.

Click Select to choose a filling item for a table. A dialog opens where you can select
from the models and variables in your session.

<} Select Filling Item

Select the item you weant to fill table with:

|tem | Type |
XN Y ariable

x L " ariable
XA Y ariable

x 5PK " ariable

X E Y ariable
A TO_Madel MEC madel
4\ HOFLOW_Model MEC model

— List optionzs

™ Display models

" Display variahles
{* Display all tems
[¥ Cnly show items thet are not filing snother table

QK I Cancel

a Depending on what kind of input you want, click the radio buttons to display
models or variables or both. You can choose to also show items that are filling
another table by clearing the check box.

b  Select the filling item for the table and click OK.
Click OK to dismiss the Table Setup dialog and create the new table.

CAGE adds a table node to the tradeoff tree. Note you can still change the input for
the table as follows. Double-click the new table in the list under Tables In Tradeoff,
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or click to select the table (it is selected automatically if it is the only table in the

tradeoff) and then click Change Filling Item (@) in the toolbar. This is also in the
Tradeoff menu and the right-click context menu.

The Select Filling Item dialog appears where you can select inputs to fill the table, as
described above.

Repeat this procedure for each new table you want to add. Each additional table in
the tradeoff must have the same normalizers as the first table, so you do not have to
select normalizer inputs and sizes repeatedly. For each new table you only have to
enter the name and initial value.

Adding Existing Tables

1

Add a table by selecting Tradeoff > Add Existing Tables or click @ in the toolbar.

A dialog appears where you can select from a list of tables in the current session.

Select a table and click OK. It may be helpful to first select the check box to only
show suitable tables that can be added to the tradeoff.

Displaying Models in Tradeoff

To display models when viewing tables in the tradeoff display,

Highlight the tradeoff node in the tree.
From the Available Models list, select the one you want to display.

Models that are filling a table are automatically displayed.

Click ﬁ Add Model to Display List in the toolbar or 2| in the Additional Display
Models pane to move the selected model into the Display Models pane. To quickly
add all available models to the display list, click the display button repeatedly and
each successive model will be added.

Repeat steps 2 and 3 to add all the models you want to the display list.
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Additioral Display Models

Ayailable Models | Type | Dizplay Models | Type
4\ TO_ModelM, L. &, SPE. E) MEC model
4\ MORFLOW_ModelM, L, A, SP... MBC model

Removing a Model
In the Display Models list, select the model that you want to remove.

Click ﬁ in the toolbar, or <lin the Display Models pane, to move the selected
model into the Available Models pane.

3 Repeat until you have cleared all the appropriate models.

Once you have displayed all the models that you want to work with, you are ready to
calibrate your tables.
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Filling Tables in a Tradeoff Calibration

5-12

Selecting a table node in the tree display enables you to view the models that you have
displayed and calibrate that table.

To calibrate the tables,

Select the table that you want to calibrate.
Highlight one operating point from the table.
Set the values for other input variables.

For information, see “Setting Values of Variables” on page 5-14.
Determine the value of the desired operating point.

For instructions, see “Choosing a Table Value at a Specific Operating Point” on page
5-16.

Click @ to apply this value to the lookup table.

This automatically adds the point to the extrapolation mask.

Repeat the steps to choose values at various operating points.

IJ,-_\-‘E"

Extrapolate to fill the table by clicking " in the toolbar.

For information, see “Filling Tables by Extrapolation” on page 4-32.

You can also edit table cell values manually by typing values, or right-click to Copy or
Paste values.

After you complete all these steps you can export your calibration. For information, see
“Exporting Calibrations” on page 3-52.

Notice that the graphs colored green indicate how the highlighted table will be filled:

If a row of graphs is highlighted, the table is being filled by the indicated model
evaluation (the value shown at the left of the row).

If the column of graphs is green, the table is being filled by the indicated input
variable (shown in the edit box below the column).

The next sections describe the following in detail:
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* “Setting Values of Variables” on page 5-14
* “Choosing a Table Value at a Specific Operating Point” on page 5-16
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Setting Values of Variables

In this section...

“Setting Values for Individual Operating Points” on page 5-14

“Setting Values for All Operating Points” on page 5-15

Setting Values for Individual Operating Points

Typically the models that you use to perform a tradeoff calibration have many inputs.
When calibrating a table of just one input, you need to set values for the other inputs.

Value: 40 ! o e T P — ] — — +— —_ '
4 |-t g ! : : ————— = |
32318 I | e — T —
AN 200 | f--i-e-ee- AR I & S b -1 - 3---ooe-
T ' ' ' i- '
- ' ' ' ' ’ ' ' '
- I b N L
|} F==1====== TE====" == bl il F """ av<c-1 | f°-°-°°°==-° A== ===== [l
g A T T
20 P — f----- chofee-d p------ ﬂ\ ....... L
Yalue: 4000 » ; : : : ] : 1 :
79.298 : : : : ] : ' :
Sl EA | k! TR : -4 - B
2 o000] | fo-ioooe-- | J—— /(‘ ------ LS R S L —
z : : : : ] : : :
9 i H L L 1 ; L
e I i e b 22 P
o : 1 : W . :
= D“ T TS ™ R T T
-1000 3 : : : - ] - ' :
h. 4 4 b 4
12 14 16 0 20 40 0 5 10
SPK E
| = = [ 19.0909 2 | J =
P
/ L /
Model output values Value of A Value of SPK Value of E

To set values for inputs at individual operating points,
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1 Highlight the operating point in the lookup table.
2 Use the edit boxes or drag the red bars to specify the values of the other variables.

In the preceding example, the spark table is selected (the SPK graph is colored green).
You have to specify the values of AFR (A) and EGR (E) to be used, for example:

1 Select the spark table node.
2 Click in the edit box for A and set its value to 14. 3.
3 Click in the edit box for E and set its value to 0.

The default values are the set points of variables, which you can edit in the Variable
Dictionary.

Setting Values for All Operating Points

For example, if you are using a tradeoff to calibrate a table for spark angle, you might
want to set the initial values for tables of air/fuel ratio (AFR) and exhaust gas recycling
(EGR).

To set constant values for all the operating points of one table,

1 Highlight the table in the tree display.

2 Select one operating point in the table.

3  Enter the desired value of the cell.

4 Right-click and select Extrapolation Mask > Add Selection.
This adds the cell to the extrapolation mask.

5

Click & to extrapolate over the entire table.

This fills the table with the value of the one cell.
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Choosing a Table Value at a Specific Operating Point
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Performing a tradeoff calibration necessarily involves the comparison of two or more
models. For example, in this case, the tradeoff allows a calibrator to check that a value of
spark that gives peak torque also gives an acceptable value for the NOX flow model.

1 To select a value of an input, do one of the following:

* Drag the red line.

* Right-click a graph and select Find the minimum, maximum, or turning point of
the model as appropriate (also in the toolbar and Inputs menu).

* Click the edit box under the graph as shown above and enter the required value.

2 Once you are satisfied with the value of your variable at this operating point, you
apply this value to the table by doing one of the following:
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Press Ctrl+T.
Click @ (Apply Table Filling Valu

es) in the toolbar.

Select Tables > Apply > Fill to Table.
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Find Maximum, Minimum, or

Right-clicking a graph enables you to

Turning Point of Graphs
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* Find minimum of model output with respect to the input variable
* Find maximum of model output with respect to the input variable
* Find turning point of model with respect to the input variable

These first three options are also in the Inputs menu.
* Reset graph zooms (also in the View menu)

There are also toolbar buttons to find the minimum, maximum and turning point of the
selected model graph.

Using Zoom Controls on the Graphs

To zoom in on a particular region, shift-click or click with both mouse buttons
simultaneously and drag to define the region as a rectangle.

To set the axes limits to the constraint boundary, select View > Zoom Inside
Constraints. This zooms the tradeoff plots inside the constraint boundaries, so you can
explore competing objectives in valid regions only. This option reduces the y axis scale as
the plots do not include regions where the model is extrapolating.

To zoom out to the original graph, double-click the selected graph, or use the right-click
Reset Graph Zooms option (also in the View menu).

Note Zooming on one graph adjusts other graphs to the same scale.

Configuring Views
Selecting the View menu offers you the following options:
+ Table History

This opens the History display. For information, see “Using the History Display” on
page 3-23.

* Configure Hidden Items

This opens a dialog box that allows you to show or hide models and input variables.
Select or clear the check boxes to display or hide items. This is particularly useful if
you are trading off a large number of models or models that have a large number of
factors.
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Display Confidence Intervals

When you select this, the graphs display the 99% confidence limits for the models.
Display Common Y Limits

Select this to toggle a common y-axis on and off for all the graphs. You can also press
CTRL+Y as a shortcut to turn common Y limits on and off.

Display Constraints

Select this to toggle constraint displays on and off. Regions outside constraints are
shown in yellow on the graphs, as elsewhere in the toolbox.

Graph Size

Select from the following options for number and size of graphs:

* Display All Graphs
* Small

* Medium

* Large

Large Graph Headers

Select this to toggle graph header size. The smaller size can be useful when you need
to display many models at once.

Reset Graph Zooms

Use this to reset if you have zoomed in on areas of interest on the graphs. Zoom in by
shift-clicking (or clicking both buttons) and dragging. You can also reset the zooms by
double-clicking, or by using the right-click context menu on the graphs.

Display Table Legend

Select this to toggle the table legend display on and off. You might want more display
space for table cells once you know what the legend means. The table legend tells you
how to interpret the table display:

* Cells with a tick contain saved values that you have applied from the tradeoff
graphs (using the 'Apply table filling values' toolbar or menu option).
* Yellow cells are in the extrapolation mask.

* Blue cells are in a region mask.

5-19



5 Tradeoff Calibrations

5-20

* Yellow and blue cells with rounded corners are both in a region and the
extrapolation mask.

* Cells with a padlock icon are locked.

Controlling Table Values, Extrapolation, and Locks

Apply Fill to Table

Select this option to apply the values from the tradeoff graphs to the selected table
cell. This option is also in the toolbar, and you can use the keyboard shortcut CTRL+T.

Note that the corresponding cell in all tables is filled with the appropriate input, not
just the cell in the currently displayed table. For example if you have graphs for spark
and EGR inputs, selecting Apply Fill to Table fills the spark table cell with the spark
value in the graphs, and the EGR table cell with the EGR value.

Extrapolation Mask — Also available in the toolbar and the context menu (by right-
clicking a table cell). Use these options to add and remove cells from the mask for
filling tables by extrapolation. Note that cells filled by applying values from the
tradeoff graphs (using the Apply Fill To Table toolbar and menu option) are
automatically added to the extrapolation mask.

¢ Add Selection
* Remove Selection
¢ Clear Mask

Extrapolation Regions — Also available in the toolbar and the context menu (by
right-clicking a table cell). Use these options to add and remove cells from regions. A
region is an area that defines locally where to extrapolate before globally
extrapolating over the entire table. Use regions to define high-priority areas for use
when filling tables by extrapolation. See “Controlling Table Extrapolation Regions” on
page 5-23.

¢ Add Selection
* Remove Selection

* Clear Regions

Extrapolate — This option (also in the toolbar) fills the table by extrapolation using
regions (to define locally where to extrapolate before globally extrapolating) and the
cells defined in the extrapolation mask.
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* Extrapolate (Ignore Regions) — This option fills the table by extrapolation only
using cells in the extrapolation mask.

+ Table Cell Locks — Also available in the context menu by right-clicking a table cell.
Use these options to lock or unlock cells; locked cells are not changed by
extrapolating.

* Lock Selection
* Unlock Selection
* Lock Entire Table
* Clear All Locks

Tradeoff Table Menus

Working With Inputs and Tools

* Reset to Last Saved Values — This option resets all the graph input values to the
last saved value. Also in the toolbar.

* Set to Table Value — This option sets the appropriate input value on the graphs to
the value in the table.

The following three options are only enabled if a graph is selected (click to select, and a
blue frame appears around the selected graph). They are also available in the right-click
context menu on the graphs.

* Find Minimum of model vs input factor

* Find Maximum of model vs input factor

* Find Turning Point of model vs input factor

where model and input factor are the model and input factor displayed in the currently
selected graph, for example, TQ_model vs Spark.

* Automated Tradeoff — Use this option once you have set up an optimization, to apply
that optimization to the selected region of your tradeoff table. See “Automated
Tradeoff” on page 5-3 for information.

Use the Tools menu to open these windows:

* Calibration Manager — opens the Calibration Manager. See “Calibration Manager”
on page 3-27.
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* Surface Viewer — Opens the Surface Viewer. See “Surface Viewer”.
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Controlling Table Extrapolation Regions

In this section...

“What Are Regions?” on page 5-23
“Defining a Region” on page 5-24

“Clearing a Region” on page 5-24

What Are Regions?

A region is an area that defines locally where to extrapolate before globally extrapolating
over the entire table.

For example, consider filling a large table that has twenty breakpoints for each
normalizer by extrapolation. Two problems arise:

* To have meaningful results, you need to set values at a large number of operating
points.

» To set values at a large number of operating points takes a long time.

To overcome this problem, you can

1  Define regions within the lookup table.

2 In each region, set the values of some operating points.
Click % to fill the table by extrapolation.

Each region is filled by extrapolation in turn. Then the rest of the table is filled by
extrapolation. The advantage of using regions is that you can have more meaningful
results by setting values for a smaller number of operating points.

Cells are colored

* Blue with rounded corners if they form part of the extrapolation mask
* Purple background if they are part of a region

* Both if they are part of the extrapolation mask and part of a region.
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Defining a Region
Click and drag to highlight the rectangle of cells in your tradeoff table.

2 To define the region, click = in the toolbar, or right-click and select Extrapolation

Regions > Add Selection, or select the menu option Tables > Extrapolation
Regions > Add Selection.

The cells in the region are colored with purple backgrounds.

Clearing a Region
Highlight the rectangle of cells in your table.

To clear the region, click “L in the toolbar, or right-click and select Extrapolation
Regions > Remove Selection, or select the menu option Tables > Extrapolation
Regions > Remove Selection.

You can clear all regions at once by selecting Clear Regions from the Extrapolation
Regions submenu.
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Point-by-Point Model Tradeoffs

In this section...

“What Is A Point-by-Point Model Tradeoff?” on page 5-25

“Adding a Point-by-Point Model Tradeoff” on page 5-26
“Calibrating Using a Point-by-Point Model Tradeoff” on page 5-26

What Is A Point-by-Point Model Tradeoff?

There are two types of tradeoff that you can add to your session, a tradeoff of
independent models, as described earlier (see “Performing a Tradeoff Calibration” on
page 5-2), or a tradeoff of interconnected models: a point-by-point model (or multimodel)
tradeoff.

A point-by-point model tradeoff is a specially built collection of models from the Model
Browser.

You can build a series of models so that each operating point has a model associated with
it. In the Model Browser, you can export models for a point-by-point model tradeoff from
the test plan node. The models must be two-stage and must have exactly two global
inputs. You can use the point-by-point test plan template to create these models. For more
information see “Fit a Point-by-Point Model”.

The procedure for calibrating by using a point-by-point model tradeoff follows:

1 Import your model and create tables from your point-by-point model. (See “Creating
Tables from a Model” on page 3-4.)

2 Calibrate the tables. (See “Calibrating Using a Point-by-Point Model Tradeoff” on
page 5-26.)

3  Export your calibration. (See “Importing and Exporting Calibrations” on page 3-52.)

The point-by-point model is only defined for certain cells in the tradeoff tables. These are
the operating points that were modeled using the Model Browser part of the toolbox.
These cells have model icons in the table. At each of these operating points, you can use
the model to trade off, and by doing this you can adjust the value in the table. The point-
by-point model is not defined for all other cells in the table and so you cannot use models
to tradeoff. You can edit these cells and they can be filled by extrapolation. You trade off
values at each of the model operating points in exactly the same way as when using
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independent models, as described in “Choosing a Table Value at a Specific Operating
Point” on page 5-16. When you have determined table values at each of the model

operating points, you can fill the whole table by extrapolation by clicking H see “Filling
Tables by Extrapolation” on page 4-32.

Adding a Point-by-Point Model Tradeoff

The simplest way to create your point-by-point tradeoff is to:

1 Import your model into CAGE. See “Import Models and Calibration Items Using
CAGE Import Tool” on page 2-5.

2 Create tables from your point-by-point model. See “Creating Tables from a Model” on
page 3-4.

When you click OK, CAGE creates all the tables for the multimodel tradeoff, with
breakpoints at the values you have selected.

Note When you calibrate the tables, you can only use models to tradeoff at the operating
points defined for the models. These cells have model icons in the table. You can edit
other cells, but they have no models to tradeoff associated with them.

Calibrating Using a Point-by-Point Model Tradeoff

Each editable operating point in your tables has a model icon in the cell, like this example
cell.

& 4B02722

These cells have a model defined at that point. You use the display of these models to help
you trade off values at these points to fulfill your aims in exactly the same way as when
using independent models in "ordinary" tradeoff mode, as described in “Choosing a Table
Value at a Specific Operating Point” on page 5-16.

1 Change input values by dragging the red lines on the graphs or by typing directly into
the edit boxes above the graphs. Use the context menu, toolbar or Inputs menu to
find the maximum, minimum, or turning point of a model if appropriate.
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2 Look at the model evaluation values (to the left of each row of graphs) and the input
variable values (in the edit boxes below the graphs) to see if they meet your

requirements.

Remember that the green highlighted graphs indicate how the selected table is filled:
if a row is green, the model evaluation value (to the left) fills the table at that
operating point; if a column is green, the input variable value (in the edit box below)

fills the table.

See the example following; the SPK column of graphs is green, so the value of SPK in

the edit box is entered in the table when you click the Apply Table Filling Values

button (@).
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This column is green, so

this value of SPK is entered
in the table when you select
Apply Fill to Table.

Value of spark
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3  When you are satisfied with the tradeoff given by the value of your variable at this
operating point, you apply this value to the table by pressing Ctrl+T, selecting

Tables -> Apply Fill to Table, or clicking @ in the toolbar.
4 When you have determined table values at each of the model operating points, you

can fill the whole table by extrapolation by clicking H see “Filling Tables by
Extrapolation” on page 4-32.

You can then export your calibration; see “Importing and Exporting Calibrations” on page
3-52.
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This section includes the following topics:

* “Using Optimization in CAGE” on page 6-2

* “Create an Optimization” on page 6-8

* “Set Up Sum Optimizations” on page 6-22

* “Set Up Multiobjective Optimizations” on page 6-30
* “Set Up Modal Optimizations” on page 6-35

* “Set Up MultiStart Optimizations” on page 6-39

» “Edit Variable Values” on page 6-42

+ “Edit Objectives and Constraints” on page 6-51

* “Run Optimizations” on page 6-59

+ “Edit Optimization Parameters” on page 6-61
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Using Optimization in CAGE

In this section...

“Overview of Optimization in CAGE” on page 6-2
“Parallel Computing in Optimization” on page 6-3
“Optimization Problems You Can Solve with CAGE” on page 6-4

Overview of Optimization in CAGE

You can use CAGE to solve many automotive optimization problems. For examples of
problems you can solve with CAGE, see “Optimization Problems You Can Solve with

CAGE” on page 6-4.

To reach the Optimization view, click the Optimization button in the left Processes
pane.

Processes

Festure

A
AN

Tradeoft

U

Cptimization

In the Optimization view you can set up and view optimizations. The view is blank until
you create an optimization. When you have optimizations in your project, the left pane
shows a tree hierarchy of your optimizations, and the right panes display details of the
optimization selected in the tree.

For any optimization, you need one or more models. You can run an optimization at a
single point, or you can supply a set of points to optimize. The steps required are
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1 Import a model or models.
2 Set up an optimization.

Optimization functionality in CAGE is described in the following sections:
* The steps for setting up and running optimizations are described in these sections:

* “Create an Optimization” on page 6-8
*  “Run Optimizations” on page 6-59

* “Optimization Analysis” describes using the optimization output views to analyze your
results, fill tables and export results.

» After you set up an optimization, you can apply it to a region in a set of tradeoff tables.
See “Automated Tradeoff” on page 5-3“Automated Tradeoff” on page 5-3.

* You can define your own optimization functions for use in CAGE. See “Optimization
Scripting”.

Parallel Computing in Optimization

By default, the toolbox automatically runs optimizations in parallel if you have Parallel
Computing Toolbox™. The optimization runs are then executed in parallel. This option
can significantly reduce the computation time for larger problems where each run is
taking a lot longer than the time it takes to send the problem to another computer.

When you run the optimization, CAGE calls parpool to open the parallel pool if
necessary, then the optimization runs are executed in parallel. CAGE displays progress
messages until the optimization is completed.

Building models in the Model Browser might also open parpool for you. See “Build
Models in Parallel”.

If you do not want to run optimizations in parallel, in CAGE, clear Optimization > Use
Parallel.
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Optimization Problems You Can Solve with CAGE

* “Point Optimization Problems” on page 6-4
* “Sum Optimization Problems” on page 6-6

Point Optimization Problems

CAGE provides a flexible optimization environment in which many automotive
optimization problems can be solved. These problems can be divided into two main
groups, point and sum problems. This section describes point problems.

In a point problem, a single optimization run can determine optimal control parameter
values at a single operating point. To optimize control parameters over a set of operating
points, an optimization can be run for each point.

Examples of point problems that CAGE can be used to solve are described below:

* Find the optimal spark timing (SPK), intake valve timing (INTCAM) and exhaust valve
timing (EXHCAM) at each point of a lookup table whose axes are engine speed (N) and
relative load (L).

Optimized values of the control parameters are determined by running the following
optimization at each point of the lookup table:
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Objective: Maximize engine torque, TQ = TQ(N, L, SPK, EXHCAM, INTCAM)
Constraints:

* Residual fraction <= 17% at each (N, L) operating point
* Exhaust temperature <= 1290°C at each (N, L) operating point
* Engine to be operated inside the operating envelope of the engine

Find the optimal mass of fuel injected (F), rail pressure (P), pilot timing (PT) and main
timing (MT) at each point of a lookup table whose axes are engine speed (N) and
engine torque (TQ).

Optimized values of the control parameters are determined by running the following
optimization at each point of the lookup table:

Objective: Minimize brake specific fuel consumption, BSFC = BSFC(N, TQ)

Constraints:

* Engine out NOx <= 0.001 kg/s at each (N, TQ) operating point
* Engine out Soot emissions <= 0.0001 kg/s at each (N, TQ) operating point

Find the optimum spark timing (SPK) and exhaust gas recirculation (EGR) at each
point of a set of operating points defined by engine speed (N), engine load (L) pairs.
Optimized values of SPK and EGR are determined by running the following
optimization at each point:

Objective: Maximize engine torque, TQ = TQ(N, L, SPK, EGR)

Constraints: Engine out NOx <= 400 g/hr at each (N, L) operating point

For a new engine, find out the optimal torque versus NOx emissions curve for this
engine over the operating range of the engine. This is a multi-objective optimization,
and CAGE Optimization contains an algorithm (NBI) to solve these problems.

For this example, the optimal torque-NOx curve is determined by solving the following
optimization problem for optimal settings of spark timing (SPK) and exhaust gas
recirculation (EGR):

Objectives:

* Maximize engine torque, TQ = TQ(N, L, SPK, EGR)
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* Minimize engine out NOx = NOx(N, L, SPK, EGR)
To find out more about solving multiobjective optimization problems in CAGE, see “Set
Up Multiobjective Optimizations” on page 6-30.

For engines with multiple operating modes, find the best operating mode for each
operating point. See “Set Up Modal Optimizations” on page 6-35.

To find out more about solving point optimization types of problems in CAGE, see “Create
an Optimization” on page 6-8.

Sum Optimization Problems

In a sum optimization, a single optimization run can determine the optimal value of
control parameters at several operating points simultaneously. All the control parameters
for the operating points are optimized by calling the algorithm once (there's only one call
to fmincon per run for a sum optimization). This approach contrasts with a point
optimization, which has to make a call to the algorithm for every point to find the optimal
settings of the control parameters.

Find the optimal spark timing (SPK), intake valve timing (INTCAM) and exhaust valve
timing (EXHCAM) at each point of a look-up table whose axes are engine speed (N)
and relative load (L).

Optimized values of the control parameters are determined by running the following
optimization once:

Objective: Maximize weighted sum of engine torque, TQ = TQ(N, L, SPK, EXHCAM,
INTCAM) over the (N, L) points of a look-up table.

Constraints:

+ Difference in INTCAM between adjacent cells is no greater than 5°.

* Difference in EXHCAM between adjacent cells is no greater than 10°.
At each table cell, residual fraction <= 17%

* At each table cell, exhaust temperature <= 1290°C

Find the optimal start of injection (SOI), basefuelmass (BFM), fuel pressure (P), turbo
position (TP) and lift of the EGR valve (EGR) at a set of mode points defined by engine
speed (N), engine torque (TQ) pairs.

Optimized values of the control parameters are determined by running the following
optimization once:
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Objective: Maximize weighted sum of brake specific fuel consumption, BSFC =
BSFC(SOI, BFM, P TP, EGR, N, TQ) over the (N, TQ) mode points.

Constraints:

* Weighted sum of brake specific NOx must be less than a legislated maximum
* At each mode point, air fuel ratio must be greater than a specified minimum
* At each mode point, turbo speed must not exceed a specified maximum

To find out more about solving these types of problems in CAGE, see “Set Up Sum
Optimizations” on page 6-22.
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In this section...

“Setting Up Optimizations” on page 6-8
“Creating Optimizations from Models” on page 6-9
“Tools for Common Optimization Tasks” on page 6-12

“Optimization Wizard” on page 6-13

Setting Up Optimizations

For any optimization, you need one or more models. Import the model or models you want
to optimize into your project. See “Import Models and Calibration Items Using CAGE
Import Tool” on page 2-5. After you import your models, you can create an optimization.

Use the following process to set up an optimization:

1  Use the wizard for “Creating Optimizations from Models” on page 6-9 to create
your optimization.

You can use the wizard to set up any type of optimization: point or sum, single or
multiobjective, modal, or multistart optimizations. See “About Point and Sum
Optimizations” on page 6-8.

2 Add constraints. You can add a boundary model constraint in the wizard. Use the
Optimization view to apply other types of constraints (model constraints, linear,
ellipsoid, 1-D table, 2-D table, and range). See “Edit Constraint” on page 6-54 for
details of all these constraints.

3 Choose the points where you want to run the optimization. To do so, you can use the
wizard or the Optimization view. In the wizard you can select a suitable table grid,
data set, or point-by-point models, or use the variable set points. In the Optimization
view you can select the points manually or import them from data sets, tables, or the
output of existing optimizations. See “Edit Variable Values” on page 6-42.

Run the optimization. See “Run Optimizations” on page 6-59.
5 View the results. See “Optimization Analysis”.

About Point and Sum Optimizations

You can set up either point or sum optimizations using the Create Optimization From
Model wizard.
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You can start a common CAGE calibration workflow by creating a point optimization.
What is a point optimization? For a point optimization problem, CAGE can determine
optimal control parameter values at a single operating point per optimization run. A run is
a single call to the optimization algorithm. To optimize control parameters for a set of
operating points, CAGE can run an optimization for each point.

You can use a point optimization workflow to find good initial values for a sum
optimization. In a sum optimization, a single optimization run can determine the optimal
value of control parameters at several operating points simultaneously. For information on
the different steps required for setting up sum optimizations, see “Set Up Sum
Optimizations” on page 6-22.

Some optimization problems require optimizing more than one objective simultaneously
(multiobjective), or multiple solutions per point (modal or multistart). For information on
the different steps required for setting up these optimizations, see “Set Up Multiobjective
Optimizations” on page 6-30, “Set Up Modal Optimizations” on page 6-35, and “Set Up
MultiStart Optimizations” on page 6-39.

For examples of types of optimization problems, see “Optimization Problems You Can
Solve with CAGE” on page 6-4

Creating Optimizations from Models

You can use the Create Optimization from Model wizard to set up any type of
optimization: point or sum, single or multiobjective, modal, or multistart optimizations. To
set up an optimization using a model in your project, from any view in CAGE, use this
procedure:

1 Select Tools > Create Optimization From Model or File > New > Optimization.

The Create Optimization From Model Wizard appears.

2 Select a model to minimize or maximize in the optimization.
If you are viewing a model, then the wizard automatically selects the current model.
If you are viewing an optimization or an optimization output node, then the wizard
automatically selects the model in the first objective.
If you have point-by-point models as shown in this example, you can optionally select
the check box to Create operating point data set.
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) Create Optimization from Model

Model

Select & model to minimize or maximize.

=10] x|

Model Type Yariahle Inputs
BSFC Paint-by-point ma... | MAINSOI FUELPRESS EGRP...
BSMOX Paint-by-point ma... | MAINSOI FUELPRESS EGRP ...
AFR Paint-by-point ma... | MAINSOI FUELPRESS EGRP ...
EGREMF Pairt-by-point ma... | MAINSOI FUELPRESS EGRP...
PEAKPRESS Pairt-by-point ma... | MAINSOI FUELPRESS EGRP...
YWGTSPEED Pairt-by-point ma... | MAINSOI FUELFRESS EGRP...

[~ Create operating point data set

{ =Back ! Mext = Firish

Cancel

Click Next.

3 Select the optimization type (algorithm, maximize or minimize, point or sum), data
source for optimization, free variables, and boundary constraint.
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) Create Optimization from Model - =10 x|

Optimization
Choose the optimization type and select free variables for the optimization.

Algorithrn: Ifnptcun j
Ohjective type: Ihﬂinimize j|Puint |
Data source: ITaI::nIe grid jIEIT@_TabIe{N:Lj |
Free variables: Vfariable
1 zelected M y=

M xw

M xL

¥ x icp

v 1 ECP

v Add a model boundary constraint

Cancel = Back Finish

Algorithm:

* Use the default fmincon for gradient-based single-objective optimizations.

* Use NBI for multiobjective optimizations. You can set up your additional
optimization objectives after you finish the wizard. See “Set Up Multiobjective
Optimizations” on page 6-30.

* Use gamultiobj for multiobjective optimizations with more than two
objectives and those that are not smooth. Such problems can work better with
gamultiobj than with NBI. You can set up your additional optimization
objectives after you finish the wizard. This algorithm is only available if you
have the Global Optimization Toolbox product installed. See “Set Up
Multiobjective Optimizations” on page 6-30.

* Use ga or patternsearch for nongradient-based single-objective
optimizations. These algorithms are only available if you have the Global
Optimization Toolbox product installed.
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o Use Modal optimization with a composite model for selecting the best
operating mode for each operating point. See “Set Up Modal Optimizations” on
page 6-35.

* Use MultiStart to look for multiple local optimum solutions by running
multiple start points for each operating point. See “Set Up MultiStart
Optimizations” on page 6-39.

* Ifyou have a suitable user-defined optimization routine in CAGE, it can appear
here. See “Optimization Scripting”.

* Objective type: Choose whether you want to Maximize or Minimize your
model, and select a Point or Sum objective.

CAGE automatically configures your variable values correctly: a run per point if
you select Point, a single run for Sum. See “Set Up Sum Optimizations” on page
6-22.

* Data Source: Choose the points where you want to run the optimization. You can
also set up points in the Optimization view. If you choose to set up points in the
wizard, the options depend on the contents of your project and your model type.
You can choose to use the variable set points, a data set, a table grid, model
operating points (the default for point-by-point models), or unique operating
points (for a composite model combining point-by-point models).

+ Free variables: Select the check boxes of the variables you want to optimize from
the set of model inputs. If you select a table grid as the Data source, as shown in
the preceding figure, CAGE automatically removes the table normalizer variables
from the selection of free variables.

* Add a model boundary constraint: Select the check box if you want to
constrain the optimization within the boundary model associated with your model.

Click Finish to create the optimization.

When you return to the Optimization view you can edit or add constraints and settings
and run the optimization.

After you create the optimization, you cannot change the free variables or the algorithm
type.

Tools for Common Optimization Tasks

% 8| T ER | E
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Common tasks are available in the toolbar:

Create Tables From Model — use this wizard to create tables (and optionally a
tradeoff) for use with the current optimization. A common workflow is creating tables
with the same inputs as your optimization, for filling with optimization results. The
wizard automatically selects the model in the first objective (you can also choose any
model in your project), and then you can choose which variables and responses to set
up tables for. You can then fill these tables with the results from your optimization, and
investigate your results in the tradeoff view. See “Creating Tables from a Model” on
page 3-4.

Add Objective — Adds an objective to your optimization (if enabled; remember
fmincon can only have a single objective). You must double-click the new objective to
open the Edit Objective dialog box, select a model, and set whether to maximize or
minimize. See “Edit Objective” on page 6-52.

Add Constraint — Adds a constraint to your optimization. You must double-click the
new constraint (in the list of constraints) to open the Constraint Editor and set up the
constraint. See “Edit Constraint” on page 6-54

Import from a data set, import from optimization output, import from table grid,
import from table values — You can use these to populate the Variable Values panes by
importing values — See “Edit Variable Values” on page 6-42.

Set Up Optimization, Set Up and Run Optimization — Both these options open the
Optimization Parameters dialog box, where you can change optimization settings such
as tolerances and number of solutions. When you close the dialog box the settings are
saved (and the optimization runs in the case of Set Up and Run). See “Edit
Optimization Parameters” on page 6-61.

Run Optimization — Starts the optimization. See “Run Optimizations” on page 6-59.

Optimization Wizard

For most optimizations, you should use the wizard for “Creating Optimizations from
Models” on page 6-9 because it simplifies the setup process.

If your user-defined optimization script defines operating point sets and/or a fixed number
of free variables, you must use the Optimization Wizard instead. This is common with
Version 2.0 scripts.

For example you may have advanced operating point set requirements, so you need to
match the data set variables as part of setting up the free variables; or your optimization
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problem may involve free variables that are not part of the objective model (e.g., some
feasibility problems).

You can use the Optimization Wizard to:

Choose algorithm

2 Set up free variables, objectives, and constraints options — “Optimization Wizard
Step 2” on page 6-16

3 Select free variables — “Optimization Wizard Step 3” on page 6-17

The last 3 steps you can do in the wizard or in the Optimization view:
Set up objectives — “Optimization Wizard Step 4” on page 6-18
Set up model constraints — “Optimization Wizard Step 5” on page 6-19
Set up data sets (user-defined optimizations only) — “Optimization Wizard Step 6” on
page 6-20
To use the Optimization Wizard, select File > New > Custom Optimization.

This takes you to the Optimization Wizard, which leads you through the steps of choosing
the optimization to run, specifying the number of variables to optimize over (unless this is
predefined by the function), and linking the variables referenced in the optimization to
CAGE variables.

Step 1. First you must choose your algorithm. The first screen of the Optimization
Wizard is shown below.
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/) Dptimization Wizard | 101 =l
Algorithm Selection
Select from the list the algorithm that you want the new optimization to use.

Axailable optimization algotithms:

MHame | Free ' ariables | Ohjectives | Caonstraints | Operating Faoint Sets |

foptcon any number 1 any number 1]

HEI any number 2 ar mare any number 1]

ga any number 1 any number 1]

patternzearch any number 1 any number 1]

‘whorkedE xample 2 1 1] 1]

Cancel | = Back | Mext = Fimizt

The first four algorithm choices in the list are standard routines you can use for
constrained single and multiobjective optimization.

+ fmincon is a single-objective optimization subject to constraints. This function uses
the MATLAB fmincon algorithm from the Optimization Toolbox™ product.

* NBI and gamultiobj are multiobjective and can also be subject to constraints.

* ga,gamultiobj, and patternsearch are only available if you have the Global
Optimization Toolbox product installed.

* ga stands for Genetic Algorithm, for single-objective optimization subject to
constraints. This function uses the MATLAB ga algorithm from the Global
Optimization Toolbox product. See “Genetic Algorithm” (Global Optimization

Toolbox).

* patternsearch is another algorithm for single-objective optimization subject to
constraints, from the Global Optimization Toolbox product. See “Direct Search”

(Global Optimization Toolbox).

* Modal optimization selects the best operating mode for each operating point, and
requires a composite model. See “Set Up Modal Optimizations” on page 6-35.

In many cases these standard routines are sufficient to allow you to solve your
optimization problem. Sometimes, however, you might need to write a customized
optimization algorithm; to do this you can use the supplied template to modify for your
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needs. Any optimization functions that you have checked into CAGE appear in this list.
See “Optimization Scripting” for information. The Worked Example option is designed to
show you how to use the modified template. For step-by-step instructions, see the
optimization tutorial section “Example User-Defined Optimization” on page 8-9.

Note If you choose a user-defined optimization function at step 1, all choices in
subsequent steps depend on the settings defined by that function. When writing user-
defined optimizations you can choose to set predetermined algorithm options or allow the
user to make selections on any subsequent screen of the Optimization Wizard.

Optimization Wizard Step 2

Here you select algorithm options for numbers of free variables, objectives, and
constraints. The optimization tries to find the best values of the free variables. The
options available depend on your selected algorithm.

« Ifin step 1 you select the fmincon algorithm and click Next, you get the following
choices:

) optmizaton wizard i

Algorithm Options
Algarithms may be able to use a variable number of iterns. Select the number of each item that you weant to use in this
optimization.

Mumber of free variables: |—1i‘
Mumber of ohjectives: |—1§‘
Mumber of constraints: I—Di‘
Murmber of operating point sets: I—DE‘

Cancel | = Back Firizh |

The fmincon algorithm can only have a single objective, so this control is not enabled.
Choose the number of free variables and constraints you require. You can also add
constraints later.
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+ Ifin step 1 you select the algorithm NBI, and click Next, you see this:

e JRT=TE

Algorithm Options
Algarithims ey be able to use a varishle number of iterns. Select the number of each itern that you want to use in this

optirmization.

Mumber of free variables: |—1§‘
Mumber of ohjectives: |—2i‘
Mumber of constraints: I—DE‘
Mumber of operating point sets: I—Di‘

Cancel = Back Finizh

NBI must have a minimum of two objectives, and you can choose as many free
variables and constraints as you like. You can add constraints later if required.

Optimization Wizard Step 3

You must select variables to link with the free variables used in your optimization.
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.} Dptimization Wizard 5 101 =l
Required Yariables
td atch each required variable in the optimization ta a variable frarm the VW ariable Dictionary.
Optimization inputs; CAGE wariables:
Symbol [ CAGE Varisble | n il
Freet arablel L
A
SPK.
E
Tt
Seleck CAGE Variable
Cancel | < Back | (=13 | Eiriizh |

Use this screen to associate the variables from your CAGE session with the free
variable(s) you want to use in the optimization. Select the correct pair in the right and left
lists by clicking, then click the large button as indicated in the figure.

Once you have assigned your free variables here you can either click Next or Finish. This
also applies to all later steps in the Optimization Wizard.

Optimization Wizard Step 4

You can set up your objectives here or you can set them up at the Optimization view in
CAGE. See “Edit Objective” on page 6-52.
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) Dptimization Wizard =10l x|

Objectives
Ohbjectives are quantities that the algorithm will attempt to optimize. Select CAGE models ta be used for each objective,
and whether it should be minimized, maximized or used as a helper model for the algorithm,

Optimization objectives: CAGE models:

TL baodel
MOFLOW _Model

Dptimization Model | CAGE Model | Typs
Ohjectivel TO_Model hd awinnize
Ohjectivez HOFLOW M. Minimize

Seleck CAGE Model

Objective type: Minimize % Maximize € Helper

Cancel | < Back | Mext » | Finizh |

Here you can select which models from your session you want to use for the optimization,
and whether you want to maximize or minimize the model output. The fmincon algorithm
is for single objectives, so you can only maximize or minimize one model. The NBI or
gamultiobj algorithms can evaluate multiple objectives. For example, you might want to
maximize torque while minimizing NOX emissions. Remember you can also define
constraints later, for example, using emissions requirements.

You can also include 'helper' models in your user-defined optimizations, so you can view
other useful information to help you make optimization decisions (this is not enabled for
NBI or fmincon).

* Click Next to proceed to setting up constraints.

* Click Finish to complete the Optimization Wizard and return to the Optimization
view. Note you can only set up point objectives in the wizard, but you can also set up
sum objectives in the main Optimization view. See “Edit Objectives and Constraints”
on page 6-51.

Optimization Wizard Step 5

You can use models to define constraint regions that restrict free variables. If you want to
use constraints you can select them here, or add them in the Optimization view in CAGE.
You can also add other types of constraints in the Optimization view. See “Edit
Constraint” on page 6-54.
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;) Dptimization Wizard 101l

Model Constraints
hodel Constraints define regions that the free variables can vary within, Select CAGE models to uze for each
constraint. Select whether to constrain the model by a fixed value or by the model's boundary constraint.

Optimization constraints: CAGE models:

Model Constraint | CAGE Model | Bound | kBT -
Constraint] RESIDFRAC Boundary -k EXTEMP
4\ RESIDFRAC
et

i WET
-\ RESIDFRACSMET
- METwithSpeed oadBa_ |7

Congztraint:

- RESDFRAC [-= -] | =

{* Boundary of model

Cancel = Back Finizh

Select a model for each constraint by selecting a CAGE model and a model constraint and
clicking the button to match them up.

For each constraint, either:

* Enter a value in the edit box to define the bound. Select the operator to define
whether the optimization output should be constrained to be greater than or less than
the value.

» Alternatively, select the radio button to use the Boundary of model as the constraint.
Optimization Wizard Step 6

If your user-defined optimization allows you to add a data set you can select it on step 6 of
the Optimization Wizard. You can use data sets to evaluate models over a different set of
operating points during an optimization run. As an example, you could run an
optimization at the points (N1, L1), (N2, L2), but an important quantity to monitor and
possibly act upon is, say, temperature at points (N3, L3), (N4, L4). You can monitor the
temperature at these points by using data sets, to help you select optimization results.
You can set up data sets in Step 6 of the wizard or in the Optimization view in CAGE
(select Optimization > Edit Data Sets).

Data sets are not enabled for fmincon and NBI optimizations.
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Click Finish to return to the Optimization view in CAGE. Your new optimization appears
as a new node in the tree pane on the left, and the setup details appear on the right.
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In this section...

“Overview of Setting Up Sum Optimizations” on page 6-22

“Example Problem to Demonstrate Controls for Sum Optimizations” on page 6-24
“Selecting Scalar Variables” on page 6-25

“Algorithm Restrictions” on page 6-25

“Using Application Point Sets” on page 6-28

Overview of Setting Up Sum Optimizations

CAGE can solve sum-type optimizations. These optimizations find the optimal settings of
control parameters at several operating points simultaneously. You can use sum
optimizations to solve drive-cycle problems where you must apply the constraints across
the whole cycle. For example, a constraint such as weighted engine out brake specific
NOx <= 3 g/kWh.

If you have an existing point optimization, you can use a utility to create a sum
optimization from your point optimization output. This approach can help you find good
initial values for a sum optimization. To create a sum optimization from your point
optimization:

* (Recommended) Select Solution > Create Sum Optimization . For more details see
“Create Sum Optimization from Point Optimization Output” on page 7-4.
* Select Optimization > Convert to Sum Optimization .

If you do not have an existing point optimization, to set up a new sum optimization:

1 Use the “Creating Optimizations from Models” on page 6-9 Wizard to create your
optimization. You can configure a sum objective in the wizard. CAGE automatically
configures your variable values correctly for a sum optimization, defining a single
run. See “What Is a Run?” on page 6-23.

You can also configure a sum objective later in the Optimization view. See “Sum
Objectives” on page 6-53.

2 Add constraints:
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* You can add a boundary model constraint in the wizard.

» To apply other types of constraints you must use the Optimization view. You can
apply linear, ellipsoid, 1-D table, 2-D table, and range constraints, and some
constraints are specific to sum optimizations—sum constraints and table gradient
constraints.

See “Edit Constraint” on page 6-54 for details of all these constraints.

Choose the points where you want to run the optimization:

* You can use the wizard to select a suitable table grid, data set, or point-by-point
model, or use the variable set points.

* You can also set up your optimization variable values in the Optimization view. You
can enter values manually, or by importing from data sets, tables, or the output of
existing optimizations. See “Edit Variable Values” on page 6-42.

For sum optimizations you must have a single run, defined by the length controls.
CAGE automatically configures your variable values correctly for a sum optimization
(defining a single run) when you either:

* Use the Create Sum Optimization utility

* Use the Create Optimization from Model wizard and then select a sum
objective.

If you prefer, you can use the length controls in the Optimization view instead of the
wizard. See “Selecting Scalar Variables” on page 6-25.

(Optional) You can evaluate objectives or constraints over different operating points
to those you specified in the optimization. See “Using Application Point Sets” on page
6-28.

Run the optimization. See “Run Optimizations” on page 6-59.

View the results (see “Viewing Your Optimization Results” on page 7-18). For
descriptions of optimization output specific to sum problems, see “Interpreting Sum
Optimization Output” on page 7-72.

What Is a Run?

Sum type optimizations determine optimal settings of operating points simultaneously.
Thus, one call to the algorithm determines the optimal settings of the control parameters
at each operating point.
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In CAGE, a run refers to each call to the optimization algorithm. . You specify the number
of runs that you want CAGE to perform with the Number of runs control in the Input
Variable Values pane. For more details, see “Selecting Scalar Variables” on page 6-25.

Example Problem to Demonstrate Controls for Sum
Optimizations

The following sections describe the controls and outputs for sum optimizations using the
following example problem for illustration.

Say you have created models for torque (TQ), residual fraction (RESIDFRAC) and exhaust
temperature (EXTEMP) for a gasoline engine.

The inputs to these models are

* Spark advance, S

* Intake cam timing, INT

» Exhaust cam timing, EXH
* Engine speed, N

* Relative load, L

You need to set up an optimization to calculate optimal settings of S, INT and EXH for the
following operating points:

N L
1000 0.3
1100 0.2
1250 0.31
1500 0.25
1625 0.18

The objective for this optimization is:
Maximize the weighted sum of TQ over the operating points.
The constraints for this optimization are:

* Constraint 1: EXTEMP <= 1290°C at each operating point
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* Constraint 2: RESIDFRAC <= 17% at each operating point

* Constraint 3: Change in INT is no more than 5.5° per 500 rpm change in N and 5.5°
per 0.1 change in L, evaluated over a 3-by-3 (N, L) table.

* Constraint 4: Change in EXH is no more than 5.5° per 500 rpm change in N and 5.5°
per 0.1 change in L, evaluated over a 3-by-3 (N, L) table.

You can use the fmincon algorithm in CAGE to solve this problem.

This example is used to explain the controls and outputs in the following sections,
“Selecting Scalar Variables” on page 6-25 and “Interpreting Sum Optimization Output”
on page 7-72.

See “Algorithm Restrictions” on page 6-25 for details on the optimization algorithm
restrictions in CAGE.

Selecting Scalar Variables

At the optimization node, the Optimization Point Set pane lists the free and fixed
variables. For sum optimizations:

* The Number of operating points is the number of points that the optimizer sums
during the optimization.

* Use Select Scalar Variables to specify the scalar values that do not depend on the
operating points.

Algorithm Restrictions

Each run of a CAGE Optimization makes a call to the algorithm you have chosen to use.
This algorithm needs to evaluate the objectives and constraints (probably several times)
to allow it to determine the optimal settings of the free variables. Optimization algorithms
typically have restrictions on the number of objective and constraint outputs they can
handle. The following table details the restrictions on the two algorithms provided in
CAGE.

Algorithm Name Objectives Constraints
fmincon One output Any number of outputs
NBI Two or more outputs Any number of outputs
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When each objective and constraint is evaluated during a run, the number of outputs it
returns depends on the maximum number of values of all of its inputs. The following table
details the number of outputs each objective type returns as a function of the maximum
number of values of all of its inputs.

Point N N A point objective is evaluated at each
operating point within a run, and all
the values are returned.

Sum N One A sum objective evaluates a model at
every operating point and returns one
value, which is the weighted sum of
the model evaluations.

Similarly, the following table details the number of outputs each constraint type returns
as a function of the maximum number of values of all of its inputs.

Linear N N These constraints are evaluated at

Ellipsoid N N every operating point within a run,
and all values are returned.

1D Table N N

2D Table N N

Model N N
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Constraint Maximum Number of Reason
Type Number of Outputs

Values of All

Inputs to the

Constraint

Range N 0, N or 2N A range constraint evaluates an
expression at each operating point
within a run. The constraint returns
two values for each point, the distance
from the lower and upper bound. In
this case 2N outputs are returned. If
one of the bounds is infinite, then only
the distance to the finite bound is
returned for each point, and N outputs
are returned. If both bounds are
infinite then 0 outputs will be
returned.

Sum N 1 A sum constraint evaluates a model at
every operating point and returns the
difference between the weighted sum
of the model and a bound.

Table N >=8 A table gradient constraint constrains
(dependent on the gradient of a free variable over a
settings) grid. The number of outputs returned

depends on the dimensions of the grid.

You can use these three tables to check whether the problem set up satisfies the
algorithm restrictions. As an example, the following table checks whether the example
problem (detailed in “Example Problem to Demonstrate Controls for Sum Optimizations”
on page 6-24) satisfies the restriction of the algorithm chosen to solve it, fmincon.

Objective Maximum Number of Number of Outputs
Values of All Inputs
Weighted sum of TQ over 5 1 (using the Objective table)

the drive cycle points
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Constraint

Maximum Number of

Values of All Inputs

EXTEMP <= 1290°C at each 5

drive cycle point

RESIDFRAC <= 17% at
each drive cycle point

Change in INT is no more
than 5.5° per 500 rpm and
5.5° per 0.1 change in L

Change in EXH is no more
than 5.5° per 500 rpm and
5.5° per 0.1 change in L

5

Number of Outputs

5 (using the Constraint
table)

5 (using the Constraint
table)

24 (this value is the number
of table gradient constraint
outputs generated from a 3-
by-3 table)

24 (this value is the number
of table gradient constraint
outputs generated from a 3-
by-3 table)

Thus, the example problem has 1 objective output and 58 constraint outputs. This
satisfies the restrictions of the fmincon algorithm and so the algorithm can be used.

Using Application Point Sets

You can use application point sets to evaluate constraints and objectives at different
operating points than those specified in the optimization. You can only use application
point sets with sum optimizations.

This can be useful for some problems, for example:

* Your calibration problem requires consideration of several drive cycles, defined at
different operating point sets. For example, it is common to have different drive cycles
for performance and emissions.

* You want to apply some constraints only at a subset of the optimization points
(sometimes called “multiregion problems”). For example, there are often different
constraints to consider at full load.

* Your full operating point set of interest is very large and optimizing at every point will
be very slow. You can run an optimization at a subset of points, and evaluate

interpolated results across an application point set.

* You may need to evaluate point-by-point models at different operating points to the
points where the models are defined.
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To use an application point set for evaluating an objective or constraint:

1

5

Right-click the objective or constraint, and select Select Application Point Set.

The Select Operating Point Variables dialog box appears.

Select a pair of variables to use in application point sets. The variables must be fixed
variables in your optimization. You only select variables once per optimization. Click
OK.

The Select Application Point Set dialog box appears.

Select an application point set. You can choose a data set or a New subset of the
optimization points. To select a subset of points, you can use the check boxes or click
points on the plot.

) Select Application Point Set -3l
Select an existing data set to uze as an application point set or creste a new one from the optimization point
=6t

Data set: IDriveCyc:Ie1 0 - l L9} Application Point Set

> Optimization Point Set

[ata =2t frEmes
2000
SPEED BTQ
v 2200 947 - : : : : :
v 2200 632 15000 - <= -4- oo h oo L SIS -oem o
v 2200 126) 5 ' 0 5 5
I 2200 1263 o P e ¢ _____ i i______
o 1900 1163 o i i ' ' '
v 1900 775, : : @ : :
Cd 1900 1550 i) T R P LI Ao I
v 1600 1163 ; : 0 0 i
E 1800 775, = ; : : : : 3
Mumber of points: 10 10600 1700 1800 1800 2000 2100 2200
SPEED

OK I Cancel | Help |

View the plot displaying the application points and optimization points. CAGE
extrapolates the optimization results to evaluate the objective or constraint at the
application points.

Click OK.

To see example plots that illustrate how CAGE uses application point sets, enter
mbcAppPointSetDemo to load the example project file mbcAppPointSetDemo. cag into
CAGE. Run the optimizations in the project to view the plots.
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In this section...

“Overview of Setting Up Multiobjective Optimizations” on page 6-30
“About the gamultiobj Algorithm” on page 6-31
“About the NBI (Normal Boundary Intersection) Algorithm” on page 6-31

Overview of Setting Up Multiobjective Optimizations

CAGE Optimization contains two algorithms (NBI and gamultiobj) to solve
multiobjective optimization problems. For example, you could use the NBI type of
optimization to determine the optimal torque versus NOx emissions curve for an engine
over the operating range of the engine. To solve this problem you must define two
competing optimization objectives, to maximize torque while minimizing NOx emissions.

To set up a new multiobjective optimization:

1

Use the wizard for “Creating Optimizations from Models” on page 6-9 to create your
optimization. You can configure one of your objectives in the wizard. You must select
either the NBI algorithm or the gamultiobj algorithm to solve a multiobjective
optimization.

Use gamultiobj for multiobjective optimizations with more than two objectives and
those that are not smooth. Such problems can work better with gamultiobj than
with NBI. The gamultiobj algorithm is only available if you have the Global
Optimization Toolbox product installed.

When you select a multiobjective algorithm, the wizard automatically creates a
second blank objective for you. When you finish the wizard and return to the
Optimization view, you can configure the second objective (and add a third if desired).

You can add a boundary model constraint in the wizard. To apply other types of
constraints you must use the Optimization view. You can apply linear, ellipsoid, 1-D
table, 2-D table, and range constraints, and some constraints are specific to sum
optimizations—sum constraints and table gradient constraints.

See “Edit Constraint” on page 6-54 for details of all these constraints.

You can use the wizard to choose the points where you want to run the optimization.
You can select a suitable table grid, data set, point-by-point model operating points,
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or use the variable set points. You can also set up your optimization variable values in
the Optimization view. See “Edit Variable Values” on page 6-42. You can enter values
manually or import them from data sets, tables, or the output of existing
optimizations.

4 Run the optimization using the procedure for “Run Optimizations” on page 6-59.

Click Run Optimization in the toolbar to run the optimization with the default
settings.

5 View the results (see “Viewing Your Optimization Results” on page 7-18). For
descriptions of optimization output specific to multiobjective problems, see “Tools for
Optimizations with Multiple Solutions” on page 7-51 and “Analyzing Multiobjective
Optimization Results” on page 7-66.

About the gamultiobj Algorithm

The gamultiobj algorithm uses the gamultiobj function from the Global Optimization
Toolbox product, and is only available if you have the Global Optimization Toolbox product
installed.

For details on the gamultiobj function, see “Multiobjective Optimization” (Global
Optimization Toolbox) in Global Optimization Toolbox. For CAGE options, see “gamultiobj
Optimization Parameters” on page 6-68.

To analyze results, see “Tools for Optimizations with Multiple Solutions” on page 7-51
and “Analyzing Multiobjective Optimization Results” on page 7-66.

About the NBI (Normal Boundary Intersection) Algorithm

To understand the options for the NBI algorithm, some limited understanding of the
algorithm is required. For more information on the NBI algorithm, see the following
reference:

Normal-Boundary Intersection: A New Method for Generating the Pareto Surface in
Nonlinear Multicriteria Optimization Problems, I. Das and ]J.E. Dennis, SIAM ]. on
Optimization. 8(3), 631-657 (1998).

The NBI algorithm is performed in two steps. The first step is to find the global of each
objective individually. This is called the shadow minima problem, and is a single-objective
problem for each objective function. The MATLAB routine fmincon is used to find these .
Once these are found, they can be plotted against each other. For example, consider an
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NBI optimization that simultaneously maximizes TQ and minimizes NOX emissions. A plot
of the against each other might resemble the following.

TQ

Best possible
value of TQ

Best possible
value of NOx

@ N

NOx

The second step is to find the "best" set of tradeoff solutions between your objectives. To
do this, the NBI algorithm spaces Npts start points in the (n-1) hypersurface, S, that
connects the shadow . In the above example, S is the straight line that connects the points
N and T. For each of the Npts points on S, the algorithm tries to maximize the distance
along the normal away from this surface (this distance is labeled L in the following
figure). This is called the NBI subproblem. For each of the points, the NBI subproblem is
a single-objective problem and the algorithm uses the MATLAB fmincon routine to solve
it. This is illustrated below for the TQ-NOX example.
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TQ

NOx

The figure above shows spacing of the points between the along the (n-1) surface. The
algorithm tries to maximize the distance L along the normal away from the surface. The
following figure shows the final solution found by the NBI algorithm.
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®
o ©©°
@)
O
O
o Pareto front
O
O
o Solutions in this region are not optimal.

NOx

To see how the NBI settings are used in the Optimization Parameters dialog box, see “NBI
Optimization Parameters” on page 6-63.
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Set Up Modal Optimizations

In this section...
“What Is Modal Optimization?” on page 6-35
“Workflow for Modal Optimization” on page 6-35

“Creating Modal Optimizations” on page 6-36
“Adding Extra Objectives to Modal Optimizations” on page 6-38

What Is Modal Optimization?

You can use the modal optimization algorithm to produce optimal calibrations for engines
with multiple operating modes. This algorithm helps you choose the best operating mode
for each operating point. The algorithm can optimize an objective for each operating
mode and select the best solution automatically. You must use a composite model for
these optimizations. See “What Are Composite Models?” on page 2-26

The optimization output views help you view and select the best solution for each
operating point.

Workflow for Modal Optimization
To find the best mode at each operating point, use the following workflow:

1 Create a composite model representing the multiple operating modes. See “Creating
and Viewing Composite Models in CAGE” on page 2-26.

2  Using the Create Optimization From Model wizard, select the Modal optimization
algorithm. The wizard then selects the mode input as a free variable.

3 (Optional) Add additional objectives in the Optimization view. You can optimize with
one objective, and use the other objectives to explore the results with graphical
comparisons. You can optionally choose a different objective to use to select the best
mode.

4  After running the optimization, use the optimization output graphical tools to view
the solutions and decide which mode you want to use for each operating point.

The modal optimization algorithm tries to automatically select the best mode for each
operating point. Use the optimization output node tools to view all solutions and see
which solution is selected. You can change the selections manually if you want. These
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features are also useful for selecting solutions for multiple objective optimizations,
such as NBI.

You can only use modal optimization for point optimization problems. When you have
selected the best mode for each operating point, you can create a sum optimization from
your modal optimization results. The toolbox automatically creates a sum optimization for
you with your selected best mode for each operating point.

To analyze your results, see “Analyzing Modal Optimization Results” on page 7-57.

Examples of Modal Optimizations

Creating Modal Optimizations

To create a modal optimization using a composite model, use the Create Optimization
From Model wizard.

1 Select Tools > Create Optimization From Model (or use the toolbar button).

The Create Optimization From Model Wizard appears.

2 Select a composite model to minimize or maximize in the optimization. If you are
viewing a model, then the wizard automatically selects that current model.
Click Next.

3  Select the Modal optimization algorithm. The wizard selects the mode input as a
free variable. Do not change the Point optimization type.

Specify other optimization information:

¢ Maximize or minimize

» Data source for optimization (for example, if you have a suitable table grid to use
for optimization points)

* Free variables
* Boundary constraint
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) Create Optimization from Model B | Ellil

Optimization
Choose optimization type and select free variables to optimize BTG

Algorithen: IM::II:IaI optimization j
Cibjective type: IMﬂximize le‘uint j
Dita source: Table grid [~ ||5Ta_Tablem,L) -
Free variables: Variable
4 selected I

OxN

OxL

X ICP

x ECP

X

. CylinderMode

v add a model boundary constraint

Cancel < Back Finizh

Click Finish to create the optimization.

For more information on the options in the wizard, see “Creating Optimizations from
Models” on page 6-9.

In the Optimization view check the Optimization Information pane to confirm your setup.
Modal optimizations show the mbcOSmodalopt algorithm name and a mode variable, as
shown in the following example.

Optimization Informstion

Algorithm name mbcOSmodalopt

Algorithm description Modal optimization using a single objective optimization subject to constraintzs
Free variables CylinderMode, 5, ICP, ECP

Operating point variables None

Wode variable CylinderMode

ltem scaling off

Distributed runs off
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Your optimization is ready to run, unless you want to change the optimization points, or
add constraints or extra objectives. For next steps, see “Adding Extra Objectives to Modal
Optimizations” on page 6-38 and “Analyzing Modal Optimization Results” on page 7-57.

Adding Extra Objectives to Modal Optimizations

You can optionally add additional objectives in the Optimization view. You can optimize
with one objective, and use the other objectives to explore the results with graphical
comparisons. You may want to manually change the selected best mode based on the
values of these additional “helper” objectives. You can optionally choose to automatically
select the best mode with a different objective.

(Optional) To add extra objectives,
1 In the Optimization view, right-click the Objectives pane and select Add Objective.

Set up the extra objective as described in “Edit Objective” on page 6-52.

2 (Optional) You can change which objective to use to select the best mode. By default
CAGE uses the first objective to select the best mode, but in some cases you may
want to change this. To change this setting,

a  Select Optimization > Set Up or click the toolbar button.

The Optimization Parameters dialog box appears.

b  Edit the setting Index to the objective to determine best mode. The default
is 1, so CAGE uses the optimized values of the first objective to select the best
mode. Change the index if you want to use a different objective.

¢ Click OK.

For next steps, see “Analyzing Modal Optimization Results” on page 7-57.
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Set Up MultiStart Optimizations

In this section...
“What Is MultiStart Optimization?” on page 6-39
“Creating a MultiStart Optimization” on page 6-39

What Is MultiStart Optimization?

If you have Global Optimization Toolbox, you can use the MultiStart algorithm in
CAGE. This algorithm can identify multiple local optimum solutions to help you create
smoother tables. Multiple local optimum solutions are often found because of the flat
nature of engine responses. The difference in performance between solutions can be
small and result in tables that are not smooth enough. The MultiStart algorithm tries to
identify multiple optimum solutions by running multiple start points for each operating
point. You can select the solutions that meet your table smoothness constraints based on
the entire table.

The optimization output views help you view and select the best solution for each
operating point.

Creating a MultiStart Optimization

1 Select Tools > Create Optimization from Model (or click the toolbar button) to
open the Create Optimization From Model wizard.

2 Select a model to minimize or maximize in the optimization. If you are viewing a
model, the wizard selects that current model.
Click Next.

3  Select the MultiStart algorithm as shown next. Do not change the Point
optimization type.
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I

Optimization
Choo=e optimization type and select free variables to optimize BTQ.

Algorithm: MutiStart - |

Objective type:  |Maximize =||point |
Data source: |Tabie grid ~||eTa_Tablem,L) |
Free variables: Variable
3 selected -

O x N

OxL

X ICP

x ECP

¥ add a model bound ary conztraint

Cancel < Back Mext = Finizh

4  Specify other optimization information:

¢ Maximize or minimize

* Data source for optimization (for example, if you have a suitable table grid to use
for optimization points)

* Free variables
* Boundary constraint
5 Click Finish to create the optimization.

(Optional) To change the number of start points to run:

1 In the Optimization view, select Optimization > Set Up or click the Set up
optimization toolbar button.

The Optimization Parameters dialog box opens.
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2 Change the Number of start points. This setting determines how many
optimizations to run for each point.

3 Click OK.

Start points is the most common parameter you may want to change. For information on
other parameters see “MultiStart Optimization Parameters” on page 6-67.
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In this section...

“What Are Variable Values?” on page 6-42
“Define Variables Manually” on page 6-42
“Import from a Data Set” on page 6-44
“Import from Output” on page 6-45
“Import from Table Grid” on page 6-49

“Import from Table Values” on page 6-49

What Are Variable Values?

In the optimization view, the Variable Values panes define the set of operating points for
the optimization. If you use the wizard for “Creating Optimizations from Models” on page
6-9, you can choose to set up operating points automatically in the wizard. You can choose
to use the variable set points, a data set, a table grid, or model operating points (if you
have point-by-point models). When you close the wizard, CAGE displays your chosen
points in the Variable Values panes. You can use the Variable Values panes to edit your
optimization operating points.

You do not have to choose a set of operating points; you can run the optimization at a
single point.

Running the optimization requires the selected models to be evaluated (many times over)
and hence values are required for all the model input factors. Choose values for the fixed
variables in the Fixed Variables pane. You chose one or more free variables, so the
optimization chooses different values for those free variables in trying to find the best
value of the objectives. The initial values for a free variable are shown in the Free
Variables pane.

To define the set of operating points for the optimization, you can define variables
manually, or you can import values from these sources: data set, optimization output,
table grid, or table values.

Define Variables Manually

To define values manually:
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1 In the Input Variable Values pane, select the Number of runs. New rows appear
for both fixed and free variables, all containing the default set point values of each
variable. Each row defines an operating point for an optimization run.

2 Edit the values in the Fixed Variables pane to define the points where you want to
run the optimization.

* You can copy and paste values from other parts of CAGE (existing optimizations or
data sets etc.), or from the Help Browser or other documents.

* You can select Optimization > Import From Data Set if you have suitable
variables to import.

* You can select Optimization > Import From Output if you have suitable
optimization outputs.

An example is shown in the following figure.

Fixed Yariables

Mariable: L M 2 E

N || = =T FH E
1 0.1 1000 12 5
2 0.8 1000 12 5
3 0.1 3000 12 5
4 0.8 3000 12 5
= 0.1 E000 12 5
5] 0.8 E000 12 5

3 Edit the values in the Free Variables pane in a similar way, if you want to define the
starting values of the free variables, or you can leave these at the default.

* For fmincon optimizations you can specify a number of initial starting values per
run, see “fmincon Optimization Parameters” on page 6-61.

+ If'you wish to restrict the range of the free variables, you can select
Optimization > Edit Free Variable Ranges. The default is the range of the
variable as defined in the Variable Dictionary.

4  Use the right-click context menu to duplicate or delete runs, or select Fill All Runs
to copy the selected run's values to all other runs.

The Number of Values controls are for sum optimizations. See “Selecting Scalar
Variables” on page 6-25.
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Import from a Data Set

1

2
3

Select Optimization > Import From Data Set (or use the toolbar button) to define
the operating points for an optimization from a data set, if you have suitable variables
to import. The Import From Data Set dialog box appears.

) Import From Data Set =101 x|

Data set ta impart from:
[ Crly shove data sets that contain optimization inputs

[Matme Rorevs | Conterts
7] Operating_points 42/, L
Kl | 0
Select data set columns to use:
Import | Optimization Input Data Set Column
C B Z
I |ece =
[~ cp |
I Y &N [
F L Bl =

— Import options

{+ Use one data set row for each run (atter number of runs)

" Use entire data set column for each run (atter length of each variahle)

QK I Cancel |

Select a data set.
Select data set columns to import.
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4 Choose whether you want a run per data set row (alter number of runs), or each
imported variable to have the same length as the number of data set rows (alter
length). For information on altering the length of variables (for sum optimizations
only), see “Selecting Scalar Variables” on page 6-25.

5 Click OK to import the variable values.

Import from Output
1 Select Optimization > Import From Output to import starting values from the

output values of a previous optimization. The Import From Output dialog box
appears.
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) Import From Output

Optimization output to import from:

v Orly shove outputs that cortain optimization inputs

=0l x|

— Selection within output

lN.ame RFowws | Solutions |Free Varishles Fixed\arishles
0 Optimization_Cutput 100 1|5, ECP, ICP M, L
1 optimization_Output_1 100 1| 5, ECP, ICP N, L

4 | |
Select output columns to use:
Import | Optimization Ingpot Outpt Yalue

¥V s X S =

¥ [ecr x ECP [

¥ icp X ICP =

M X N [

V L X L =

Runs: (% All
" Selection:
" Acceptable

" Unacceptable

Salution: (% Selected solition
£ Salution;

[ 2

—

Select in Takle... |

— Import option=

% Use one output row for each run Cater number of runs)

(" Use ertire output column for each run (atter length of each variable)

Ok I Cancel |

Select the desired optimization output.

Select the columns from the output you want to import.

Choose the runs from the optimization output that you want to use. The Selection
within output controls allow you to choose a subselection. If the number of values
per run differs between current inputs and selected outputs, the inputs are altered to

match.

* Select the option button All to import all runs.
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* Select the option button Selection to import a subset of runs. You can enter a
vector specifying the runs you want to import (e.g., 1 3 6:9), or click the button
Select in Table to open a dialog box and select runs manually.

* Select the option button Acceptable to use only the runs with a selected Accept
check box. See “Choosing Acceptable Solutions” on page 7-2. Click the button
Select in Table to open a dialog box and view or edit the selection.

* Select the option button Unacceptable to use only the runs without a selected
Accept check box. Click the button Select in Table to open a dialog box and view
and edit the selection.

» For multiobjective optimizations you can choose to use the selected solutions or a
solution number.

5 Use the Import options buttons to choose whether you want a run per output row

(alter number of runs), or each imported variable to have the same length as the

number of output rows (alter length).

If you click the button Select in Table you see the following dialog box.
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T — =lolx|

Select s subset of the output data by highlighting & selection of rowws in the displayed table of
output data. If there are muttiple solutions in the output you can look st each solution.

Run selection: E4 2225 3236 43:47 55 Salution: %) Selected solution
( Solution; I 1 EI

Select runs based on acceptability: IAcceptabIe - l Select |

‘Wector display format: W

Fun | @) Accept 5 ECP ICP H L 0b
14 d + 22.565 -5 26.881 1000 n4 s
15 e r 22548 11.592 16.101 1000 05

16 8 r 24 507 20116 20418 1000 05

17 e r 25 225 225 1000 07 J
18 & r 5 325 225 1000 0&

19 $r 25 25 25 1000 03

20 e 25 225 225 1000 1

21 L I 2234 M .993 18.977 1500 0.1

22 a ~ 2585 0 50 1500 02

23 d +~ 235089 2077 24321 1500 03

24 d ~ 26985 & 31.996 1500 04

25 d F 33.084 376 50 1500 05

26 e r 25 22.5 225 1500 05

27 & r | 25 225 22.5I 1500 07 _ILI

4 *

Ok I Cancel |

Highlight cells in the table (Shift+click, Ctrl+click, or click and drag) to select runs to
import.

If you chose a subselection on the parent dialog box (e.g., a vector of runs or an
acceptable status), the table appears prefiltered with runs selected by those choices. You
can filter again for acceptable status on this dialog box: select Acceptable or
Unacceptable from the drop-down list and click the Select button.

If there are multiple solutions in the output you can browse them with the Solution
controls.

When you are satisfied with the selected runs, click OK to return to the Import From
Output dialog box. Click OK to import the runs.
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Import from Table Grid

1 Select Optimization > Import From Table Grid to import starting values from the
breakpoint values of a table. The Import From Table Grid dialog box appears.

J Import From Table Grid ] _ -10] x|

Select table to import grid from:

Matne ize Fiowy Inpt Column Input
A EXHCAM 10%10 L Y -
IMTC 0 1010 L h,
MET_Ease 10x10 L il
L MET Dusl 10%10 L M
L MET Exhaust 1060 L N hd

— Import options

% |lze one table cell for esch run (alter number of runs)

{ Use alltable cells for each run (atter length of each variakble)

Ok Cancel

Select the desired table in the list.

Use the Import options buttons to choose whether you want a run per table cell
(alter number of runs), or each imported variable to have the same length as the
number of table cells (alter length).

4 Click OK.

When you click OK, values for each table cell are imported into the optimization input
variable values pane, e.g., for a 10 by 10 table, 100 starting points are imported.

Import from Table Values

1  Select Optimization > Import From Table Values to import starting values from
the evaluation of a table. The Import From Table Values dialog box appears.
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) Import From Table Yalues

Fill aptimization input variable values with the evaluation of a table. Unmatched
inputs are unattered by the import. Matched inputs are replaced with an

evaluation of the table st the current optimization values.

=10l x|

Select table values to import:

Impart | Optimization Input Fill Input Witk
W |z 1 MET Base =]
W  |EcP 1% ExHCAM =]
™ lcp i
I~ [
L i
]9 Cancel

2 For each input you want to import, select the appropriate table from the Fill Input

With list.

The check box for an input is automatically selected when you select a table for it.

You cannot choose to fill an input with a table that depends on it.

3 Click OK.

When you click OK, your selected optimization inputs are replaced with an evaluation of
the table at the current optimization values. Other inputs are not altered.
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Edit Objectives and Constraints

In this section...

“Overview of Objectives and Constraints” on page 6-51
“Edit Objective” on page 6-52
“Edit Constraint” on page 6-54

Overview of Objectives and Constraints

When you create your optimization, you can set up initial objectives and a boundary
constraint within the Create Optimization from Model wizard. You can add and edit
constraints and objectives in the main CAGE Optimization view.

You can perform the following tasks by using the right-click context menu or
Optimization menu (if allowed by the algorithm—fmincon can only have a single
objective):

* You can Add, Edit, Delete, or Rename objectives and constraints.

» For objectives, if your objective model has a boundary model, you can select Add
modelname Boundary to Constraints. This shortcut allows you to set up a boundary
constraint without needing to open the Edit Constraint dialog box.

* For constraints, you can:

* Select Duplicate to copy an existing constraint.

* Select Import to copy existing constraints from another suitable optimization (with
common free variables) in your session. Values for any new variables are only
imported if the number of points in the optimization match.

* Select Disable to remove constraints without deleting them, and use Enable to
reapply them.

» For objectives and constraints, you can Select Application Point Set. See “Using
Application Point Sets” on page 6-28.

Double-click to edit existing objectives and constraints in the Objectives or Constraints
panes. This opens the Edit Objective or Edit Constraint dialog boxes.

You can run two types of optimizations, point optimizations and sum optimizations. Point
optimizations look for the optimal values of each objective function at each point of an
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operating point set. A sum optimization finds the optimal value of a weighted sum of each
objective function. The weighted sum is taken over each point, and the weights can be
edited.

You can set up sum objectives either in the Create Optimization from Model wizard or the
Edit Objective dialog box.

You need to use the Edit Constraint dialog box to set up model sum constraints. You
cannot set up sum constraints from the Create Optimization from Model wizard or the
Optimization Wizard.

You can also set up linear, 1- and 2-D table, and ellipsoid constraints in the Edit
Constraint dialog box, as for designs in the Model Browser part of the Model-Based
Calibration Toolbox product.

Edit Objective

Double-click or right-click objectives to open the Edit Objective dialog box.

) Edit Objective o ] 4

Ohjective type: IPoint Chbjective - I A point objective function is & CAGE model that provides -
an ohjective to be optimized for each set of input values., ”

Ohjective name; Ebjective

Available models: Ohijective type:

Madel Type " Minimize
TG _Model MEC maodlel i Maximize
ol NOXFLOWY Model MEC madel

= Helper

Selected model: TE_Made!

Ok I Cancel | Help |

You can select Point objective or Sum objective from the Objective type drop-
down menu. Use sum objectives only for weighted sum optimizations; otherwise, use
point objectives.
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You can rename the objective by editing the Objective name edit box, to aid analysis in
the Optimization views. This may be disabled for user-defined optimizations.

Point Objectives

The preceding example shows the point objective controls. Select which models from your
session you want to use for the optimization, and whether you want to maximize or
minimize the model output. The fmincon algorithm is for single objectives, so you can
only maximize or minimize one model. The NBI algorithm can evaluate multiple
objectives. For example, you might want to maximize torque while minimizing NOX
emissions.

You can also include 'helper' models in your user-defined optimizations, so you can view
other useful information to help you make optimization decisions (this is not enabled for
NBI or fmincon).

These are the same options you can choose in the Optimization Wizard. See “Optimization
Wizard Step 4” on page 6-18.

Sum Objectives

For weighted sum optimizations, the objectives are typically sum objectives. See the
following example.
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) Edit Dbjective o ] [

Ohjective type: ISum Objective - I A =um objective function calculstes the weighted sum of the \7_.%9'
output of & CAGE model sz its objective value. Py ¥

Objective name: ETQ T A

Available models: Objective type:

Model Type " Minimize

SLETO ME model & Maximize

-\ EXTEMP ME model € Helper

-ﬂ. REZIDFRAC MEC model

-\ WET ME model

-ﬂ. RESIDFRACEMET MEC model

‘ﬂ METwithSpeedloadBoundary | MEC model

Selected maodel: BTE

Ok I Cancel Help

As for point objectives, select which models from your session you want to use for the
optimization, and whether you want to maximize or minimize the model output.

You can edit weights in the Optimization view, to make certain operating points more
important, giving more flexibility to solutions for other points. You can edit the weights in
the Fixed Variables pane. This is the same process as selecting weights for the
Weighted Pareto View. See “Weighted Objective Pareto Slice” on page 7-67.

Edit Constraint

You can rename the constraint by editing the Constraint name edit box, to aid analysis
in the Optimization views. This may be disabled for user-defined optimizations.

Select a Constraint type in the drop-down menu. The first four choices are the same as
the following design constraint types:

¢ “Linear Constraints”

» “Ellipsoid Constraints”
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« “1-D Table Constraints”
o “2-D Table Constraints”

These are the same constraints you can apply to designs in the Model Browser part of the
Model-Based Calibration Toolbox product.

In the context of optimization you can select constraint inputs on the additional Inputs
tab. You can select any variable or model as an input into constraints. The default selects
the free variables where possible. Models are treated as nonlinear functions, so if you
choose to feed a model into a linear constraint it will make that constraint nonlinear. You
are not able to access it as a linear constraint in user-defined optimization scripts.

For optimization constraints you can also select the following constraint types:

* “Model Constraints” on page 6-55

* “Range Constraints” on page 6-56

* “Sum Constraints” on page 6-57

* “Table Gradient Constraints” on page 6-57

Model Constraints
To construct a model constraint:

Select an Input model in the left list.

You can use the Evaluate quantity drop-down list to choose Evaluation value,
Boundary constraint, or PEV value (model prediction error variance) to define
your constraint.

3 Choose the appropriate option button to either enter a value in the Constant edit
box, or to select a CAGE item from the list of models or variables.

4 Select the Constraint type operator to define whether the optimization output
should be constrained to be greater than, less than, or equal to the constant or item
value specified on the right.

5 Check the displayed Constraint description, and click OK.

The model constraint settings are shown in the following figure.
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) Edit Constraint O o [=] S
Constraint type: Ir.1.;|ue| - I Model constraintz keep only points where the output value L
of an expression is above, below or equal to the zpecified limit. “
Constraint name: Fq_equals
Input model: Constraint bound:
Model Type £ Constant; I 0 %
Hitg MBC model |4 * CAGE item:
vt WMBC model
4 e s IShuw variables j
ol eqrexh MBC model
«fk pkpress MBC model Constraint type: SZIELE Type
-‘. exhtemp MEC model I== - I X _fuelpress Variable :I
4 NOX WMBC model X grackmea Variable
-‘. eqrmf MEC model X _egrlit Variable
'@. bsfc Function model | X tq_desired “Variable
-@.afr Function model j X _afr_min Variable il
Evaluate quantity: IEvaIuatiun value j Evaluate quantity: IEvaIuatiun value j
Constraint description: ‘tq(sui, meazrpm, basefueimazs, fuelpress, grackmea, egrift) == tq_desired
oK I Cancel | Help |

Range Constraints

You can specify an upper and lower bound to constrain expressions (which can be
variables, models or tables). You can specify bounds with constants, vectors, variables,
models, or tables.

1 Select a CAGE item to constrain on the Bound Expression tab. Use the drop-down
menu to switch between variables, models, or tables, and then select the item to
constrain. For appropriate models you can also choose to constrain either the PEV or
evaluation value.

2  On the Lower Bound tab, select an option button to choose whether to use a constant,
vector, or CAGE item to specify the bound.
* For constants, enter a value.

» For vectors, you can enter the lower bound for each point in the Input Variable
Values pane in the Optimization view after you close the Edit Constraint dialog
box.
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* For CAGE items, use the drop-down menu to switch between variables, models, or
tables, and then select the item to specify the lower bound. For appropriate
models you can also choose to use either the PEV or evaluation value.

3 Specify the upper bound on the Upper Bound tab in the same way as you specified
the lower bound on the Lower Bound tab.

4  Check the displayed Constraint description, and click OK.

For a detailed explanation of range constraint outputs, see “Range Constraint Output” on
page 7-30.

Sum Constraints

Use these for weighted sum optimizations. Choose a model, constraint bound value and
an operator.

You can have a mixture of point and sum constraints.
Table Gradient Constraints

Table Gradient constraints must be used in sum optimizations. Unless you are using a
user-defined optimization, for Table Gradient constraints, use a sum objective. You cannot
run point optimizations that contain table gradient constraints.

Table Gradient constraints allow you to constrain the gradient of a free variable or model
over a grid of fixed variables.
1 Select a free variable or model to constrain.

2 Specify one or two fixed variables, and a grid of points either manually or by
selecting table axes.

3  Enter values in the Maximum change and Axis value change edit boxes to specify
the maximum change in the free variable or model per amount of fixed variable
change between cells. For example, enter 5 and 1000 to specify 5 degrees maximum
change in cam angle per 1000 rpm.

4 To set upper limits or lower limits in a table gradient constraint, specify a two
element row vector in the Maximum change edit box. e.g., [-5 20].
Use Inf if you only want to specify a lower or upper bound, e.g., enter [0 Inf] to
specify a table gradient > 0, and [-Inf 0] to specify a table gradient < 0.

5 Check the displayed Constraint description, and click OK.
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See Also

More About
. “Table Gradient Constraint Output” on page 7-78
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Run Optimizations

When you have created an optimization, your new optimization appears as a new node in
the tree pane on the left, and the setup details appear on the right. An example follows:

) CAGE Browser - tradeoffInit.cag

File Edit Optimization Tools Window Help

=10l x|

B EE T YT |
Processes Optirnization | Ohbjectives | Optirnization Information
------ Optimization Mame |Descripﬁ0n |Type Algor... |mbc:OSfminc:0n
Ay Chijectivel TG _Model(SPK, L, M, &, E) i (Algori... |Single objective...
Free ... |SPK
Feature
L) J | 0
|} . :
: |C0nstra|nts |
}&me | Descrigtion [statu |
4 constraintt MOKFLOWY_Model(SPHK, L, M, &, ..
4 | i

Free Wariahle Intial ‘alues Fixed “ariahle Yalues
Murnber of runs: |—1§| “ector display format: |Expanded ver... =
ector display format: IExpanded Vet .. vl Watiable: L N .
Mumber of 1= = l—
“ariable: SPK walles: - -
Murmber of 1= 1 | 1 0.6 2500
values: =
1 ] 0
I I i

| Ready

If your optimization is ready to run you can click Run Optimization in the toolbar to
proceed. You may want to edit variable values, constraints or objectives before running
the optimization. If you need to set up any objectives or constraints Run will not be
enabled. If your optimization is ready to run you can also click Set Up and Run
Optimization if you want to change algorithm-specific settings such as number of
required solutions and tolerances for termination.
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* Ifyou click Set Up and Run Optimization, you can change settings in the
Optimization Parameters dialog box. Then when you click OK the optimization process
begins. See “Edit Optimization Parameters” on page 6-61.

* Ifyou click Run Optimization instead, you do not see the optimization settings, but
go straight to running the optimization.

You will see a progress bar as the optimization proceeds. When it is finished, a new
Output node appears under your Optimization node in the tree and the view automatically
switches to this node where you can analyze the results. An example tree is shown in the
following figure. For information on viewing and using your results, see “Optimization
Analysis”.

Optirnization |
=-[# Optimization
-- Optimization_Output
E| Optimization_1
Optimization_1_Output
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Edit Optimization Parameters

In this section...

“Overview of the Optimization Parameters Dialog Box” on page 6-61
“fmincon Optimization Parameters” on page 6-61

“NBI Optimization Parameters” on page 6-63

“GA Optimization Parameters” on page 6-64

“Pattern Search Optimization Parameters” on page 6-65

“Modal Optimization Parameters” on page 6-67

“MultiStart Optimization Parameters” on page 6-67

“gamultiobj Optimization Parameters” on page 6-68

“Scale Optimization” on page 6-68

Overview of the Optimization Parameters Dialog Box
The settings in the Optimization Parameters dialog box are algorithm specific.

If you edit these settings and later want to return to the defaults, select Optimization >
Reset Parameters. If you add parameters to user-defined optimization scripts, you may
need to use this reset option to make all new parameters appear in the dialog box.

fmincon Optimization Parameters

The fmincon optimization algorithm in CAGE uses the MATLAB fmincon algorithm from
the Optimization Toolbox product. fmincon wraps up the fmincon function so that you
can use the function for maximizing as well as minimizing. For more information, see the
fmincon reference page in the Optimization Toolbox documentation, fmincon.

* Constrained optimization algorithm — Choose one of the fmincon function
algorithms: active-set, sqp, interior-point. Try the default first, interior-
point. Try sqp or interior-point with sum optimizations which are slow or have
problems converging. Optimizations created before Release 2010a do not have this
setting.

* Display — choose none, iter, or final. This setting determines the level of
diagnostic information displayed in the MATLAB workspace.
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* none — No information is displayed.

* iter — Displays statistical information every iteration.

+ final — Displays statistical information at the end of the optimization.
* Maximum iterations — Choose a positive integer.

Maximum number of iterations allowed
* Maximum function evaluations — Choose a positive integer.

Maximum number of function evaluations allowed
* Function tolerance — Choose a positive scalar value.

Termination tolerance on the function value
* Variable tolerance — Choose a positive scalar value.

Termination tolerance on the free variables
* Constraint tolerance — Choose a positive scalar value.

Termination tolerance on the constraint violation
¢ Number of start points — Choose a positive integer, N. (N-1) start points per run are
generated in addition to the starting value specified in the Input Variable Values pane.

The optimization runs from each of the N start points (possibly subject to feasibility,
see Run from feasible start points only option) and the best solution is chosen.

The N-1 extra start points are generated as follows:

1 Generate a 10000 point Halton set design, D, over the free variables.
Evaluate the objectives and constraints over D.
Return the N-1 feasible points with the lowest objective value.

If there are not N-1 feasible points, fill the remaining starting values with the
points with the lowest maximum constraint violation.

Note For point optimization problems, it is strongly recommended that you set
Number of start points to either 1 or 2.

* Run from feasible start points only — Select this option to terminate all runs that
start with an initial value that does not satisfy the constraints. If this condition is not
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met this is reported in Qutput message, in the Solution Information pane of the
Optimization Output view.

Interface version — This option is only enabled when a user-defined optimization
script does not specify a version to use. Some existing user-defined optimization
scripts may require setting the interface version as 2 or 3, according to the toolbox
version. Version 3 is preferable, but may not work with all old scripts. See
setRunInterfaceVersion for details.

NBI Optimization Parameters

The NBI algorithm is for multiobjective optimizations. For more details see “Set Up
Multiobjective Optimizations” on page 6-30.

View and edit the NBI options in the Optimization Parameters dialog box.

NBI Options

Tradeoff points per objective pair (Np)
Specify how many tradeoff solutions you want the optimization to find per run.

The number of tradeoff solutions between your objectives that you want to find, Npts,
is determined by the following formula:

_(n+Np-12
Npts - ("3, 01 )

where

* Np is the number of points per objective pair.
* nis the number of objective functions.

Note the following:

For problems with two objectives (n = 2),
Npts = Np

For problems with three objectives (n = 3),

Npts = NEEI\;E +1y
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Shadow minima options and NBI subproblem options

The NBI algorithm uses the MATLAB fmincon algorithm to solve the shadow minima
problem and the NBI subproblems, the options available are similar to those for the
fmincon library function. For more information on these options, see the previous
section, “fmincon Optimization Parameters” on page 6-61.

For more information on the NBI algorithm, see “About the NBI (Normal Boundary
Intersection) Algorithm” on page 6-31.

GA Optimization Parameters

The ga optimization algorithm in CAGE uses the MATLAB ga algorithm from Global
Optimization Toolbox product. In CAGE, ga wraps up the ga function from this toolbox so
that you can use the function for maximizing as well as minimizing. If you have Global
Optimization Toolbox product installed, see “Genetic Algorithm” (Global Optimization
Toolbox).

Display — choose none, iter, final, or diagnose. This setting determines the level
of diagnostic information displayed in the MATLAB workspace.

* none — No information is displayed.
* iter — Displays statistical information every iteration.
+ final — Displays statistical information at the end of the optimization.

* diagnose — Displays information at each iteration. In addition, the diagnostic lists
some problem information and the options that have been changed from the
defaults.

Crossover function — Choose a function to use to generate new population members
from the existing GA population by crossover. For more information on each function,
see the Crossover Options section in the Global Optimization Toolbox documentation.
It is recommended not to use a heuristic crossover function for nonlinearly
constrained problems.

Crossover fraction — Choose a scalar in the range [0 1]. This parameter specifies the
fraction of the next generation, other than elite children, that is produced by
Crossover.

Mutation function — Choose a function to use to generate new population members
from the existing GA population by mutation. The fraction of the next generation,
other than elite children, that is produced by mutation is (1 minus Crossover
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fraction). Also, for nonlinearly constrained problems, the mutation function must be
set to adaptfeasible.

Selection function — Choose a function to use to select the population members that
will be used as the parents for the crossover and selection functions.

Population size — Choose a positive integer value. Number of population members
used by the algorithm. See the Global Optimization Toolbox documentation for
guidelines on setting the population size.

Generations - Choose a positive integer value. The algorithm stops when the number
of generations reaches the value of Generations.

Hybrid function — Choose an optimization function that will run after the GA has
terminated to try to improve the value of the objective function. Note that if the
algorithm has nonlinear constraints, the hybrid function cannot be fminunc or
fminsearch. If either of these algorithms is selected in this case, the hybrid
algorithm switches to fmincon.

Stall generations — Choose a positive integer value. The algorithm stops when the
weighted average change in the objective function over Stall generations is less than
Function tolerance.

Stall time limit - Choose a positive scalar value. The algorithm stops if there is no
improvement in the objective function during an interval of time in seconds equal to
Stall time limit.

Function tolerance — Choose a positive scalar value. The algorithm runs until the
weighted average change in the fitness function value over Stall generations is less
than Function tolerance.

Constraint tolerance - Choose a positive scalar value. This tolerance determines
whether a population member is feasible with respect to the nonlinear constraints.

Time limit - Choose a positive scalar value. The algorithm stops after running for an
amount of time in seconds equal to Time limit.

Pattern Search Optimization Parameters

The patternsearch optimization algorithm in CAGE uses the MATLAB patternsearch
algorithm from Global Optimization Toolbox product. In CAGE, patternsearch wraps up
the patternsearch function from this toolbox so that you can use the function for
maximizing as well as minimizing. If you have the Global Optimization Toolbox product
installed, see “Direct Search” (Global Optimization Toolbox).

Display — Choose none, iter, final, or diagnose. This setting determines the
level of diagnostic information displayed in the MATLAB workspace.
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* none — No information is displayed.
+ iter — Displays statistical information at every iteration.
» final — Displays statistical information at the end of the optimization.

* diagnose — Displays information at each iteration. In addition, the diagnostic lists
some problem information and the options that have been changed from the
defaults.

* Time limit - Choose a positive scalar value. The algorithm stops after running for an
amount of time in seconds equal to Time limit.

¢ Maximum number of iterations — Choose a positive scalar value. This parameter
specifies the maximum number of iterations performed by the algorithm.

* Maximum function evaluations — Choose a positive integer value. The algorithm
stops if the number of function evaluations reaches this value.

* Variable tolerance — Choose a positive scalar value. The algorithm stops if the
distance between two consecutive free variable values is less than the variable
tolerance.

* Function tolerance — Choose a positive scalar value. The algorithm stops if the
distance between two consecutive objective function values and the mesh size are
both less than Function tolerance.

* Constraint tolerance - Choose a positive scalar value. Determine feasibility with
respect to the nonlinear constraints.

* Mesh tolerance — Choose a positive scalar value. The algorithm stops if the mesh
size is smaller than Mesh tolerance.

» Initial mesh size — Choose a positive scalar value. Sets the initial size of the mesh
for the pattern search algorithm. Do not set this value too small, as insufficient size
may lead to the algorithm getting trapped in local optima.

* Poll method - Choose a poll method from the drop-down list. This parameter sets the
polling strategy that will be used by the pattern search algorithm. Generally, the
GPSPositiveBasis2N and MADSPositiveBasis2N methods will be slower than the
GPSPositiveBasisNpl and MADSPositiveBasisNpl methods. However, the
former methods perform a more thorough search. For more information on these
methods, consult the Global Optimization Toolbox documentation.

* Search method — Choose a search method from the drop-down list. This parameter
selects a function that will perform a search in addition to that performed by the
pattern search algorithm. For automotive problems, searchlhs tends to perform well.
For details on possible search methods, consult the Global Optimization Toolbox
documentation.
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Modal Optimization Parameters

Use the Modal optimization algorithm with a composite model to select the best
operating mode for each operating point. The algorithm uses the fmincon algorithm to
optimize an objective for each operating mode and select the best solution.

Modal optimization has the same parameters as fmincon, plus two additional
parameters:

* Index to mode free variable — Specify mode variable (only for optimizations created
with the Optimization Wizard). If you use the Create Optimization from Model wizard,
you select your mode variable during setup and do not need to set this index on the
Optimization Parameters dialog box. If you use the Custom Optimization Wizard to
create your optimization, then you must use this setting to specify your mode variable.

* Index to the objective to determine best mode — (Optional) Choose which
objective (if you have multiple) to use to select best mode. The default is 1, so CAGE
uses the optimized values of the first objective to select the best mode. Change the
index to use a different objective.

See “Set Up Modal Optimizations” on page 6-35.

MultiStart Optimization Parameters

The MultiStart optimization algorithm in CAGE uses the MultiStart algorithm from
Global Optimization Toolbox product. The MultiStart algorithm tries to identify
multiple optimal solutions for each operating point. You can set a subset of the algorithm
options in CAGE. If you have Global Optimization Toolbox, see “How GlobalSearch and
MultiStart Work” (Global Optimization Toolbox).

In CAGE, the MultiStart algorithm uses the fmincon algorithm to optimize an
objective for multiple start points at each operating point, and selects the best solution.
You can specify the number of start points and other options in the Optimization
Parameters dialog box.

*  Number of start points — Choose the number of start points per operating point
(default is 10).

» Start point set type — Choose Sobol Set (space-filling start points) or Random
(random start points).

* Start points to run — Choose all or bounds-inegs. Use bounds-ineqs to run
only feasible start points that meet constraints.
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* Run start points in parallel — Choose never or always to run each start point in
parallel. Ensure the Distribute Runs optimization option is turned off for the start
points to run in parallel. See “Parallel Computing in Optimization” on page 6-3.

* Tolerance for separate objective values — Specify how far apart objective values
must be to qualify as separate local optima.

+ Tolerance for separate solutions — Specify how far apart solution free variable
values must be to qualify as separate solutions.

* Local optimization solver — Specify fmincon options. See “fmincon Optimization
Parameters” on page 6-61 for these options.

See “Set Up MultiStart Optimizations” on page 6-39.

gamultiobj Optimization Parameters

The gamultiobj algorithm uses the gamultiobj function from the Global Optimization
Toolbox product.

If you have Global Optimization Toolbox, see “Multiobjective Optimization” (Global
Optimization Toolbox).

The optimization parameters for gamultiobj are similar to the options for GA, with some
additional options specific to gamultiobj. See “GA Optimization Parameters” on page 6-
64 and gamultiobj.

Use a point optimization to find feasible start points for a sum optimization, then select
Solution > Create Sum Optimization. CAGE sets a default population size of 200 for
the gamultiobj sum optimization. If CAGE does not find a feasible solution, try
increasing the population size in the Optimization Parameters dialog box. Larger
populations increase the chance of finding feasible points, but take longer to compute.

Scale Optimization

The Optimization menu contains the option to Scale Optimization Items — Select this
to toggle scaling on and off. When you select scaling on, objective and constraint
evaluations are (approximately) scaled onto the range [-1 1]. With scaling off, when you
run the optimization the ohjective and constraint evaluations return their raw numbers.

Try running your optimization with scaling off, which is the default setting, to see if it
converges to a satisfactory solution (check the output flags and the contour view). If your
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optimization solution is unsatisfactory, check to see if the objective and constraint
functions have vastly different scales. In this case, try turning scaling on, because these
optimization problems may benefit from objective and constraint evaluations being scaled
to a common scale.

The output view always shows the solutions in raw, unscaled values, whether or not you
use scaling to evaluate the problem.
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This section includes the following topics:

+ “Using Optimization Results” on page 7-2

* “Filling Tables from Optimization Results” on page 7-9

* “Viewing Your Optimization Results” on page 7-18

* “Analyzing Point Optimization Output” on page 7-36

* “Tools for Optimizations with Multiple Solutions” on page 7-51
* “Analyzing Modal Optimization Results” on page 7-57

* “Analyzing MultiStart Optimization Results” on page 7-63

* “Analyzing Multiobjective Optimization Results” on page 7-66
* “Interpreting Sum Optimization Output” on page 7-72
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Using Optimization Results
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In this section...

“Choosing Acceptable Solutions” on page 7-2
“Create Sum Optimization from Point Optimization Output” on page 7-4
“Exporting to a Data Set” on page 7-4

“Custom Fill Function Structure” on page 7-6

Choosing Acceptable Solutions

After you run an optimization, an Qutput node appears in the optimization tree and the
Optimization Output views appear. CAGE provides tools for analyzing your results with
these views.

CAGE automatically selects successful optimization solutions and highlights unsuccessful
solutions for you to investigate. These selections are shown in the icons and check boxes
next to the Run column in the Optimization Results table, and shown in the Results
Surface and Results Contour views. You can change the selections using the check boxes
for each solution, or right-click to change acceptable status of solutions in the graphical
views.

You can use these selections to choose solutions within the table for use in:

» “Filling Tables from Optimization Results” on page 7-9
* “Exporting to a Data Set” on page 7-4
* Importing to other optimization starting values: “Import from Output” on page 6-45

Accept status is shown in the following ways:

* CAGE automatically selects the Accept check boxes for solutions where the algorithm
exit flag indicates success (>0). These solutions show a green square icon next to the
check box. Typically constraints are met within tolerance.

[~

* Solutions with a red round icon indicate that the algorithm exit flag does not report
success (<0). Some constraints may not be met.

LIl
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Solutions with an orange triangular icon indicate that the algorithm exit flag is zero.
Some constraints may not be met. An exit flag of zero indicates the algorithm failed
because it exceeded limits on the amount of computation allowed (e.g., the algorithm
ran out of iterations or function evaluations). You could decide to accept these
solutions or you could try changing tolerances and optimizing again.

Al

Solutions where you have altered the check box status show an asterisk.

AP

Violated constraints are shown by yellow cells with cross icons in the table. You can
control the value used for this highlighting by selecting View > Edit Constraint
Tolerance.

4703187

It is possible to have highlighted constraints within green accept status solutions. The
algorithm can report success if constraints are met within tolerance on scaled values.
The constraint display applies a tolerance to raw values, and you can also edit this
tolerance to help you analyze results.

If you are viewing constraints with multiple values and have the view set to Compact,
the cell is yellow if any of the individual values are infeasible.

You can view the algorithm output flag in a tooltip by hovering the mouse over each
colored accept status icon, or click to select a solution and then you can view the
algorithm Exit flag, Exit message and other details in the Solution Information
table.

The icon and (editable) Accept status check box are also shown at the top right for the
currently selected solution.

For more information on using the graphical views to investigate your results, see
“Viewing Your Optimization Results” on page 7-18.

CAGE has additional graphical tools for analyzing optimizations with more than one
solution. See “Tools for Optimizations with Multiple Solutions” on page 7-51.

Note For help understanding your results, see “Analyzing Point Optimization Output” on
page 7-36 or “Interpreting Sum Optimization Output” on page 7-72.
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Create Sum Optimization from Point Optimization Output

Many users employ a point optimization to find good initial values for a sum optimization.
To make this workflow easier and faster, you can use a utility to create a sum optimization
from your point optimization output.

From your point optimization output node, select Solution > Create Sum Optimization.

CAGE creates a new optimization (called Sum_myOptimizationName). The optimization
has these characteristics:

» The objective matches your original optimization but converted to a sum objective.

* The new optimization has identical constraints to your original optimization. Edit or
add to these as usual if desired.

* Your original fixed and free variables are converted to a sum optimization (a single run
with multiple values).

* The new optimization uses only accepted solutions from your original optimization
output (all runs with a selected Accept check box).

* Therefore, the number of accepted solutions you had in the original optimization
determines the number of values within the sum optimization run.

* The free variable initial values and fixed variable values are populated from your point
optimal results (accepted solutions only).

* The fixed variables have a Weights column with every value set to 1.

If you rerun point optimizations that have associated sum optimizations, the Model-Based
Calibration Toolbox can update and rerun the sum optimization with the point
optimization results. The Model-Based Calibration Toolbox uses the existing sum
optimization constraints when it reruns the optimization. Previously, the Model-Based
Calibration Toolbox created a new sum optimization.

For modal and multistart optimizations, the create sum optimization function converts the
optimization to a standard single objective optimization (fmincon algorithm). See
“Creating Sum Optimizations from Modal Optimizations” on page 7-60 and “Creating
Sum Optimizations from MultiStart Optimizations” on page 7-65.

Exporting to a Data Set

You can export the optimization output results to new or existing data sets.
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Note In an optimization where there is only one solution for each operating point, this is
exported. Use the Accept check boxes to choose a subset of results for export. See
“Choosing Acceptable Solutions” on page 7-2.

Some optimizations produce more than one solution per point, so you can either export all
solutions or select your preferred solutions for export to a data set. See “Tools for
Optimizations with Multiple Solutions” on page 7-51.

To export to a data set:

1 Select Solution > Export to Data Set or use the toolbar button. The Export to Data
Set dialog box appears.

) boport ToDataser _imix

Select target data set:
£ Mewy:

"dew_Dataset
+ Modify existing:

Mame: Roswes | Columns

Optim_fmincon 43| S, ECP, TP, M, L
B Optim_patternsearch 43| 5, ECP,ICP, N, L
Action: I.&ppend j

[+ Use acceptable solutions only

Ok | Cancel |

2 [f exporting to a New data set (the default), you can edit the name in the edit box.

3 Ifyou want to overwrite or add to an existing data set:
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Click the option button Modify existing.
Select the desired data set in the list.
¢ Choose from Action list:

* Append adds the data to the chosen data set.
* Overwrite replaces all data in the data set with the new data.

4 By default, the check box Use acceptable solutions only is selected. Optimization
results with selected Accept check boxes will be exported. Clear the Use acceptable
solutions only check box if you want to export all the optimization results. See
“Choosing Acceptable Solutions” on page 7-2.

5 Click OK and the data is exported to the data set.
Export Rules
All fixed and free variables are exported where possible.

No models are exported to the data set. If you want to evaluate a model at the variable
values, add the model to the data set in the Data Sets view.

When appending, the rules are the same as when merging data sets:
* Columns of inputs are appended to columns with names that match in the data set you
are appending to.

* Outputs (models) and any other columns without matching names are not appended.

* The values for any unmatched columns in the data set are set to the set point if
possible, or zero otherwise.

Custom Fill Function Structure

It can be useful to create your own function to fill tables from the results of an
optimization, for example, to implement alternative fill methods, smoothing strategies, or
to customize output.

The input/output structure of a custom fill function resembles that of the MATLAB
interpolation routines INTERP1 and INTERP2. To see the structure of the function it is
best to look at an example:

1 Locate and open the file griddataTableFill.min the mbctraining folder.
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2 Type the following at the command line to open the example:

edit griddataTableFill

All 2-D custom fill functions must take the following six inputs, which will be supplied to it
by CAGE when the function is called:

Input
col

row
filldata
colaxis

rowaxis
currtabdata

Description

Column coordinate of optimization results (NF -
by-1)

Row coordinate of optimization results (NF-by-1)
Optimized results at (row, col) points (NF-by-1)

Column breakpoints of table to be filled (1-by-
NCOL)

Row breakpoints of table to be filled (NROW-by-1)

Existing table values of table to be filled (NROW-by -
NCOL)

The function must pass three output arguments back to CAGE, to allow CAGE to fill the

table:

Output
ok

tabval

fillmask

In the above specifications:

Description

Boolean flag to indicate success of the table fill
(TRUE or FALSE)

New table values of table to be filled (NROW-by -
NCOL)

Logical matrix to indicate cells to be added to the
extrapolation mask as a consequence of the table
being filled (NROW-by-NCOL)

* NF is the number of points from the optimization results that will be used to fill your

tables.

* NCOL is the number of column breakpoints in the table.

* NROW is the number of row breakpoints in the table.
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Note that your function should handle the cases when the table fill is successful or not. In
griddataTableFill, this is handled using the try-catch construct around the call to
griddata. If griddata should fail, then the ok flag is set to false and the function
returns.

Custom Fill Function for 1-D Tables

You can also write custom fill functions to fill 1-D tables. In this case the input and output
specifications are as follows:

Input Description

row Row coordinate of optimization results (NF-by-1)

filldata Optimized results at (row, col) points (NF-by-1)

rowaxis Row breakpoints of table to be filled (NROW-by-1)
currtabdata Existing table values of table to be filled (NROW-by-1)

Output Description

ok Boolean flag to indicate success of the table fill (TRUE or FALSE)
tabval New table values of table to be filled (NROW-by-1)

fillmask Logical matrix to indicate cells to be added to the extrapolation

mask as a consequence of the table being filled (NROW-by-1)
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Filling Tables from Optimization Results

In this section...

“Table Filling from Optimization Results Wizard” on page 7-9

“Table Filling When Optimization Operating Point Inputs Differ from Table Inputs” on
page 7-13

“Filling Tables Via Data Sets” on page 7-16

You can fill tables with optimization results using either a wizard or data sets.

Table Filling from Optimization Results Wizard

In a single objective optimization, there is only one solution for each operating point, so
you can fill tables with your results. In a multiobjective optimization there is more than
one solution per point, and you must first select the preferred solutions before you can
use the Table Filling wizard. To collect your preferred solutions you must use the
“Selected Solution Slice” on page 7-53, then you can use this wizard to fill tables with

the selected solutions. Modal and multistart optimizations also have multiple solutions per
point but CAGE automatically selects solutions for you, so you do not have to select
solutions before table filling.

In the Optimization output view, you can use the Table Filling wizard as follows.

1 Atthe Optimizationname Output node, select Solution > Fill Tables, or click
the toolbar button = ,

The Table Filling wizard appears.

Note If your tables have been filled before, CAGE remembers all your fill settings
between optimization runs and saves the settings with the CAGE project.

2 Select the tables to fill, and click the button to add them to the list of tables to be
filled. Click Next.
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u Table Filling from Optimization Results Wizard

Table Selection
Select the CAGE tables that vou wish to fill from the optimization results

Axailable CAGE tables: CAGE tables to be filled:

Table Table

L@ MBT_Base(LNormalizer NNormalizer) % ECP_Table(NNormalizer,_Normalizer)

Lﬁ MBT_Intake{LNormalizer, MNNormalizer) LQ ICP_Table{MNormalizer, LNormalizer})

Lﬁ MBT_Exhaust(LMormalizer NMormalizer) LQ BTQ_Table(NNormalizer LNormalizer)

h MBT_Dual(lLNormalizer, NNormalizer) jc? EXTEMP_Table{NMNormalizer, LNormalizer)
LQ MBT_Start(LNormalizer, NNormalizer) 1:? RESIDFRAC_Table(MNormalizer, LNormalizer)

d table to fill

Cancel

o
=]
0
=
L
T
=]
[
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3 Select or change filling factors for the tables.

CAGE automatically populates the filling factors for the tables if you created your
tables using the Create Tables from Model wizard, and left the defaults to add all
your new tables to a tradeoff.

View the Tradeoff column to see if a table is associated with a tradeoff. CAGE does
not populate the fill factor if a table belongs to more than one tradeoff and there are
different fill factors.

Note If you create your tables using the Create Tables from Model wizard, you can
add all your new tables to a tradeoff. The tradeoff can be useful for specifying fill
factors for tables, and for investigating optimization results. See “Creating Tables
from a Model” on page 3-4.
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If your tables are not in a tradeoff and you have not filled them before, select filling

factors for your tables as follows:

a Select a CAGE table to be filled in the Table values to be filled list.

b

Select the correct variable or model output from the list of Optimization

Results and click the button to match the result to the table.

Your selected filling factor appears in the Fill with column.

Repeat for other tables.

u Table Filling from Optimization Results Wizard
Optimal Result Selection

Choose the optimization results that you want to fill each table with.

Tables values to be filled:

CAGE Table Fill with
S_Table(NMormalizer LN... | -

% ECP_Table(NNormalizer, .

| Tradeoff

=15 =

| Optimization Resufts
i ey
X ECP

x IcP
g
xL
| Select optimization result to fill with
o\ EXTEMP
|k RESIDFRAC
<\ MBT

o\ MBTwithSpeedLoadBoundary

X ECP oB BTQ_Tradeoff
% IcP_Table(NNormalizer,L...| x 1cP @ BTO_Tradeoff
% BTQ_Table(NNormalizer, .. <k BTQ 25 BTQ_Tradeoff
% EXTEMP_Table(NNormali... [k EXTEMP 22 BTQ_Tradeoff
% RESIDFRAC_TableiNNor... |k RESIDFRAC |25 BTQ_Tradeoff
Mormalizer inputs:
.Nnrn_'laliz_er i _.Iﬂput_
1= LNormalizer puL
i_{_ NNormalizer X N

s

(e ] |

< Back H Next = ] e

Verify the Normalizer inputs show the correct inputs. You might need to specify the
Normalizer inputs to match with optimization results, if you are filling tables with
different inputs to your optimization operating points. See “Table Filling When
Optimization Operating Point Inputs Differ from Table Inputs” on page 7-13.

Click Next.

Select a Fill Method.

extrapolation.

Extrapolate Fill — Uses the optimization results to fill the whole table by
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* Direct Fill — Fills only those table cells whose breakpoints exactly match the
optimization points.

* Custom Fill — You can write your own table filling algorithm and use the file
browser to select it. See “Custom Fill Function Structure” on page 7-6.

Table Filling from Optimization Results Wizard =] (=]
Fill Algorithm
Set up table filling algorithm.

Fill Method: |Extrapolate Fill -
[¥] Use acceptable solutions only [¥] Use locked table values in extrapolation
|| Update tradeoffs || Use existing extrapolation mask in il

Fitter rules for tables:

Table Output Column Filter Rule Fitter Rule Inputs
% 5 Table xS X 5
% ECP_Table X ECP X ECP
% cP_Table X IcP x Icp
®pTo Table  |4hBETQ XN
% EXTEMP_Table |<fk EXTEMP xL
% resoFRAC_T... |k RESIDFRAC <\ BTO
<\ EXTEMP
-\ RESIDFRAC
< MBT

A MBTwithSpeedLoadBoundary

| Cancel || = Back | Mext = Finish

5 Use acceptable solutions only — Leave this check box selected to use only
optimization results marked as 'acceptable'. See “Choosing Acceptable Solutions” on
page 7-2.

6 Update tradeoffs — Select this check box to update tradeoffs with the optimal
values from your optimization. You must update your tradeoff to populate it with
optimization results. If you do not update the tradeoff, table values and tradeoff
values do not match.

For best results, you need a table for each model input (free and fixed, except
normalizer variables) to fill simultaneously from the optimization results. You can
automatically create a tradeoff with all these tables by using the Create Tables from
Model wizard. Evaluation of models in tradeoff uses the variable set points for any
variables that do not have a tradeoff table.
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Use the two check boxes on the right to incrementally fill tables from the results of
multiple optimizations with smooth interpolation through existing table values. CAGE
can extrapolate the optimization results to pass smoothly through table masks and
locked cells. Use these features when you want to use separate optimizations to fill
different regions of a lookup table.

* Use locked table values in extrapolation— When this check box is selected,
CAGE smoothly fills the table between fixed table values and optimization results.

If your calibration tables have fixed values for some table cells, use locked cells
for the table cells with fixed values. Such cells often appear on the edge of a table.

+ Use existing extrapolation mask in fill— When this check box is selected,
CAGE smoothly fills the table between the values in the mask (from previous table
filling) and the current optimization results.

Select this check box when you want to fill the same table from multiple
optimizations that provide solutions at different operating points. Complex
calibration problems can require different optimizations for different regions of a
table. The toolbox automatically adds filled cells to the table mask.

If you use the wizard to repeatedly fill a table, CAGE adds to any existing
extrapolation mask. As an example, consider filling multiple zones of a table using
results from different optimizations. All zones are cumulatively added to the mask.
If there is overlap with previous fills, cells are overwritten unless they are locked.
Locked cells are never altered by table filling.

(Optional) Specify Filter Rules to select part of the optimization results for table
filling. Specify a filter rule with a logical expression using any input or model
available for use in table filling. You can specify an operating mode (for modal
optimizations) or any valid expression as a filter. For an example, see “Filling Tables
for Operating Modes” on page 7-61.

Click Finish to fill the tables.

A dialog box shows which tables have been successfully filled. Switch to the Tables
view to examine the tables.

Table Filling When Optimization Operating Point Inputs Differ
from Table Inputs

For some optimization problems, you want to optimize at operating points in different
variables to the tables you want to fill, and use response models as normalizer inputs to
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7-14

tables. For example, your problem requires running an optimization at torque and speed
operating points, but you want to fill tables on axes of mainfuel (a response model) and
speed. If all the response model input variables are in your optimization, you can fill
tables with that response model as a normalizer input.

1 Create your tables using the Create Tables from Model wizard, and select a response
model as an input to your tables. For example, using the example project
DieselPointByPoint.cag in the mbctraining folder, create tables from the
MAINFUEL model, and select MAINFUEL as the Y-axis normalizer input, as shown.

'l N
n Create Tables from Model ]
Table Inputs
Select the table inputs and set up the normalizers to use for all the new tables.
|:| Uze model operating points
Y -axis input: SPEED - ¥-axis input: MAINFUEL -
Mormalizer: <Mew:> - Mormalizer: <Mew:> -
Table rows: yi== Table columns: 11
SPEED normalizer: MAINFUEL normalizer:
Input Cutput Input Cutput
16800 0 » 0 0 »
1700 1 20 1 =
1800 2| = 40 P
1500 3 &0 3
2000 4 a0 4
2100 1 100 ]
’ Cancel ] ’ = Back ] ’ Mext = ] Finizh
LS

You must specify the breakpoints for your model input normalizer. Edit breakpoints
by clicking the button after Table columns, and enter a number of points and the
range to space the breakpoints over. If you do not do this, model inputs are spaced
over 0-1, because CAGE cannot determine the range automatically as happens with
variables. After you create your tables with a model input, in the Variable Dictionary
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you can view a new variable named modelname input with the range you specified.
CAGE uses this input variable to match to model names when you fill tables from
optimization results.

When you are ready to fill tables with optimization results, open the Table Filling
from Optimization Results Wizard, select your tables with the response model
normalizer input, e.g., MAINFUEL norm, and click Next.

Table Filling from Optimization Results Wizard EI =] @
Table Selection

Select the CAGE tables that vou wish to fil from the optimization results

Available CAGE tables: CAGE tables to be filled:

Table Table

Q MAINSO|_Table(SPEED_norm,BTC_norm) Q MAINSOI Table_1{SPEED_norm_1,MAINFUEL_norm)
1& FUELPRESS_Table(SPEED_norm, BTC_norm) Q FUELPRESS_Table_1({SPEED_norm_1,MAINFUEL_norm)
Q VWGTPOS_Table(SPEED_norm,BTQ_norm) Q WGTPOS_Table_1(SPEED_norm_1,MAINFUEL_norm)
Q EGRPOS_Table(SPEED_norm,BTC_norm) Q EGRPOS_Table_1(SPEED_norm_1,MAINFUEL_norm)
i@ AFR_Table{SPEED_norm BTC_narm) Q BTC_Table(SPEED_norm_1,MAINFUEL_norm)

1@ MAINFUEL_Table(SPEED_norm,BTQ_norm} i‘ AFR_Table_1(SPEED_norm_1,MAINFUEL_norm)

@ BSFC_Table(SPEED noerm,BTO_norm) EJ

’Q BSNOX_Table(SPEED_norm,BTQ_norm})

Cancel = Back Next = Finish

On the Optimal Result Selection screen, CAGE looks for matches by name among the
variables and response models in the Optimization Results list. Verify the Normalizer
Input column shows the input you want. If CAGE cannot find a match, the Input
column is empty. To select or change an input, select an item in the Optimization
Results list and click the button to select the optimization result for normalizer input.
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Table Filling from Optimization Results Wizard = @ |3
Optimal Result Selection

Choose the optimization results that you want to fill each table with.

Tables values to be filled:

CAGE Table Fill with Tradeoff Optimization Results
1@* MAINSC| Table_1(SPEE... .+ MAINSOI . MAINFUEL_Trade... A MAINSOI
% FUELPRESS Table 1(SP..| X FUELPRESS  |BS MAINFUEL_Trade.. X FUELPRESS
% GTPOS_Table_1(SPEE... | x vGTPOS BB MAINFUEL_Trade... —— | X VGTPOS
% EGRPOS_Table_1(SPEE... | X EGRPOS e MAINFUEL_Trade... u X EGRPOS
1@ BTQ_Table(SPEED_norm... X BTQ B MAINFUEL_Trade... X SPEED
X BTQ
X MaxPressure
3 BsFc
4% BSNOX
Mormalizer inputs: ﬁ AFR
Normalizer Input dg EGRMF
|/ SPEED_norm_1 ' SPEED 43 PEAKPRESS
|/ MAINFUEL _norm 4% MAINFUEL @ 4% VGTSPEED
4% MANFUEL

| Select optimization result for normalizer input

| Cancel || < Back || Next = Finish

4 Click Next and Finish to fill your tables.

Filling Tables Via Data Sets

The alternative method of filling tables with optimization output uses Data Sets. This can
be useful to see the optimization results and the filled table surface on the same plot. In
Data Sets you can also manually edit the results before filling, and compare results with
external data.

1 4
From the optimization Qutput node, click i (Export to Data Set) in the toolbar

(or select Solution > Export to Data Set). The Export to Data Set dialog box
appears. See “Exporting to a Data Set” on page 7-4 for instructions.

2 Go to the Data Sets view (click the Data Sets button in the Data Objects pane) to
see that the table of optimization results is contained in the new data set.

You can now use this data set (or any optimization results) to fill tables, as you can
with any data set.

Select the data set and click E (Fill Table from Data Set) in the toolbar.
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4 Clear the check box to Show table history after fill.

Choose to fill a table with the desired optimization output by selecting them in the
two lists, then click the button Fill Table at the bottom right.

6 Right-click the display and select Surface to see the filled table surface and the
optimization output values.

See also “Fill Tables from Data” for an example showing how to use data sets to fill tables.
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Viewing Your Optimization Results

7-18

In this section...

“Navigating the Optimization Output View” on page 7-18

“Solution Slice: Optimization Results Table” on page 7-20

“Solution Slice: Results Surface and Results Contour Views” on page 7-21
“Objective Slice Graphs” on page 7-26

“Objective Contour Plot” on page 7-27

“Constraint Slice Graphs” on page 7-27

“Constraint Summary Table” on page 7-29

Navigating the Optimization Output View

Use the Optimization Output view toolbar buttons shown in the following figures to
determine what is displayed in the table and the graph views. The first default view is the
Solution Slice table and the Objective Slice Graphs.

Use these toolbar buttons or the View menu to select the following Table Views:
% 1=

* “Solution Slice: Optimization Results Table” on page 7-20 and “Solution Slice: Results
Surface and Results Contour Views” on page 7-21— See also “Choosing Acceptable
Solutions” on page 7-2

» “Pareto Slice Table View” on page 7-51
* “Weighted Objective Pareto Slice” on page 7-67
» “Selected Solution Slice” on page 7-53

Use these toolbar buttons to select the following Views:

CEUEGRE

* “Objective Slice Graphs” on page 7-26
*  “Objective Contour Plot” on page 7-27
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* “Pareto Graphs” on page 7-66
* “Constraint Slice Graphs” on page 7-27
* “Constraint Summary Table” on page 7-29

* Free Variable Values Table — displays the values of the free variables for the currently
selected solution.

* Solution Information Table — displays information about the currently selected
solution, including the Accept status, the algorithm exit flag and exit message, and
other algorithm details such as the number of iterations.

Hover the mouse pointer over the Exit message to see the whole message. This
message can tell you, for example, if an fmincon optimization run terminated because
no feasible start point was found.

You can split and add these views as in the Design, Data and Boundary Editors. Use the
right-click context menu, the View menu, or the buttons in the view title bars to do so.

M |3
These toolbar buttons are also in the Solution menu:
» Select solution — Use this option for choosing your preferred solution for each

operating point. See “Tools for Optimizations with Multiple Solutions” on page 7-51.

» [Edit pareto weights — This option is used for evaluating weighted sums. See
“Weighted Objective Pareto Slice” on page 7-67.

* Export to data set — This option exports the table visible in the current view only to a
new or existing data set. See “Using Optimization Results” on page 7-2.

+ Fill tables using optimal solutions — This option opens the Table Filling From
Optimization Results Wizard. See “Using Optimization Results” on page 7-2.

* The Solution menu also has:
* Create Sum Optimization — see “Create Sum Optimization from Point
Optimization Output” on page 7-4.

* Retain Output (also in the context menu when you right-click an optimization
output node). If you select this option, the output node is retained, so if you rerun
the optimization you get additional output nodes.
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Note For help understanding your results, see “Analyzing Point Optimization Output” on
page 7-36 or “Interpreting Sum Optimization Output” on page 7-72.

Solution Slice: Optimization Results Table

The Solution Slice view (click W ) shows a table with one solution at all operating points
and all runs. The solution is shown in both tabular and graphical forms — see “Solution
Slice: Results Surface and Results Contour Views” on page 7-21 for information on the
graphical views.

The following example shows a Solution Slice table display.

E | Current run: il 11 ﬂ

Optimization Results

“ector display format: IExuanded vertically j
Run | Accept|ICP N L BTQ BTQ_Bou...
10 o ] 40 500 1 214.427|= 0.895(=
11 S| 1.836| 1000 0.1 -28.352(X 0.322|
12 ) ] 3.817] 1000 0.2 1.439x 0.128)
13 [ ] [1] 17825 1000 0.3 32.266|X 0.012]
14 | 24,658 1000 0.4 60.37 -0.031
15 [ ] [1] 36.62) 1000 0.5 86.937|® 0.045)
16 a4 [1] 34841 1000 0.6 112713 0.176
' ] [1] 29.342 1000 0.7 137.876(= 0.294)
18 & 0O 40 1000 0.8  166391@ 0461
19 o [] 40 1000 0.9 192.394 (X 0.609)
20 I 1] 17.581 1000 1 215.270|= 0.761
21 ] [1] 5.58) 1500 0.1 -17.699(= 0.252|
22 O+ O 5.425) 1500 0.2 B.243 5 525e-8
23 | 20.168| 1500 0.3 35.094 -0.085
24 F| 39.369 1500 0.4 62.778 3.712e-8
25 | 42 807 1500 0.5 50.336 2.115e-7
26 ) [1] 38438 1500 0.6 115179 0.011
27 # [1] 34312 1500 0.7 140.302(= 0.181
28 & [1] 26.3: 1500 0.8 164 523 0.324]
24 ] 1 j.19a 1500 na 188 7211% | naf

CAGE automatically selects successful optimization solutions and highlights unsuccessful
solutions for you to investigate. These selections are shown in the icons and check boxes
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next to the Run column in the Optimization Results table. For more information, see
“Choosing Acceptable Solutions” on page 7-2.

The Solution Slice view shows a table of one solution at all operating points and all runs
in the problem. For single-objective optimizations there is only one solution per operating
point, so the Solution Slice is the only useful view.

For optimizations with more than one solution per run (multiobjective and modal), the
solution slice displays controls so you can scroll through the solutions using the arrows or
edit box at the top.

The table shows the selected solution at all operating points. The Optimization Results
pane shows the fixed variable settings, the optimal free variable settings, and the
evaluation of objectives and constraints at the optimal free variable settings.

Click inside the table to make the graph views (objective slice, constraint slice and pareto
front) display the selected operating point.

* The Results Surface or Results Contour view highlights the selected point.

* The “Objective Slice Graphs” on page 7-26 show the objective functions at the
operating point selected in the table, with the solution value in orange.

» Ifyou have constraints you can also choose to display the “Constraint Slice Graphs” on
page 7-27. These show the constraint functions at the selected operating point with
the solution value in orange.

» Ifyou are viewing a multiobjective optimization you can also choose to display the
“Pareto Graphs” on page 7-66, which show the available solutions with the current
selection highlighted in red.

* You can also display the “Constraint Summary Table” on page 7-29, which details the
distance to each constraint edge for the selected operating point in the table. This
table can be useful to see at a glance if a solution met all the constraints. If there are
many constraints it can be time-consuming to use the constraint graphs to verify that
the constraints are met.

Solution Slice: Results Surface and Results Contour Views

* “Contour View of Optimization Results” on page 7-22
* “Surface View of Optimization Results” on page 7-24
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Contour View of Optimization Results

The Results Contour view shows a contour plot of one solution at all operating points
and all runs in the problem. Use the axes popup controls to change what is plotted on
each axis. You can plot the following against each other:

» Fixed variable settings

* Optimal free variable settings

» Evaluation of objectives at the optimal free variable settings

The optimization results are plotted as points in the contour plot and extrapolation
contours (of the z-axis quantity as a function of the x and y-axis quantities) are also
displayed.

Each optimization result is displayed using the Accept icon, as shown in the Optimization

Results table:

B Successful result

@ Failed result
VAN Problem result

T’}? User-altered accept status.

@ Currently selected result (black outline). Select results by clicking an icon in the
plot or a value in the table. Changing the currently selected result in the Results
Contour view also updates the result selected in the table, and updates any plots
displayed in the lower half of the output view.
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Rotation is not permitted in the contour view.

Use the right-click context menu to control these options:
* Results to Display

* All - Show all optimization results for this solution

* Acceptable - Show only the acceptable results for this solution
* Green - Show the results with a positive exit flag

* Orange - Show the results with a zero exit flag

* Red - Show the results with a negative exit flag
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* Set Acceptable — mark an optimization result as acceptable if it is currently marked
as unacceptable.
Any results whose acceptability has been changed are shown as stars in the plot

* Set Unacceptable — mark an optimization result as unacceptable.

+ Extrapolate All — toggles extrapolation from acceptable solutions only (default) to
using all results for extrapolation.

* Contour Options

* Label Contour Lines
* Fill Contours

* Contour Levels — These contour options are identical to those for the objective
contour view.

* Show Axes Grid — Toggle whether the axes grid is displayed or not.
* Hide Contour — Toggle whether the contour is hidden or not.
* Display Contour — Toggle whether the contour is displayed or not.

To toggle between contour and surface view, right-click the view and select Current
View. To display both views use the title bar buttons to split the view.

Surface View of Optimization Results

The Results Surface view shows a 3D plot of one solution at all operating points and all
runs in the problem. Use the axes popup controls to change what is plotted on each axis.
You can plot the following against each other:

» Fixed variable settings

* Optimal free variable settings

+ Evaluation of objectives at the optimal free variable settings

The optimization results are plotted as points, and an extrapolation surface (of the z-axis

quantity as a function of the x and y-axis quantities) is also displayed. The accept icon for
each result is plotted as for the Results Contour.
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Results Surface

Left-click anywhere except an icon to rotate the plot.

The right-click context menu shares these options with the Results Contour view:
Results to Display, Set Acceptable/Unacceptable, and Extrapolate All. Some
additional items for the surface view:

* Surface Options

* Reset Axes Orientation — Reset the axes orientation to the default.
* Show Axes Grid — Toggle whether the axes grid is displayed or not.
* Show Axes Box — Toggle whether the axes box is displayed or not.
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* Hide Surface — Toggle whether the surface is visible or not.

* Show Stems — Use this option to additionally display stems projected from the
data to the surface. These stems can be useful to show the location of results that
are not used in the extrapolation and are hidden by the surface.

Objective Slice Graphs

The objective slice graphs are displayed by default for optimization output views, or you
can select @in the toolbar.

70

Ohjectivet

B3

Ed

............................

35 4

a0 -

. x b
i} 10 20 a0 40 a0 i} 10 20 30 40 50 i} 10 20 30 40 350
s EXH INT

The objective slice graphs show the objective functions at the point selected in the table,
with the solution value in orange. Whether the table is displaying a solution slice or
pareto slice, the cell you select in the table is always displayed in the graphs. The
objective graphs show cross section plots of the objective function against each free
variable in the problem.

The yellow areas show a region outside a constraint tolerance (such as a boundary
constraint exported from the Model Browser part of the Model-Based Calibration Toolbox
product, or any other optimization constraint). All constraint regions in optimization
displays (as in the rest of the toolbox) are shown in yellow.

Use the right-click context menu to toggle constraint display and alter graph size.
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Objective Contour Plot

The Objective Contour Plot (click ) shows the contours of the objective against any pair
of control parameters, at the run selected in the table, with the solution value at the
center of the orange cross-hairs. Yellow areas show a region outside a constraint
tolerance (see the following figure). This view can be useful for exploring objective
functions—a visual way to help avoid local minima.

Objective Contaurs
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Select parameters to plot in the drop-down lists, and if you have more than one objective
you can select from the Objective drop-down list.

Use the right-click context menu to toggle constraint display, contour labels, fill contours,
and colorbar, and control other options such as number and placing of contour levels.

Constraint Slice Graphs

The Constraint Slice graphs (click E) show the constraint functions at the selected
operating point with the solution value in orange. Click inside the tables to select
solutions to display. Yellow areas on the graphs show a region outside a constraint
tolerance, as shown in the following figure.
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Zonstraint Graphs
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This example shows the constraint EXTEMP < 1290° C.

The constraint graphs (the blue lines) show how the Left Value of each output of a
constraint (in this case, the EXTEMP model) depends on the free variables in the
optimization (in this case S, EXH and INT). The Left Value is compared with a plot of the
Right Value output (in this case, 1290° C) on the same axes.

The red horizontal line denotes the Right Value (i.e., the upper bound on EXTEMP) which
in this case is 1290° C). Because this value is an upper bound, the yellow region above
the red line shows where the constraint is infeasible. Yellow is shown above the Right
Value plus the tolerance — on many graphs the distance is too small to see between the
red line and the tolerance line where the yellow begins. By default, this tolerance is taken
from the optimization constraint tolerance. You can control the value used for this
highlighting by selecting View > Edit Constraint Tolerance.

The vertical orange lines show the optimal values of the free variables; the intersection of
these with the blue lines is marked with a blue triangle on the Constraint1 axis—this
intersection is the Left Value (1290° C) at the optimal settings. These are the Left and
Right values in the Constraint Summary table for Constraintl. See “Constraint Summary
Table” on page 7-29.

Note Use the right-click context menu to alter graph size.
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If a constraint is violated at the solution value, the Y axis is highlighted in yellow, as
shown in Constraint 2 in the following example. If constraint values are greater than the
tolerance, the row is highlighted in yellow. By default, this tolerance is taken from the
optimization constraint tolerance. You can control the value used for this highlighting by
selecting View > Edit Constraint Tolerance.
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See also “Range Constraint Output” on page 7-30 for an explanation of range constraint
graphs, and “Constraint Graphs” on page 7-76 for specific sum optimization features,
such as a table gradient constraints.

Constraint Summary Table

The Constraint Summary Table (click I ) view displays the constraint values for the
selected solution in the table. This view can be useful to see at a glance if a solution met
all the constraints. If there are many constraints it can be time-consuming to use the
constraint graphs for verification. If you are using equality constraints or tight table
gradient constraints, the graphs can appear entirely yellow and you can only see whether
a feasible solution has been found by looking at the Constraint Summary Table, shown in
the following figure.
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Constraint Summary

Name v Description Caonstraint */alus Left “alue Right "/alue
E RESIDFRACatMET | FESIDFRACAtMBT(N, L, ICP, ECP) == 25 -3.345 21 652 23
E MBT_Boundary Boundary constraint of MBT(N, L, ICP, ECP) 0.454 0.454 a

Constraint values greater than the tolerance appear in bold, and the row is highlighted in
yellow. By default, this tolerance is taken from the optimization constraint tolerance. You
can control the value used for this highlighting by selecting View > Edit Constraint
Tolerance. These results should be checked as they may show the optimization failed to
find a solution within the constraint, or they may be within tolerance (very close to zero).
Constraint values less than zero are within the constraint.

Constraints are evaluated as inequalities, e.g., the first constraint, RESIDFRACatMBT, as
shown in the preceding figure, is RESIDFRACatMBT = 25%. The Left Value shows the left
side of the inequality at the optimal settings of the free variables (in this case, the output
of the residual fraction model (RESIDFRACatMBT), which is 21.652). The Right Value
shows the right side of the inequality (in this case, the upper bound, 25%). The constraint
value is the difference between the Left and Right values, and the distance to the
constraint edge.

In this case, the second constraint, MBT Boundary, is violated, so the row is yellow, and
the positive Constraint Value is highlighted in bold.

For additional information on working with constraints, see the following topics:

+ “Range Constraint Output” on page 7-30 for an explanation of range constraints in
the summary table.

* “Constraint Summary” on page 7-77 for specific sum optimization features, such as
table gradient constraint outputs.

Range Constraint Output

The range constraint output is best explained using an example problem.
Control parameters or free variables: S, EXH, INT

Fixed variables: N, L

Objective: Maximize TQ(S, EXH, INT, N, L) at the fixed values shown in the following
table.
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Run N L
1 3000 0.5
2 4000 0.6

Constraint: Restrict S between an upper and lower bound shown in the following table.

Run N L Min S Max S
1 3000 0.5 20 30
2 4000 0.6 30 40

When the optimization is run the optimizer returns the following optimal values of S, EXH
and INT, as the following table shows.

Run N L Optimal S Optimal EXH Optimal INT
1 3000 0.5 21.33 8.593 29.839
2 4000 0.6 30 5 7.767

Range constraints implement the following expression:
Lower Bound (LB) < Expression < Upper Bound (UB)

In CAGE, this expression is implemented as two upper-bound constraints, namely:

RangeConLeft(2) UB RangeConRight(2)

RangeConLeft(1) | | —Expression < —-LB| | RangeConRight(1)
| Expression |~ B

A range constraint returns two values at each operating point within a run, as shown in
the following expression:

[RangeConOut(l)} B [—Expression + LB}

RangeConOut(2) Expression —UB

The two values that the range constraint returns are the distance from the lower bound,
RangeConOut(1), and the distance from the upper bound, RangeConOut(2), respectively.

The constraint in the example problem is

LB(N,L) = S = UB(N,L)
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CAGE implements this constraint as
-S - -LB(N,L)
S | | UB(N,L)
and returns the following two values at each operating point within a run to the optimizer

(in this point example there is only one point per run):

RangeConOut(1) | |-S+LB(N,L)
RangeConOut(2)| | S-UB(N,L)

Optimization Output Yalues

“ector dizplay format:  [SEGEWECTRE=Ti =11
ExXH INT I L S_Lower... |S_UpperB... | Ohjectivel | Constraint1
Run | @) Accept iI= iI= iI= iI= iI= 12 12 12 22
1 m |E] ¥ 21.33 §.5897 29832 3000 0.5 20 30 92 467 -1.33
(2) -867
2 m |E ¥ 30 -5 7IET 4000 06 30 40 115.285 1]
(2) -10

The Optimization Results pane shows the fixed variable settings, the optimal free variable
settings, and the evaluation of objectives and constraints at the optimal free variable
settings. In this example, the output of the range constraint at the optimal free variable
settings is shown in the Constraint1 column. For each operating point in a run, two
values are returned from the range constraint.

Looking at the first run:

Optimal S value = 21.33°

To calculate the distances returned from the range constraint:

Distance from lower bound: RangeConOut(1) = -21.33°+20° = -1.33°

Distance from upper bound: RangeConOut(2) = 21.33°-30° = -8.67°

These are the values shown in the Constraint1 column. Remember that negative
constraint values mean that the constraint is feasible. The same values appear in the

Constraint Summary Table for the selected run, in the Constraint Value column, as
shown in the following figure.
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Constraink Summary

Congztraint value Lett Value Right *alue
-1.33 -21.33 -20
-8 67 .33 30

Mame Description
8 constrsintt -5 <= -5_LowerBound
5 2= 5_UpperBound

The Constraint Value gives a measure of the distance to the constraint boundary for
each constraint output. If the Left Value > Right Value and greater than the tolerance for
any of the constraint outputs, the constraint value is bold and the row is highlighted
yellow. By default this tolerance is taken from the optimization constraint tolerance. You
can control the value used for this highlighting by selecting View > Edit Constraint
Tolerance. This means that this constraint distance should be checked to see if the

constraint is feasible at that point.

120- ! ; : !
115 4 .
1104
105 4

100 4

Ohjectivel

93 4

a0 4

85 4
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The Objective Graphs show cross-section plots of the objective function against each free
variable in the problem. The left plot is a plot of the objective function against S, with
EXH and INT at their optimal values, for the second run. The range constraint for the
second operating point (30 = S < 40) can be seen; within the constraint region is white,
and all other regions outside the constraint are yellow.
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Constrairt1(1)

Constraint1 (2)

. 4 . 4 . 4
1} 10 20 30 40 a0 o M0 20 30 40 50 1} 10 20 30 40 S0
s EXH IMT

The constraint graphs for a range constraint shows how the Left Value of each output of a
range constraint depends on the free variables in the optimization. The Left Value is
compared with a plot of the Right Value output on the same axes. This comparison is
illustrated for the example problem at the second run, as shown in the top left graph.

Constraint1(1) is the first Left Value of the range constraint, RangeConLeft(1), for the
first run in the example problem. The top-left graph shows a blue line, which is a plot of
RangeConlLeft(1) against S (the constrained variable) with all other free variables set to
their optimal values. The red horizontal line denotes the Right Value (RangeConRight(1),
i.e., the upper bound on S) which in this case is -20°. Because this value is an upper
bound, the yellow region above the red line shows where the table gradient constraint is
infeasible. The vertical orange line shows the optimal value of S; the intersection of this
line with the blue line is marked with a blue triangle on the Constraint1(1) axis—the
triangle marks the Left Value (-21.3°) at the optimal settings. These are the Left and Right
values in the Constraint Summary table for Constraint1(1).

Constraint1(2) is the second Left Value of the range constraint, RangeConLeft(2), for
the first run in the example problem. The bottom left graph shows a blue line plot of
RangeConLeft(2) against S with all other free variables set to their optimal values. The
horizontal red line denotes the Right Value (RangeConRight(2) ) which in this case is 30°.
Because this value is an upper bound, the yellow region above the red line denotes where
the table gradient constraint is infeasible. The vertical orange line shows the optimal
value of S; the intersection of this with the blue line is marked with a blue triangle on the
Constraint1(2) axis—the triangle marks the Left Value (21.3°) at the optimal settings.
These are the Left and Right values in the Constraint Summary table for Constraint1(2).
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In this example, the range constraint does not depend on EXH or INT, so the constraint
graphs against these variables are blank.
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Analyzing Point Optimization Output
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In this section...

“Process for Analyzing Optimization Results” on page 7-36
“Detecting Local Optima” on page 7-38
“Investigating Early Termination of Optimization” on page 7-42

“Handling Flat Optima” on page 7-47

Process for Analyzing Optimization Results

This topic describes a process for analyzing the results from single-objective
optimizations (e.g., maximizing torque vs. spark, ICP ECP at an engine operating point,
using fmincon, ga and patternsearch algorithms).

For each run of an optimization, the aim is to find the optimal solution. The Optimization
Output View provides graphical tools to help you determine whether an optimal solution
has been found for a given run. This view provides a table with icons that indicate the
status of each optimization run.

Optimization Results Table Icons

Icon Description

Green square Accept icon Indicates success (algorithm exit flag > 0 ).
|

Orange triangle Accept icon Indicates the optimization terminated early
I (exit flag = 0 ). This situation typically

occurs when the optimizer has reached
some form of time limit. Examples of this
include exceeding a number of iterations or
function evaluation limit. In such cases, the
optimization was in progress but was forced
to terminate before the optimal solution

had been found.
Red circle Accept icon Indicates failure (an exit flag < 0 ).
] Typically this occurs due to the problem

being over constrained for this run.




Analyzing Point Optimization Output

The process for analyzing point optimization results comprises the following tasks:

“Analyzing Output for All Runs” on page 7-37
“Adjusting Settings To Improve Results” on page 7-37

Analyzing Output for All Runs

1
2

Switch to the Optimization Output view for the optimization.
Analyze all runs with green square Accept icons (@Ll). For each run:

a Inspect the Objective Graphs.

b  Inspect Objective Contour plots for as many pairs of free variables as possible.
You can configure the optimization output view to display multiple contour plots
simultaneously.

Has the solution found a local optimum? Many optimization algorithms are designed
to locate local optima (e.g., fmincon in CAGE). Check each successful run to ensure
that the optimizer has found the best solution possible. See “Detecting Local Optima”
on page 7-38 for more information and examples.

Does the optimization appear to have terminated early? In some cases an
optimization appears to return sub-optimal results even though the optimizer has
returned a positive exit flag. Investigate such cases. See “Investigating Early
Termination of Optimization” on page 7-42.

Repeat steps 2a and 2b to analyze all runs with orange triangle Accept icons
(&) that indicate the optimization terminated early. See “Investigating Early
Termination of Optimization” on page 7-42 for more information and examples.

Repeat steps 2a and 2b to analyze all runs with red circle Accept icons ()
that indicate failures. These runs have typically failed to meet constraints. Inspect the
plots and determine if it is acceptable to relax any of the constraints.

Adjusting Settings To Improve Results

After you investigate your results to identify problems, use these suggestions to try to
improve your optimization results:

1

If you detect local optima, try running the optimization again to locate the best
optimum.
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Edit the initial condition manually for this optimization operating point and rerun.

For point optimizations that use the fmincon algorithm, set the Number of start
points to be greater than 1 and rerun. In this case, CAGE performs the
optimization more than once for each run. To save time, you might want to only
repeat the offending runs in this way.

Use an alternative algorithm on the runs that have found a local optimum. For
example, you could try the ga or patternsearch algorithms in CAGE (if you
tried the fmincon algorithm first).

2 If the optimization terminates early:

In cases where the optimizer runs out of iterations/function evaluations/time and
the solution returned is feasible, determine whether the solution is acceptable to
you.

* To accept the solution, select the Accept check box on the Optimization Results
table.

* Ifyou reject the solution, rerun the optimization with modified parameter
settings. In this case, if fmincon or patternsearch is being used, it is
advisable to start the optimizer from the solution that has just been found.

In cases where the optimizer runs out of iterations/function evaluations/time and
the solution returned is infeasible, you can try rerunning the optimization from
different initial conditions (for fmincon or patternsearch) or different
parameter settings (all algorithms). If this approach does not resolve the problem,
determine if any constraint has been violated. Investigate violated constraints, to
determine whether they can be relaxed. If they can, rerun the optimization with
the relaxed constraints; if not, leave the check box unselected to indicate the
solution is unacceptable.

3  See also “Handling Flat Optima” on page 7-47.

Detecting Local Optima

The following figure shows views for an optimization which has found the optimal

solution. The objective is to maximize Torque (Objectivel) against spark angle (S),
Exhaust valve closing (ECP) and Intake valve opening (ICP).
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When you analyze the optimization results, look for results that have located the best
optimum against the free variables.

In this case, an individual plot can only show it is highly likely rather than definitely the
optimal value because there are more than two free variables. For problems with more
than two free variables, the Objective Graphs and Contours views cannot guarantee that
an optimal solution has been found because they provide projections of the model.

For further confirmation, you should inspect the Objective Contour view for as many pairs
of free variables as you have time to analyze.

The following example shows the algorithm has found a local maximum (marked by the
orange cross). You can see the global maximum for this optimization in the lower-right
corner of the contour plot.

A constraint, such as a table gradient constraint, could cause a local maximum result.
This result could be desirable, however, because it may be preferable for table
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smoothness to find a local maximum with a slight loss of torque compared to the global
maximum (in this case, about 1.3 NM of torque (1%) which is within model accuracy).
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ICP

To inspect contour plots for many pairs of free variables, you can configure the
optimization output view to display multiple contour plots simultaneously. Simultaneous
display can help locate those runs that have converged to a local optimum.

The following figure simultaneously shows contour plots for all pairs of free variables for
the gasoline case study.
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Investigating Early Termination of Optimization

Inspect the Objective Graphs and Contour Views to check for optimizations that have
terminated early. Early termination typically occurs with runs that have warning orange
triangle Accept icons, but can also occur when the optimizer has returned a successful
green square Accept icon.

The following figure shows an optimization run with a warning orange triangle Accept
icon that has been forced to terminate because it exceeded the iterations limit.

W ; ; ; : : : Objectivel
AN o

0y

Objecdivel

In this case, the optimizer has almost found the optimal solution for this run. If this
optimizer has taken a long time to run, then as this solution is almost optimal it is
probably worth marking as acceptable (select the Accept box in the Optimization Results
table for this run).

The following figure shows another example where an optimization terminated early
because it exceeded the iterations limit.
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In this case, the problem appears to be over constrained because the plots are entirely
shaded yellow. You can check the constraint summary table or the output table to identify
if constraints are met. Also inspect the constraint summary and constraint graphs.

Note Solutions on the constraint boundary and table gradient constraints often cause all
objective and contour plots to be yellow (see “Table Gradient Constraint Output” on page
7-78).

The constraint graphs for this case are shown in the following figure.
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These constraint views confirm that Constraint2 is violated for this run. Therefore, this
solution is probably best left as unacceptable. In cases like this, if it is not already marked
as unacceptable, clear the Accept box in the Optimization Results table for this run.

The following figure shows an optimization that appears to have terminated early despite
returning a positive exit flag. You can see that the optimizer has not located the
maximum. You should investigate cases like this.



Analyzing Point Optimization Output

166 -

) S,

164 }----

162 }----

T

Objective

([T - I .
] 0 R T B OV Y B —
156 e e e e e
-2 0 2 -2 0 2
ECF ICP

There are many reasons why an optimization appears to terminate early. Two common
causes and possible resolutions are discussed in this section.

Poor algorithm parameter settings

fmincon may not return a local optimum if the following parameter values are too high:

* Variable tolerance

» Function tolerance

* Constraint tolerance

In this case try reducing the values of these parameters to improve performance.
However, do not reduce these parameter values too low (less than ~1019) to avoid

internal issues with fmincon. Models that have nonphysical nonlinearity can also cause
failure.
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Some nongradient-based algorithms may not return an optimum solution. An example of
this is the genetic algorithm (ga) optimization in CAGE. A poor choice of parameters for
such algorithms can lead to early termination of the optimization. For example, setting
the Crossover Fraction parameter of the ga algorithm to 1 can lead to a situation where
the algorithm prematurely converges. In this case, try rerunning the optimization at
alternative parameter settings. For best results, rerun the algorithm with a Crossover
Fraction lower than 1 (the default is 0.8).

Using fmincon with noisy models

Optimizations can terminate early because the models are noisy and you used a gradient
based algorithm (fmincon) to solve the optimization problem.

If the contour plots or any results are suspicious you should always investigate model
trends to check if they are sensible and not overfitting. Examine models in the CAGE
Surface Viewer or the Model Browser response surface view. You may need to remodel.

To check whether your model is noisy, zoom in on a line plot of the model in the CAGE
Surface viewer. Following is a plot of Objectivel against x around the value of x returned
by the optimizer.
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You can see that the model is noisy and the optimizer has (correctly) returned a local
maximum of the model. However, this result is a maximum of the noise component in the
model and not the physical component. If the noise is not behavior of the physical system,
then you should remodel the noisy models in the Model Browser. The CAGE Import tool
can be used to replace the noisy models with the results of the remodeling and the
optimization can be rerun.

Handling Flat Optima
Functions that are flat in the vicinity of their optima can be difficult to optimize. The

following figure shows an example of such a function, § (x,y) = (" +y* + xy)’* , and its
surface plot.
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This function has a global minimum at (0, 0) and is very flat in the vicinity of the optimal
solution.

Using the fmincon algorithm in CAGE to find the minimum of this function (from initial
conditions of (*,¥)=[0.5,0.5] ) produces the result shown in the following figure. The

optimizer finds a solution at (x,y) =[=0.113,=0.113]  which is not optimal. In the

following plots, you can clearly see that the optimizer has not located the minimum at (0,
0).
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adjust the optimizer to find the minimum, you can take one of several approaches:

Change the initial conditions.

For a gradient-based algorithm (fmincon in CAGE), changing the initial conditions
can help the optimizer locate a minimum where the objective function is flat in the
vicinity of the minimum. In the example shown in the previous figure, changing the
initial conditions to (x,y) = (1,1) leads to fmincon finding the minimum at (0, 0).

Rescale the objective function.

Rescale the objective function with an operation that does not change the location of
any optimal solutions, e.g., try taking a square root, fourth root or log, or multiplying
by a positive scalar. Check that the position of the optimum is not changed. When an
objective function is flat in the vicinity of an optimum, rescaling the objective function
can help gradient-based optimization algorithms such as fmincon in CAGE. In the
example shown in the previous figure, when fmincon in CAGE is used to minimize

12
107 g(x, y) , the minimum at (0, 0) is located.
Use a non-gradient based algorithm.
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Try either the pattern search or genetic algorithm options. As these algorithms do not
use gradient information, they can perform better when used on optimization
problems with flat minima. In the example shown in the previous figure, the pattern
search algorithm in CAGE located the minimum using the default settings.

Run the optimization from several initial condition values.

If you are using fmincon then another possible workaround is to set the Number of
Start Points parameter to be greater than 1. This setting runs fmincon the specified
number of times from different start conditions. Use this option only for the affected
runs as it can be time consuming.

Change tolerances.

For a gradient-based algorithm (fmincon in CAGE), changing the variable or function
tolerances can help the optimizer locate a minimum where the objective function is
flat in the vicinity of the minimum. Reducing the variable and function tolerances
may improve the convergence to the optimum value in this case.
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Tools for Optimizations with Multiple Solutions

In this section...

“Analyzing Modal, MultiStart, and Multiobjective Optimizations” on page 7-51
“Pareto Slice Table View” on page 7-51
“Selected Solution Slice” on page 7-53

“Exporting Selected Solutions” on page 7-55

Analyzing Modal, MultiStart, and Multiobjective Optimizations

CAGE has additional tools for analyzing optimizations with more than one solution for
each operating point. Optimizations with multiple solutions are multiobjective
optimizations, modal optimizations and multistart optimizations. Use the optimization
output node tools to view all solutions and select solutions. The tools for viewing and
selecting solutions are described in the following sections:

» “Pareto Slice Table View” on page 7-51 shows a table of all solutions at one run.

» “Selected Solution Slice” on page 7-53 is for collecting and exporting only the
solutions you have decided are optimal at each run.

You can export selected solutions or all solutions to a data set, and you can restrict
export to acceptable solutions only. See “Exporting Selected Solutions” on page 7-55.

* Check the messages and exit flags for each solution, shown in the Optimization
Results table and the Solution Information pane.

* For advice on multiobjective optimizations, see “Analyzing Multiobjective Optimization
Results” on page 7-66 .

» For advice on modal optimizations, see “Analyzing Modal Optimization Results” on
page 7-57.

» For advice on multistart optimizations, see “Analyzing MultiStart Optimization
Results” on page 7-63.
Pareto Slice Table View

The Pareto Slice table view (click ‘1") is for optimizations where there is more than one
solution at each run (multiobjective, multistart or modal). The Pareto Slice shows a table
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of all solutions at one run; you can scroll through the runs using the arrows or edit box at
the top.

To collect best solutions across different runs, you need to select a solution for each run,
and your selections are stored in the Selected Solution slice.

To select a solution for each run:

1 Decide which solution you want to use for the currently selected run. Use these tools
to help you:

* Use the Pareto Slice table and Results contour and surface views along with the
“Objective Slice Graphs” on page 7-26 to select the best solution for the run. If
you have constraints you can also use the “Constraint Slice Graphs” on page 7-27
and “Constraint Summary Table” on page 7-29 to help you decide which solution
to choose for each run.

* For multiobjective optimizations, display the “Pareto Graphs” on page 7-66

(click in the toolbar) which shows the available solutions with the current
selection highlighted in red.

* For modal optimizations, see “Analyzing Modal Optimization Results” on page 7-
57.

2 When you have decided which solution you want to use for the currently selected run,
you can select it as best by editing the Selected solution control above the table, or

by clicking Select Solution ( ﬂ ) in the toolbar. You can also select best solutions
with the toolbar in the Solution Slice view, see “Solution Slice: Optimization Results
Table” on page 7-20 .

3 Scroll through the runs and select a best solution for each. These selections are
collected in the Selected Solutions Slice, where you can view them, use them to fill
tables, or export to a data set. You can also import them to an optimization. See
“Selected Solution Slice” on page 7-53.

Before you run an NBI optimization you can specify how many solutions you want the
optimization to find, using the Set Up and Run Optimization toolbar button.
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As in the other table views, you can use the Accept check boxes to choose a selection of
rows within the table. In this table view, you can only use this to select solutions within a
single run. Each different solution has a check box and colored icon for “Acceptable”
status. You can override these selections using the check boxes if you want to choose
solutions within a run, for use when exporting to a data set, importing to other
optimizations, or for future reference. See “Choosing Acceptable Solutions” on page 7-2.

Selected Solution Slice

In a multiobjective, modal or multistart optimization, there is more than one possible
optimal solution at each run. You can use the Selected Solution view to collect, view,
and export those solutions you have decided are optimal at each run.

Click Selected Solution in the toolbar @ to view the Selected Solution view.
CAGE selects solutions depending on the type of optimization as follows:

* Modal optimizations and MultiStart optimizations select a solution for each run
automatically that you can view and change manually if you want.

+ For multiobjective optimizations you must choose solutions manually to decide the
acceptable tradeoff between the competing objectives.

Note You can use the Selected Solution slice, or alternatively you can choose to export all
solutions to a data set. See “Exporting Selected Solutions” on page 7-55
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You can use the plots and table views to help you select best solutions for each run. These
solutions are saved in the Selected Solution view. You can then export your chosen
optimization output for each point from the Selected Solution view to a data set, or use
your optimization output to fill tables or import to another optimization.

1 Ifyou want you can initialize the Selected Solutions view with a particular solution
for all runs. Select Solution > Selected Solution > Initialize.

The Create Selected Solution dialog box appears.

<) Initialize Selected Sa -10] =l
Default salution numker: I 1 i‘

QK I Cancel |

The default 1 initializes the first solution for each run as the selected solution. You
can edit the solution number here if you want. For example, if you select 4, solution
number 4 is initialized as the best solution for every run. Click OK.

2 Use the table views and the plots in the graphs (Objective Slice, Pareto Front, and
Constraint Slice graphs) to help you select the best solution for each run. Use the
procedure described in “Pareto Slice Table View” on page 7-51 to select a solution for
each run. Repeat until you have selected solutions for all runs.

3 You can also change selected solution in the Selected Solution slice view, by editing
the Selected solution control above the table. You should use the Pareto Slice table
and other views to investigate all solutions.

These solutions are saved in the Selected Solutions view. This view collects all your
selected solutions together in one place. For example, you might want to select solution 7
for the first run, and solution 6 for the second, and so on. You can then use your chosen
optimization output for each point to fill tables (see “Filling Tables from Optimization

T
Results” on page 7-9), or choose the Export to Data Set = toolbar and Solution menu
option (see “Exporting to a Data Set” on page 7-4), or use these solutions as starting
points in another optimization (see “Import from Output” on page 6-45).

An example of the Selected Solutions view is shown. It looks similar to the Solution
Slice view, except the Selected solution controls at the top are enabled instead of the
Current solution. You can change the selected solution in this view. The solution chosen
as best (in this or other views) for the currently selected run is displayed in both current
and selected solution edit boxes.



Tools for Optimizations with Multiple Solutions

As in the other table views you can use the Accept check boxes to choose a selection of
rows within the table. See “Choosing Acceptable Solutions” on page 7-2.

E | Current run: 4| 1 ﬂ Current solution: <| 1 ﬂ Selected solution: <| 1 ﬂ

Optimization Results

“ector dizplay format: IExnanded verticalty j
Run | Accept 5 ICP ECP N L BTQ BTQ_Bo...
10 [ [] 50 23.877] 224258 5504174 0.052 24.55] 0.786}
11 ] ] 33.746 23.014] 16.39 879.31 0.178 45 638 6.2566-3
12 | 35.653 17.897) 22411 1393.184 0.178 50.103| -0.202
13 F| 41.283 19.8] 27.831 1807.058 0.178 52 258 -0.276
14 | 41.938 23.188| 25.747| 2420531 0.178 52.832 -0.335
15 d 38.544 24748 18.762| 2834.805 0.178 52 86| -0.465
16 F| 34.541 22.01 13.787| 3448.679 0.178 51.998) -0.345
17 P 42.135 38.387| 2.765| 3962552 0.178 52 058 1.967e-8
18 F| 45,259 35.71 §.226| 4475426 0.178 51.398| 1.053e-9
19 ) ] 50 23.877| 22428 4550.3 0.178 49 357 0.029
20 [ [1] 50 23.877] 224258 5504174 0.178 49.252 0.256
21 - ] 24.456 23.877| 22428 879.31 0.255 52 857 0.138
22 | 25.183 21.542] 32679 1393.184 0.265 96.452 -0.089

Exporting Selected Solutions

For optimizations with multiple solutions (multiobjective, modal and multistart), you can

choose to export only selected solutions or all solutions to a data set. You can restrict

export to acceptable solutions only (specified by the Accept check boxes). See “Choosing
Acceptable Solutions” on page 7-2. You can use the Selected Solution slice to collect only
the best solution for each run.

1 Select Solution > Export to Data Set or use the toolbar button. The Export to Data
Set dialog box appears. For optimizations with multiple solutions this dialog provides
an additional control called Solutions to Export.

2 Use the Solutions to Export drop-down list to select either:

Selected Solutions — this exports your collected solutions in the Selected

Solution Slice.

A1l Solutions — this exports every solution from every run.

You can choose whether to export acceptable solutions only with the check box
Use acceptable solutions only.

7-35



7 Optimization Analysis

For more information on exporting optimization results, see “Exporting to a Data Set” on
page 7-4.

See Also

Related Examples

. “Analyzing Modal Optimization Results” on page 7-57
. “Analyzing MultiStart Optimization Results” on page 7-63
. “Analyzing Multiobjective Optimization Results” on page 7-66
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Analyzing Modal Optimization Results

In this section...

“Viewing and Selecting Modal Optimization Results” on page 7-57
“Creating Sum Optimizations from Modal Optimizations” on page 7-60
“Filling Tables for Operating Modes” on page 7-61

Viewing and Selecting Modal Optimization Results

After you run your modal optimization, use the optimization output node to verify the
results. For general advice see “Analyzing Point Optimization Output” on page 7-36. The
following process describes features specific to the results of modal optimizations.

Modal optimization results have more than one solution at each operating point. The
modal optimization algorithm tries to automatically select the best mode for each
operating point.

Use the optimization output node tools to view all solutions, see which solution is
selected, and change the selections manually if you want. These features are also useful
for selecting solutions for multiple objective optimizations (using the NBI algorithm) and
multiple start points (using the MultiStart algorithm) that also have more than one
solution per point.

1  Use the Solution Slice view to see all the results for a single mode at a time. In the
Solution Slice table view, use the Current solution controls to change which mode
results to display.

The default view in the GasolineComposite. cag example shows all the solutions
for CylinderMode 1, the 4 cylinder mode. Set the Current solution to 2 to view
solutions for CylinderMode 2(8 cylinder mode).

In the example shown following the table and contour plot shows the results for
CylinderMode 2(8 cylinder mode) at every operating point.
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@ | Current run: il SZﬂ Current solution: il 2ﬂ Selected solution: il Eﬂ [ ™ Accept
Optimization Resutts
“ector display format: IExpanded vertically j
Run i
| Accept CylinderMode s ICP ;I ® N o
21 @ 0O 2 24738 10.31
50 | 2 35.019 12919 o “H- O
23 F] 2 44511 15724
24 | 2 32,885 14645 o - =
25 [ 2 39.195 16,986 J o o o
26 | 2 35,389 0.871
27 @ O 2 27167 23877
28 @ O 2 32,208 23877
29 @ 0O 2 35.335 23.877
30 @& 0O 2 37.905 14987
31 ® 0O 2 28.52 23.031)
32 | Pl 17.557|
33 ] 2 41,483 19.285
34 | 2 42018 22.743
35 | 2 39.004 24 98
386 | 7 2 35.407 22-02_'|;| K-axiz [N T Yoaxis: L ¢ Taxiz | ™
i e

2 To see which mode is selected as best for all operating points in one view, switch to
the Selected Solution view. Select View > Selected Solution or use the toolbar
button. The table and contour plot display the selected best solution for all operating
points.
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e +3E M HELHRRERB | @D

@ | Current run: il SZﬂ Current solution: 1| 2 ﬂ Selected solution: <| Zj [] ¥ Accept

Optimization Results

“ectar display format: IExpanded vertically j
Run [@| Accept| CylinderMode s ICP
32 [ o 35716 17.557
23 || 2 41.483 19.285
34 | 1 16.054 20.289
a5 P 1 17.82 19,831
6 | 1 20.85 1,859
37 [ 1 23,645 45573
38 | 1 2567 47017
29 | 1 27168 45338
40 8 0O 1 32,755 23877
41 ® O 1 28.12 23,877
42 [d 2 34.481 21.445
43 | 2 =0 23,285
44 | 2 35.293 27.219)
a5 A 2 40.06 35.853
45 | 2 33.975 44344
a2 E : 2 S 44'329’ vl Heaxiz M7 Yegxis: LT Logxiz |07

N

3 In the Selected Solution view, review the Results Contour plot to see which mode has
been selected across all operating points. Use this view to verify the distribution of
mode selection.

4 Ifyou have extra objectives, you can also view them in the tables and plots. Use the
other objectives to explore the results. For example you may want to manually
change the selected mode based on an extra objective value. If you have extra
objectives it can be useful to view plots of the other objective values at your selected
solutions. To display another plot simultaneously, right-click the Results Contour title
bar and select Split View.

5 Click to select a point in the table or Results Contour, and you can use the Selected
solution controls (or the toolbar button) to alter which mode is selected at that
point. You may want to change selected mode if another mode is also feasible at that
point. For example, you can change the mode if you want to make the table more
smooth.
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In the GasolineComposite.cag example, some operating points can be run in
either 4- or 8-cylinder mode. When both modes are feasible, the modal optimization
algorithm selects the mode that results in the best torque.

Use the Pareto Slice view to see all the solutions for a particular operating point. You
can inspect the objective value (and any extra objective values) for each solution. If
needed, you can manually change the selected mode to meet other criteria, such as
the mode in adjacent operating points, or the value of an extra objective. Change the
selected solution using the Selected solution control or by selecting the solution
and using the toolbar.

If you change the selected mode for a point, return to the Selected Solution view to
observe the selected solutions for all operating points.

Check the messages and exit flags for each solution, shown in the Optimization
Results table (hover over the Accept icons) and the Solution Information pane. Modal
optimizations provide exit messages from fmincon and prefix the message with the
mode number for the solution. See the fmincon function for exit messages. There is
also an exit message specific to modal optimization: -7 which reports that the mode
is not valid (NaN) for a particular operating point.

Creating Sum Optimizations from Modal Optimizations

When you are satisfied with all selected solutions for your modal optimization you can
make a sum optimization over all operating points. The mode must be fixed in the sum
optimization to avoid optimizing a very large number of combinations of operating modes.
For example, the GasolineComposite.cag example optimization has 2x57=114
different combinations of modes.

To create a sum optimization from your point modal optimization:

1

From your point optimization output node, select Solution > Create Sum
Optimization.

The toolbox automatically creates a sum optimization for you with your selected best
mode for each operating point. The create sum optimization function converts the
modal optimization to a standard single objective optimization (fmincon algorithm)
and changes the Mode Variable to a fixed variable.

You can then add table gradient constraints to ensure smooth control and engine
response.

See also “Create Sum Optimization from Point Optimization Output” on page 7-4.
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Filling Tables for Operating Modes

Composite models can require the ability to select part of the optimization results to fill a
particular table. For example, you need to discard solutions for other modes when filling a
table with an input that is not used for all modes.

You can apply filter rules to select part of the optimization results for table filling. The
filter rules are important for modal optimizations. You can specify an operating mode or
any valid expression as a filter when using the Table Filling wizard.

» Use filter rules when your goal is to fill a different table for each mode.

* Specify a filter rule with a logical expression using any input or model available for
use in table filling.

* The Table Filling from Optimization Results wizard automatically sets up filter rules
for you if some inputs are not used for all modes in your composite model.

From any type of optimization you can use the Table Filling From Optimization Results
Wizard. The example project CompositeWith2Tables. cag shows the use of filter rules
in the wizard to specify results from a single mode to fill a specified table.

In this example project:

* There is a single table for each control variable which stores the value for the best
mode. The strategy has separate tables for each mode.

Composite calibration problems of this kind often involve separate optimizations (point
and sum) with different free variables and constraints for each mode.

* There is a separate point optimization for each mode. The results from each mode are
exported to the same data set (using the append option). The sum optimization uses
the point results data set.

* To finish off the calibration, the sum optimization provides results for a multimodal
drive cycle, using the selected mode at each point.
To see the example:
1 Load the example project CompositeWith2Tables.cag found in matlab\toolbox
\mbc\mbctraining.
View completed examples of composite models, optimizations and filled tables.

To see the table filling filter rules, expand the Sum_BTQ Optimization node to view
the optimization output node.
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4  Select Solution > Fill Tables or use the toolbar button.

The Table Filling From Optimization Results Wizard appears.
Click Next to review the saved settings in the wizard.

On the final screen of the wizard, you can view filter rules. These rules specify which
mode to use to fill each table.

) Table Filling from Optimization Results Wizard 10 =l

Fill Algorithm
Set up table filling algorithm.

Fill Method:  [Extrapolate Fill -1 iy

¥ Use acceptable =olutions only ¥ Use locked table values in extrapolation
¥ Update tradeoffz [ Use existing extrapolation mask in fil
Fiter rules for tables:

Table Qutput Column Filter Rule Fitter Rule Inputz
e 5_acy xs CylinderMode== «| [xs

i& ICP_dcyl X ICP CylinderMode== X ICP

LQ ECP_4cyl X ECP CylinderMode== X ECP

i& CylinderMode... | X CylinderMode | CylinderMode== X N

jc? BTQ_4cyl E: BTQ CylinderMode== XL

i& EXTEMP_4cyl E: EXTEMP CylinderMode== X CylinderMode
LQ RESIDFRAC_4... E: RESIDFRAC CylinderMode== E-* BTQ

i& 5_8eyl X 5 CylinderMode==2 5.'7 EXTEMP
j<‘.?IE:P_EScyI X ICP CylinderMode== E-* RESIDFRAC
i& ECP_8cyl X ECP CylinderMode==2 :I

Kl | +]

Cancel | < Back | Finizh
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Analyzing MultiStart Optimization Results

In this section...

“Viewing and Selecting MultiStart Results” on page 7-63

“Creating Sum Optimizations from MultiStart Optimizations” on page 7-65

Viewing and Selecting MultiStart Results

After you run your optimization, use the optimization output node to verify the results.
For general advice, see “Analyzing Point Optimization Output” on page 7-36. The
following process describes features specific to the results of MultiStart optimizations.

Optimizations using the MultiStart algorithm have multiple start points and try to find
multiple solutions per point. CAGE selects the best solution based on the objective value.
You can investigate all solutions and change selected solutions manually if you want, for
example to make smoother tables.

To examine MultiStart optimization results:

1
Click the Selected Solution button @ in the toolbar to see the optimal results
selected by CAGE in the Selected Solution table.

2 View your results in the Results Contour plot. Look for table areas that are not
smooth enough.

You can also view the Results Surface at the same time by right-clicking the title bar
and selecting Split View Horizontally.

Focus on runs that have accepted solutions (green squares) and then solutions that
ran out of time (orange triangles). Red circles indicate failures to meet constraints
with any of the start points (e.g., outside boundary model), so further analysis is less
useful compared to the accepted solutions. For example, investigate green squares
where the table is not very smooth.

3 Click the plots or table to select a point to investigate.

This example shows a selected point where the value of spark is too different from
the neighboring points, which makes the table not smooth enough.
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Results Contour BE Results Surface

0_255...&..

3000 4000 =000

M
K-axis: IN 'I ¥ -axis: IL 'I Z-axis: IS 'I

4

1000 2000

Click *+ in the toolbar to switch to the Pareto Slice and view all solutions at the
selected point.

This example shows MultiStart results as follows:

* CAGE sorts MultiStart results with the best solution at the top (solution 1).

* The number of solutions is not necessarily the same as the Number of start
points. The example has five feasible solutions, and an additional row displaying
NaNs. This means that CAGE found six different feasible solutions for at least one
other run in this optimization. Ignore any rows with NaNs. CAGE shows the same
maximum number of solution rows for every run. If there are rows beyond the
feasible solutions for the current run, then CAGE fills the rows with NaNs.

You can set the tolerance between different solutions with the Tolerance for
separate solutions MultiStart setting.
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Here, CAGE has selected the best solution with the optimal value of torque, BTQ. In
this case you can instead select another solution to make a smoother table in spark
(S) with only a small tradeoff in the torque value.

A——

Current run: il Zﬂﬂ Current solution: il 1ﬂ Selected solution: il 1ﬂ

Optimization Resultz

Vector dizplay format: IExuanded vertically j

Solution | @] Accept 5 ICP ECP N L BTQ BTQ_Bo... | RESIDFR...
1 | 1500 0.3 -0.085 9.113e7
2 | 24.343 3.507 15.167 1500 0.3 34793 -2.555=-9 -7. 745
3 | 30.984 26.725) 7.708 1500 0.3 34488 3.528e-8 -4.377|
4 | 31.073 25.782) 7734 1500 0.3 34,488 3.427e-8 -4,345)
5 | 1.608e-20 22.353 27613 1500 0.3 28.788 -0.024) 254110
] [ ] [1] MaN NaN MaN 1500 0.3 NaM -0.145|X NaM
5 Change the selected solution using the Selected solution control, or click the

solution in the table and click Select Solution ﬂ in the toolbar.
Return to the Selected Solution slice to view the difference in your table.
Repeat the process to investigate your other results.

Creating Sum Optimizations from MultiStart Optimizations

When you are satisfied with all selected solutions for your optimization, you can make a
sum optimization over all operating points. To create a sum optimization from your point
MultiStart optimization:

1

2

From your point optimization output node, select Solution > Create Sum
Optimization.

The toolbox creates a sum optimization with your selected solution values defining
the operating points. The create sum optimization function converts the MultiStart
optimization to a standard single objective sum optimization (fmincon algorithm)
and uses your accepted selected solutions for variable values.

Add table gradient constraints to ensure smooth control and engine response.

See also “Create Sum Optimization from Point Optimization Output” on page 7-4.
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Analyzing Multiobjective Optimization Results

In this section...

“Pareto Graphs” on page 7-66
“Weighted Objective Pareto Slice” on page 7-67
“Multiobjective Output Messages” on page 7-70

Pareto Graphs

The Pareto Front Graphs (click ) are for multiobjective optimization where there is
more than one solution at each run. The Pareto graphs show the available solutions for
the selected run:

» The current selection is highlighted with a gray circle outline.

» Pareto solutions are green squares.

* Dominated solutions are orange triangles.

* Unsuccessful solutions are red circles (constraints may not be met or the algorithm
ran out of time).

» The selected solution is a star shape.
Click in the tables or graphs to view solutions. To change the selected solution, edit the

number in the Selected solution box. The selected solution is displayed in all other
graphs (objective and constraint).

Note:
* The Pareto Graphs show all the solutions for the selected run. These graphs help you

select best solutions for each run.

* It can be useful to display the Solution Information view at the same time to view
information about a selected solution. You might want to select a dominated solution
(orange triangle) over a pareto solution (green square) to trade off desired properties.

* The “Weighted Objective Pareto Slice” on page 7-67 shows a weighted sum of the
objective values over all runs for each solution.

Use the Pareto graphs, shown in the following figure, in combination with the table views
(Solution Slice and Pareto Slice) and the other plots in the graphs (Objective Slice and
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Constraint Slice graphs) to help you select best solutions for each run. You can collect
these solutions together in the “Selected Solution Slice” on page 7-53.

Pareto Graphs EIET B

BSFC
[m]
B

NOXFLOW

Before you run an NBI multiobjective optimization you can specify how many solutions
you want the optimization to find by using the Optimization Parameters dialog box. The
NBI default number of solutions is 10 for two objectives. For more objectives, see “NBI
Options” on page 6-63. Click Set Up and Run Optimization to change the number of
solutions before running again. In the Optimization Parameters dialog box, change how
many tradeoff solutions you want the optimization to find per run. See “NBI Optimization
Parameters” on page 6-63.

For gamultiobj, if CAGE does not find a feasible solution, you might try increasing the
default population size. See “gamultiobj Optimization Parameters” on page 6-68. To
examine example gamultiobj optimization results, see “Examine the Multiobjective
Optimization” in the Multi-Injection Diesel Calibration case study.

Weighted Objective Pareto Slice

The Weighted Objective Pareto Slice view (click F ) shows a weighted sum Pareto
solution. This table shows a weighted sum of the objective values over all runs for each
solution. For a single objective optimization there is a single cell, which is the sum of the
objective across all runs.
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In the following multiobjective example, the value in the Objectivel column in the first
row shows the sum of the solution 1 values of the first objective across all runs. The
second row shows the sum of solution 2 Objectivel values across all runs, and so on for
all ten solutions in this case. This information can be useful, for example, for evaluating
total emissions across a drive cycle. The default weights are unity (1) for each run.

Current run:  <none: Current solution: 3

Y il 1ﬂ ‘
Optimization Results
“ector display format: IExpanded harizortally d
Solution | @) Accept | Objectivet | Objective?
1 [ r 164.316| 16064
2 M r 179212 173.762
3 M@ r 1 i
4 M r 20689  205.359
5 [ r 0355 226825
B M r 230,611 250,961
7 [ r 240,351 279 G56
g M r 248171 314.004
g [ r 253516 355293
10 o r 255 571 404 93

You can change the weights; for example, if you need a weighted sum of emissions over a
drive cycle, you might want to give a higher weight to the value at idle speed. You can

alter weights by clicking Edit Pareto Weights ( M ) in the toolbar. The Pareto Weights

Editor appears.
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) Pareto Weights Editor =100 ]

Ohbjectives: Weights for Objective!:

ERETC . | ¢ robicentry

Cibjective?

Weights
10

-

LU U T P

-

7 MATLAE wectar:

7 Output column;
I |
;I Select data from =solution: I 1 ;‘

Ok I Cancel | Help |

In this dialog box, you can select objectives to sum, and select weights for any run by
clicking and editing, as shown in the previous example. The same weights are applied to
each solution to calculate the weighted sums. Click OK to apply new weights, and the
weighted sums are recalculated.

You can also specify weights with a MATLAB vector or any column in the optimization
output by selecting the other option buttons. If you select Output column you can also
specify which solution; for example, you could choose to use the values of spark from
solution 5 at each operating point as weights. Click Table Entry again, and you can then
view and edit these new values.

Note Weights applied in the Weighted Pareto View do not alter the results of your
optimization as seen in other views. You can use the weighted sums to investigate your
results only. You need to perform a sum optimization if you want to optimize using
weighted operating points.

The Accept check box is disabled in this view. The exit flag is the minimum of all of the
runs that are summed over, so the Accept status can only go green if all runs are green.
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Multiobjective Output Messages

Multiobjective solutions can have specific exit messages.

To view the exit flag, hover over the accept status icon (green square, orange triangle, or
red circle) for a run in the Optimization output view. You can view the algorithm exit
messages for the currently selected run by selecting View > Current View > Solution
Information. Check these messages to check for problems with your optimization.
Multiobjective gamultiobj Output Messages

For information on gamultiobj output messages, see gamultiobj.

Multiobjective NBI Output Messages

Shadow solutions are displayed at the start of the solution list and indicated by the prefix
“Shadow solution” in the message.

The NBI output messages include the exit flags and the first part of the message returned
by fmincon calls. Extra information about the NBI solution is added to this to explain
certain situations. The extra NBI messages are shown in the following table.

Exit flag |NBI Message

6 Some shadow solutions do not differ. Remove one of the non-competing
objectives.

Note CAGE does not run the subproblems if any pair of shadow solutions are
the same (within tolerance). All subproblems will show an exit flag of -8.

0 The solver stopped prematurely in at least one shadow problem and some
shadow solutions do not differ.

Note All shadow problems share the exit flag of 0, and CAGE does not run
the subproblems (all will show an exit flag of -8)

-7 Solution is dominated by other solutions.

Note Only successful solutions (with an fmincon exit flag >= 0) are used to
determine whether a point is dominated.




See Also

Exit flag |NBI Message

-8 NBI subproblem was not run because some shadow problems do not differ.
-9 NBI subproblem was not run because a shadow problem failed.

See Also

Related Examples
. “Tools for Optimizations with Multiple Solutions” on page 7-51
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Interpreting Sum Optimization Output

Some features of the output node are specific to sum optimizations. Using the Example
Problem (see “Example Problem to Demonstrate Controls for Sum Optimizations” on page
6-24) for reference these features are described in the following sections:

In this section...

“Operating Point Indices” on page 7-72
“Optimization Results Table” on page 7-73
“Objective Graphs” on page 7-74

“Objective Contour Plot” on page 7-75
“Constraint Graphs” on page 7-76

“Constraint Summary” on page 7-77

“Table Gradient Constraint Output” on page 7-78

Operating Point Indices

As in the Input Variable Values pane in the Optimization view, in the output view, the
index of the operating point within a run is denoted by the number in brackets. The
following figures provide examples.

Optimization Results

Yector display format: [SH8e FresVariableValues
5017 15121655260
=02 17 9225754665
Fum B A =03 15.5645478751
1 (1 d =04 2251 78699692
(2) S5 271636105819
ExXH(1) 2253472412308

Ohbjective Graphs

11a
105

Ohjectivel

100
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In the Optimization Results table, the index of the operating point within the run is shown
in brackets. In the Free Variable Values table and graphical displays, the input variable at
the i-th operating point within a run is denoted by InputVariableName (i), for

example, S(4) is the spark value at the 4th operating point, EXH(1) is the value of
exhaust cam phasing at the first operating point.

Optimization Results Table

Features of the Optimization Results table are labeled in the following figure.

Optimization Output Yalues
Vector display format: lExpanded vertically = |
S EXH INT Objective... N L Objective1} Constraint! | Constraint2 | Constraint3 | Constraint4
Run @ Accept 53 53 53 53 5% 53 I 1i| I sil I sil I 24i| I 24i|
D (1) v 15122 22347 39.162 1 1000 0.3 115.005 -153.321 -2966e-8] -6.635e-3| -6.302e-3
\ (2) 17.923| 15.784 44132 1| 1100 02 184163 -3194e-8| -5741e-3 -6556e-3
A (3) 18.565| 24801 41.214 1| 1250 0.31 -151.336| -4.808e-11] -7.015e-3| -6.345e-3
(4) 22818, 19487 44 162 1 1500 0.25 -162.578 -0.955] -7.124e-3| -6513e-3
(5) 27164 17.21 46.515 1| 1625 018 -165.434| 9.012e-9] -6923e-3| -7.331e-3
(6) -7.088e-3| -6.311e-3
) -0.015 -0.016
(8) -0.015 -0.015
(9) -0.015 -0.016
101 -0.015 -0.015
A B C E F G

Key to Optimization Results Table

* A: The run index — Index into the set of operating points that is being displayed.
* B: The quantity index.

* For fixed and free variables this index corresponds to the index of the operating
point within the run.

* For objectives this corresponds to the index of the output for the specific labeled

objective.

* For constraints this corresponds to the index of the output for the specific labeled

constraint.

7-73



7 Optimization Analysis

7-74

* C: Optimal Free Variable Settings — The optimal settings in this case of S, EXH and
INT at each operating point in the run. For example, the optimal settings of S, EXH
and INT at the third operating point in this run 1 are S=18.565°, EXH= 24.801°, INT=
41.214°

* D: Fixed Variable Settings — These settings define the operating points for the run and
other fixed variables (such as weights) required for objectives and constraints. These
values were set up before the optimization was run. For information on the set up of
these values, see “Selecting Scalar Variables” on page 6-25.

* E: Optimal objective outputs — The optimal values of any objective outputs are
displayed here, e.g., the optimized value of the weighted sum of TQ (115.002 Nm) over
the 5 operating points shown in this case.

* FEG: Constraint outputs at optimized control parameter settings — The value of
constraint outputs are displayed here. For the example problem, the model constraint
outputs are displayed in the section labeled F. Note that the number of constraint
outputs matches the number of operating points. The table gradient constraint outputs
are displayed in the section labeled G. The number of values returned by the table
gradient constraint is dependent on the internal settings of that constraint (see
information see “Table Gradient Constraint Output” on page 7-78). For more
information on the number of values returned by objectives and constraints, see
“Algorithm Restrictions” on page 6-25.

Objective Graphs

The objective graphs for sum objective problems show the objective cross section plots as
in the point case. However, plots are now displayed against each control parameter at
each point in the set of operating points within each run. In the following figure, the
weighted sum of TQ is plotted against the spark values at the first four operating points in
run 1.
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Objectivel
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Objective Contour Plot

The objective contour plot for sum objective problems shows the contours of the objective
as in the point case. However, plots can now be displayed against any pair of control
parameters chosen from all the control parameters at each point in the set of operating
points within each run. In the following figure, a contour plot of the weighted sum of TQ is
plotted against the value of exhaust valve timing for the third operating point, EXH(3)
and the value of intake valve timing for the third operating point, INT(3).

7-75



7 Optimization Analysis
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Constraint Graphs

The constraint graphs for sum objective problems show the cross section plots of the left
side of the constraints as in the point case. However, in the sum case there are several
more inputs and outputs that can be plotted. Specifically, each constraint can return
several outputs (see “Algorithm Restrictions” on page 6-25 for more detail) and these can
be displayed against each control parameter at each point in the set of operating points
within each run.
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Conskraink Graphs
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In the example problem, the exhaust temperature and residual fraction constraints have 5
outputs, one for each operating point. In the graphs shown, one output of the exhaust
temperature and residual fraction constraints is displayed against four free variables.
Specifically, the exhaust temperature model evaluated at the fifth operating point in run 1
(Constraint1(5)) and the residual fraction model evaluated at the first operating point
inrun 1 (Constraint2(1)) is plotted against the values of exhaust valve timing at
operating points 4 and 5 (EXH(4) and EXH(5)) plus the values of intake valve timing at
operating points 1 and 2 (INT(1) and INT(2)).

See also “Table Gradient Constraint Output” on page 7-78.

Constraint Summary

The constraint summary for sum optimizations shows a summary of all the constraint
outputs for each constraint at the optimized control parameter settings for the selected
run. The constraint summary table for the Example problem is shown in the following
figure.
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aink Surnmary
Description Constraint alue Left ¥alue Right alug
4 constraintt EXTEMPES(13, Ni13, L1, EXHE Y, INTE13) <= 1290 1553321 1136679 1240
EXTEMPES(2), N(29, L(2), EXHE2), INTE2)) <= 1290 AB4 163 1105 537 1200
EXTEMPES(S), NG3), L3, EXHER), INTES)) <= 1290 51 336 1138 564 1200
EXTEMPES(4), Ni4), L(4), EXH4), INTE4)) <= 1290 152,578 1127 422 1200
EXTEMPES(5), Ni5), L(5), EXHES), INTES)) <= 1230 165434 1124 566 1290
IE Constraint2 RESIDFRACES(1Y, Mi13, LE13, EXHOY, INTE ) == 17 -2 9fifie-5 17 17
RESIDFRAC(S(2), M(2), L(2), EXHIZ), INT(2)) == 17 -3.194e-5 17 17
RESIDFRAC(S(3), Mi3), L(3), EXH(3), INT(3)) == 17 -4 609e-11 17 17
RESIDFRACIS(4), Mid), L(4), EXH(4), INT(4)) == 17 _0.455 16045 17
RESIDFRAC(S(S), Mi5), L(S), EXH(S), INT(S)) == 17 9.012e.9 17 17
n Constrairt? Mazitum rowe gradiert of INT over (ML) -6 .635e-3 4.365e-3 0.011
Mazitum column gracient of IMT owver (ML) -23.167 31.833 55
n Constrairtd Mazimum rowy graciert of EXH over (ML) -6.302e-3 4 596e-3 0.011
Maximum column gradient of EXH over (ML) 1.066e-13 55 55

A summary of the first constraint, EXTEMP <= 1290°C at each operating point
(Constraintl), is shown in the first five rows of the table. In this case, each of the rows
corresponds to an evaluation of the constraint at each operating point within the run. For
example, the second row of Constraintl details an evaluation of EXTEMP <= 1290°C
at the second operating point in the set of operating points in the run, as indicated in the
Description: EXTEMP(S(2), N(2), EXH(2), INT(2))<= 1290.

The summary for the table gradients (Constraint3 and Constraint4) is shown. For a
detailed explanation of table gradient outputs, see the next section, “Table Gradient
Constraint Output” on page 7-78.

Table Gradient Constraint Output

The table gradient constraint output is best explained using an example problem.
Control parameters/free variables: SPK, EXH, INT

Fixed variables: N, L

Objective: Maximize Weighted sum of TQ(SPK, EXH, INT, N, L) over the points shown in
the following table (with unit weights at each point):

N L

3000 0.5
3000 0.6
4000 0.5
4000 0.6
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Table Gradient Constraint: Maximum change in EXH is bounded by the following
specifications:

* No more than 5° per 1000rpm change in N

* No more than 4° per 0.1 change in L

* Over the following 2-by-2 table: N breakpoints = [3000 4000]; L breakpoints =[0.5
0.6]

In this case, the optimization operating points are the same as the selected table
breakpoints for the table gradient constraint, but these are not necessarily always the
same.

When the optimization has run, the following optimal values of EXH are returned from the
optimizer, as shown in the following tables.

N/L L(1) L(2)
N(@) EXH(1) EXH(2)
N(2) EXH(3) EXH(4)

The values for all these items are shown in the following table.

N/L 0.5 0.6
3000 2.225 0
4000 -2.775 =B

Table gradient constraints calculate the gradient between the values of specified free
variable at the specified table points specified by the constraint. In the example problem,
the table gradient constraint returns a set of constraint values as follows.

The table gradient constraint takes the values of EXH from the optimizer, and then
determines the value of EXH at the grid points defined in the table gradient constraint. In
this case, those grid points are the same, so this is identical to the preceding table. In
cases where the grid points in the optimization do not match those in the table gradient
constraint, a radial basis function interpolant is used to estimate the constrained variable
on the table gradient grid points.

The table gradient constraint takes the grid of EXH values and calculates row and column

gradients. Row gradients in the direction of increasing N, rg™¢, are calculated on the grid
as follows:
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rg,n¢ = (EXH(3)-EXH(1))/(N(2)-N(1))
= (-2.775-2.225)/1000

=-0.005

rg,™ = (EXH(4)-EXH(2))/(N(2)-N(1))
= (-5-0)/1000

=-0.005

The table gradient constraint restricts the row and column gradients in each direction.
Row gradients in the direction of decreasing N, rg?e¢, are calculated on the grid as
follows:

rg;9¢¢ = -rg;° = 0.005
rgZdec = - mc = 0.005

Column gradients in the direction of increasing L, cg™¢, are calculated on the grid as
follows:

cg;™ = (EXH(2)-EXH(1))/(L(2)-L(1))
= (0-2.225)/0.1

=-22.25

cg;™ = (EXH(4)-EXH(3))/(L(2)-L(1))
= (-5-(-2.775))/0.1

=-22.25

Similarly, column gradients in the direction of decreasing N, rg?e, are calculated on the
grid as follows:

cg,%e¢ = -cg,"° = 22.25
ngdec — _ g inc — 22 25

The table gradient constraint implements the following:
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rgl

rg2

inc

inc

5/1000
<

[5/1000]
5/1000
5/1000

4/0.1
4/0.1
4/0.1

| 4/0.1 |

This equation can be rewritten as Left Value <= Right Value. In each row the Left Value
must be smaller than the Right Value to meet the constraint.

The Constraint Value numbers returned to the optimizer are calculated as follows:
Constraint Value = Left Value - Right Value.

i inc
r81
inc
r82
dec

r81

dec

r81
inc

81
inc

€82

dec

c81

dec

LC81

[5/1000 ]
5/1000
5/1000
5/1000
4/0.1
4/0.1
4/0.1

| 4/0.1

[-0.005 |
—-0.005
0.005
0.005
-22.25
-22.25
22.25

| 22.25 |

[0.005]

0.005
0.005
0.005

5888

[ —0.01 |
-0.01
0
0
—62.25
—-62.25
-17.75

| -17.75 ]

These constraint values are shown in the Optimization Results table. Negative constraint
values mean the constraint is feasible, and infeasible constraints are highlighted yellow.
In the following figure, these values appear in the Constraint4 column. The Optimization
Results pane also shows the fixed variable settings, the optimal free variable settings, and
the evaluation of objectives and constraints at the optimal free settings.
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The constraint graphs for a table gradient constraint show how the Left Value of each
output of a table gradient constraint depends on the free variables in the optimization.
These graphs for the example problem appear in the following figure.

Constraink Graphs
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The Left Value is compared with a plot of the Right Value output on the same axes. This
comparison is illustrated for the table gradient example problem. Consider the top-left
graph in the figure shown. Constraint4(1) is the first Left Value (rg;™) of the table
gradient constraint in the example problem. Recall that this can be written as
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rg,i"c = (EXH(3)-EXH(1))/(N(2)-N(1))

The top left graph shows a plot of rg;™ against EXH(1) with all other free variables set to
their optimal values, i.e.,

rg;¢ = (2.775-EXH(1))/1000

which is the blue line shown in the top left graph. The horizontal red line shows the Right
Value (i.e., the upper bound on rg,;¢). Because this value is an upper bound on the
allowable gradient, the yellow region above the line shows where the table gradient
constraint is infeasible. The vertical orange line shows the optimal value of the free
variable, EXH(1). The blue marker on the Constraint4(1) axis marks the Left Value (the
value of rg,i") at the intersection of the optimal EXH(1) value and the blue line.

The graph of Constraint4(1) against EXH(2) shows a flat line. The flat line indicates that
there is no dependence of rg;" on EXH(2), as it is calculated as (EXH(3)-EXH(1))/(N(2)-
N(1)).

The other constraint graphs can be analyzed in a similar way.

Note If you are using table gradient constraints the solution may appear infeasible upon
inspection of the objective and constraint graphs (the graphs may appear to be entirely
yellow). There are cases when the solution is actually feasible in this case. This
appearance of infeasibility often arises in sum problems which have tight table gradient
constraints. In such cases, you should check the Solution Information pane and the
Constraint Summary Table to check whether a feasible solution has been found.

A summary of the table gradient constraint output is shown in the Constraint Summary
table, as shown following.

Constraint Summaty |

Mathe Description Constraint Yalus Left Yalue Rigit ¥ alue

E Constraintd Maimum rovy gradient of EXH over (ML) u] Se-3 Se-3
Maimum column gradient of EXH over (ML) -17.75 2225 40

The maximum gradient in the row and column direction (if it is a 2-D table gradient
constraint) is shown in the table. In the example shown, observe the maximum column
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gradient of EXH. Recall previously that the cg (column gradient) values were calculated to
be -22.25, -22.25, 22.25 and 22.25. The maximum column gradient is 22.25, shown in the
Left Value column in the Constraint Summary table. The bound at the maximum value of
the column gradient is 40, shown in the Right Value column in the table. The Constraint
Value column shows the value of Left Value minus Right Value, which is -17.75, so the
constraint has been met.

The Constraint Value gives a measure of the distance to the constraint boundary for
each constraint output. If the Left Value > Right Value and greater than the tolerance for
any of the constraint outputs, the constraint value is bold and the row is highlighted
yellow. By default this tolerance is taken from the optimization constraint tolerance. You
can control the value used for this highlighting by selecting View > Edit Constraint
Tolerance. The highlighting indicates that this constraint distance should be checked to
see if the constraint is feasible at that point.
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This section includes the following topics:

* “User-Defined Optimizations” on page 8-2

+ “Example User-Defined Optimization” on page 8-9

* “Creating an Optimization from Your Own Algorithm” on page 8-16
* “Optimization Function Reference” on page 8-31

* “Functions — Alphabetical List” on page 8-35
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In this section...

“Introducing User-Defined Optimization” on page 8-2
“Implementing Your Optimization Algorithm in CAGE” on page 8-3
“About the Worked Example Optimization Algorithm” on page 8-5
“Checking User-Defined Optimizations into CAGE” on page 8-7

Introducing User-Defined Optimization

User-defined optimizations are described in the following sections:

* “Implementing Your Optimization Algorithm in CAGE” on page 8-3 describes how to
customize the optimization template to use your optimization routines in CAGE.

* There is a step-by-step guide to using the example provided to help you understand
how to modify the template file to use your own optimization functions. See the
tutorial section “Example User-Defined Optimization” on page 8-9.

In many cases the standard routines supplied for constrained single objective (fmincon,
ga, and patternsearch) and multiobjective optimization (NBI) are sufficient to allow
you to solve your optimization problem. Sometimes, however, you need to write a
customized optimization algorithm. This can be useful in many situations, for example,

* For an expert to capture an optimization process to solve a particular problem, for
example, determination of optimal spark angle and exhaust gas recirculation rate on a
port-fuel injection engine

» To implement an alternative optimization algorithm to those supplied

» To implement a complex constraint or objective that is only possible through writing
code

» To produce custom output graphics

User-defined optimization functions in CAGE allow advanced users to write their own
optimization routines that can access current CAGE data. In order to access the user
function from CAGE, you must register the file with CAGE and place it on the MATLAB
path. It is crucial that this function conforms to the template specified. The following
sections describe this process.
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Implementing Your Optimization Algorithm in CAGE

At some point a CAGE optimization function calls on an algorithm to optimize the
objective functions over the free variables. You can implement the algorithm in the CAGE
optimization function as an external MATLAB file. Use the template file as a basis for your
optimization function. The best way to understand how to alter the template file to
implement your own optimization algorithms is to compare it with the worked example, as
described in the tutorial.

* See the following optimization tutorial sections:
+ “Example User-Defined Optimization” on page 8-9 describes the process of using

the worked example

* “Creating an Optimization from Your Own Algorithm” on page 8-16 describes in
detail the steps necessary to use an example optimization algorithm in CAGE

* “About the Worked Example Optimization Algorithm” on page 8-5, later on this
page, examines the coding involved in implementing an external optimizer in a CAGE
optimization file

* “Checking User-Defined Optimizations into CAGE” on page 8-7, later on this page,
explains how to check in your optimization function so you can use it in CAGE

Optimization Function Structure

The optimization function files have two sections. To compare these sections in the
worked example with the template file on which it is based:

1 Locate and open the file mbcOStemplate in the mbctraining folder.
2 Type the following at the command line to open the example:

edit mbcOSworkedexample
The two sections are the Options section and Evaluate section.

1 The Options function section contains the settings that define your optimization.
Here you can set up these attributes:

* Name
* Description
* Free variables
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* Objective functions

* Constraints

* Helper data sets

* Optimization parameters

CAGE interacts with the cgoptimoptions object, where all these settings are
stored.

See “Methods of cgoptimoptions” on page 8-31 for information about setting up the
options section.

If you leave the cgoptimoptions function unchanged, your optimization function
must be able to support the default options. That is, your optimization will have:

* One objective
* Any number of constraints (selected by the user in CAGE )

2 The Evaluate function section contains your optimization routine. CAGE calls this
section when the Run button is clicked.

Place your optimization routine under this section, interacting with CAGE (obtaining
inputs and sending outputs) via the cgoptimstore object. Your optimization must
conform to the following syntax:

optimstore = <Your Optimization> (optimstore)
where <Your Optimization> is the name of your optimization function.

Any local functions called by your optimization routine should also be placed at the
bottom of this section.

See “Methods of cgoptimstore” on page 8-33.

Note Be careful not to overwrite the worked example and template files when you are
trying them out — save them under a new name when you make changes.

There is a step-by-step guide describing how to modify the template using the worked
example optimization function in the optimization tutorial. See “Example User-Defined
Optimization” on page 8-9.
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About the Worked Example Optimization Algorithm

mbcweoptimizer is an example of a user-specified optimization that solves the following
problem:

max TQ over (AFR, SPK).

* [bestafr, bestspk] = mbcweoptimizer(TQ) finds a maximum (bestafr,
bestspk) to the function TQ.

TQ must be a function (or a function handle) where the first two input arguments are
AFR and SPK respectively. TQ functions with more parameters can be used. The extra
parameters to these functions can be specified using anonymous functions. For
example if a TQ model has N and L inputs, you can use the following call to
mbcweoptimizer:

[bestafr, bestspk] = mbcweoptimizer(@(afr, spk)TQ(afr, spk, N, L))

* [bestafr, bestspk]l=mbcweoptimizer(TQ, afrrng, spkrng) finds a maximum
(bestafr,bestspk) to the function TQ.

afrrng and spkrng are 1-by-2 row vectors containing search ranges for those
variables.

* [bestafr, bestspk]=mbcweoptimizer(TQ, afrrng, spkrng, res)findsa
maximum (bestafr,bestspk) to the function TQ.

This optimization is performed over a res-by-res grid of (AFR, SPK) values. If res is
not specified, the default grid resolution is 25.

The Structure of the Worked Example

The best way to understand how to implement an external optimizer in a CAGE
optimization function is to study the details of the example.

» To view the whole worked example file, at the command line, type
edit mbcOSworkedexample

The following code section is taken from the Evaluate section of the worked example file
as an example.
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% For every fixed point, find/the optimum (afr, spk) using

% the mbcweoptimizer rouytd have written

[bestafr, bestspk] boweoptimizer @n_evalTQ, [roinAFR, maxiFR],
[inSPK, max3PK], res

% Set the best wvalues calculated for the free wvariable(s) into the

% data set
optimstore = setFreeVariables(optimstore, [bestafr, bestspk]):
% Return sowme information about the optimization

OQUTPUT.Algorithm = 'Brute force search':
OQUTPUT.Resolution = res;

% Set all information in the optimstore
optimstore = sgsetExitStatus(optimstore, 1, 'Optimization Completed'):
optimstore = setOutput (optimstore, OUTPUT):;

The code fragment above is in the 1 Evaluate local function. This local function is
called once for each run of the script. The line of code labeled A above calls the worked
example optimization algorithm external to the optimization function. As with functions in
the Optimization Toolbox product, the first argument to the call to the optimizer is a
function handle that evaluates the objectives at a given input point. We recommend you
place the function pointed at by the function handle in the optimization file. If you do not
place them in the same file you must make sure the evaluate function file is on the
MATLAB path. As an example, the optimization evaluation function in the worked example
optimization is shown in the code fragment following.
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function ¥ = n_evalTQ(afr, spk)

v = evaluate [afr, spk]):

end
B

The inputs to n_evalTQ are the required inputs for the torque (in this case) model. To
evaluate the objective, the evaluate method from the optimstore object is used. In the
above example, the line of code referenced by B evaluates the torque model in the worked
example at the (afr, spk) input points. The values of (N, L) at the current run are used in
the evaluation of the torque model. CAGE retrieves these values from optimstore when
the torque model is evaluated.

The two local functions presented above are an example of how to implement an external
optimizer in a CAGE optimization file.

See also the optimization tutorial section “Creating an Optimization from Your Own
Algorithm” on page 8-16, which describes in detail the steps involved in incorporating an
example algorithm into a CAGE optimization file.

Checking User-Defined Optimizations into CAGE

When you have modified the template to create your own optimization function, you must
check it into the Model-Based Calibration Toolbox product in order to use the function in
CAGE. Once you have checked in your optimization function it appears in the
Optimization Wizard. See “Optimization Wizard” on page 6-13.

To check a user-defined optimization into CAGE,

1 Select File -> Preferences.

2 Click the Optimization tab and click Add... to browse to your file. Select the file and
click Open. This registers the optimization function with CAGE. You need to do this
when you customize your own optimizations.
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The example shows the worked example function, which is already registered with
CAGE for use in the optimization tutorial.

You can click Test to check that the optimization function is correctly set up. This is a
very useful function when you use your own functions; if anything is incorrectly set
up the test results tell you where to start correcting your function.

You can see an example of this by saving a copy of the worked example file and
changing one of the variable names (such as afr) to a number. Try to check this
altered function into CAGE and the Test button will return an informative error
specifying the line you have altered.

Click OK to dismiss the CAGE Preferences dialog box and return to the CAGE
browser.

Registered optimizations appear in the Optimization Wizard when you set up a new
optimization.

Registered optimizations appear in the Create Optimization from Model Wizard
unless your user-defined optimization script defines operating point sets and/or a
fixed number of free variables. This is common with Version 2.0 scripts. If this is the
case you must use the Optimization Wizard instead.
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Example User-Defined Optimization

In this section...

“Example Overview” on page 8-9
“Using the Worked Example Optimization” on page 8-10

Example Overview

There is a simple worked example provided to show you what you can do by modifying the
template file to write your own optimizations. This example demonstrates a simple use of
the CAGE optimization feature. The aim of this example is to obtain values of spark (SPK)
and air/fuel ratio (AFR) that maximize torque at a given speed (N) and load (L). These
values could then be used to fill calibration tables.

An example of a user-defined optimization algorithm is provided.
* To see a description of this algorithm, at the command line type
help mbcweoptimizer

mbcweoptimizer is an example of a user-specified optimization that solves the following
problem:

Maximum TQ over (AFR, SPK) at a given (N, L) point.

The syntax for this example function, mbcweoptimizer, mimics that used in the
Optimization Toolbox product.

* To evaluate this at the command line, type this example:

[bestafr, bestspk] = mbcweoptimizer(@(afr, spk)mbcTQ(afr,...
spk, 1000, 0.2))

The optimization finds values of AFR and spark (the free variables) that give the
maximum output from TQ at the values of speed and load (the fixed variables) that you
specified, in this case speed = 1000, load = 0.2, as shown below.

bestafr =
12.9167
bestspk =
25
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To use this optimization algorithm in CAGE, you need to include the function in a CAGE
optimization function script. This worked example modifies the template provided to show
you how to use your own algorithms within CAGE. You can find detailed information on all
the available CAGE optimization interface functions in “User-Defined Optimizations” on
page 8-2 in the CAGE documentation.

» To view the worked example file, at the command line, type
edit mbcOSworkedexample

The worked example optimization wraps mbcweoptimizer in a function that can be
called by the CAGE optimization feature. When you run your optimization from CAGE, you
can alter the search ranges of the free variables and the resolution of the search.

The next section, “Using the Worked Example Optimization” on page 8-10, demonstrates
how to use the example within CAGE.

The section “Creating an Optimization from Your Own Algorithm” on page 8-16 is a
detailed tutorial example explaining how to incorporate an example user-defined
optimization algorithm into a CAGE optimization function.

Using the Worked Example Optimization
In order to run any optimization, you first need to set up your CAGE session with a model.

For this example, the CAGE session requires

* A torque model

» Avariable dictionary defining required variable ranges and set points (N, L, AFR, and
SPK)

* A data set defining the (N,L) operating points where you want to run the optimizer

There is a preconfigured session provided that contains the model, variable dictionary,
and data set.

1  Select File > Open Project and load the file optimworkedexample. cag. This is in
the mbctraining folder.

* The tg model was fitted to the Holliday engine data and exported from the Model
Browser quick start tutorial (also used in the CAGE feature calibration tutorial). It
can be found in tutorial.exm in the mbctraining folder. To view this model in
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your current session, click the Models button in the Data Objects pane. There is
also another model in the session that you will use later.

* You can look at the variables by clicking the Variable Dictionary button in the
Data Objects pane.

* You can look at the operating point set by clicking Data Sets in the Data Objects
pane. Note you can specify fixed variables for optimizations either directly in the
optimization view or import them from a data set or table.

Select File > New > Custom Optimization.

The Optimization Wizard appears.
Select WorkedExample, and click Next.

Associate each pair of inputs and variables, by clicking afr and A in the left and right
lists, and then click the Select button. Similarly associate spark with spk. Click
Next.

) Dptimization Wizard =10l =]

Required Yariables
Match each recuired variable in the optitnization to a varisble from the Variable Dictionary .

Optitnization inputs: CAGE variahles:
Label | CAGE Yariable | X spark
afr A XM
sk spark XL
: A
e

Cancel | = Back | Mext = Finizh |

The next screen of the wizard automatically shows the Torque model selected and

Maximize chosen; these are specified in the function. Select tq in the CAGE model
list and click the button to match it with the Torque optimization model, then click
Finish.
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) Optimization Wizard [ 4|

Objectives
Ohjectives are gquantities that the algorithm will attempt to optimize. Select CAGE models to bhe used for each objective,
andd whether it should be minimized, maximized or used a2 a helper model for the algorithm.

Optitnization ohjectives: CAGE models:
Oiptimization Model | CAGE Model | Type ity
Torque tq I aximize 4tu‘t‘lq

Objective type: & Winimize (% Maximize  Helper

Cancel | = Back | [t = Finish |

CAGE switches to the Optimization view and the new Optimization node appears
in the tree.

6 If you ran the optimization now it would run at one point, the set point of all the
variables. You use the free and fixed Variable Values panes to select operating
points. You can edit points manually or import them. Select Optimization > Import
From Data Set.
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) Import From Data Set

Data zet to import from:
v Only show data sets that contain optimization inputs

Marme

Rows | Contents

D Mew Dataset

38(L, N

Rl

Select data =t columns 1o use:

Impart | Optimization Input Data Set Colurmn
r |a e
[ spark ;l
F | Ba N [
F L B L [
— Import options

{% |Jze one data set row for each run (ater number of ...

= Use entire data set column for each run (atter length...

Ok

Cancel

The project file contains a data set with N and L values, and these are automatically

selected. Click OK to import.

Notice 36 rows appear in both fixed and free variable panes, and operating point
values have been imported into the N and L columns in the Fixed Variables pane.
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The initial values for A and spark for each point are the set points in the variable
dictionary.

Click Run Optimization in the toolbar.

When the optimization completes, the view switches to the new
Optimization Output node.

The output display should look like the following. The optimization has found the
values of SPK and AFR that give the maximum model value of torque at each
operating point specified. Select different operating points by clicking in the table:
the model plots at the selected operating point are shown. There is only one solution
per operating point, so you cannot scroll through the solutions.
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)} CAGE Browser - optimworkedexample.cag - |EI|5|
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| Ready |

For a detailed walk-through of incorporating an example user-defined optimization
algorithm into a CAGE optimization function, see the next tutorial section, “Creating
an Optimization from Your Own Algorithm” on page 8-16.
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Creating an Optimization from Your Own Algorithm

8-16

In this section...

“Process Overview” on page 8-16

“Step 1: Verify the Algorithm” on page 8-17

“Step 2: Create a CAGE Optimization Function” on page 8-19

“Step 3: Define the Optimization Options” on page 8-20

“Step 4: Add the Algorithm to the Optimization Function” on page 8-23
“Step 5: Register Your Optimization Function with CAGE” on page 8-26

“Step 6: Verify Your New Optimization” on page 8-27

Process Overview

The CAGE optimization feature allows you to use your own optimization algorithms as
alternatives to the library routines fmincon, NBI, ga and patternsearch.

Using an example, this tutorial illustrates how to take an existing optimization algorithm
and implement it as an optimization function for use in CAGE optimization.

The problem to be solved is the worked example problem:

Maximize torque (TQ) over the free variables (SPK, AFR) over a specified set of (N, L)
points. These points are defined in the data set New Dataset, which can be found in the
CAGE session optimworkedexample.cag and can be imported to the fixed variable
values pane in the Optimization view.

The torque model to be used is that in /mbctraining/Holliday.mat.

The process steps are:

1  Start with your own algorithm. We will use fminunc from the Optimization Toolbox
product as an example.

Create a CAGE optimization function.

Define the attributes of your optimization in the CAGE optimization function.

Add your algorithm to the CAGE optimization function.

gua & W N

Register your completed optimization function with CAGE.
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6

Verify the optimization.

The steps of this tutorial lead you through a series of examples illustrating how to
construct the code to incorporate your own algorithm into an optimization in CAGE.

Before you begin you must create a working folder.

1

Create a new folder (for example, C:\Optimization Work). We recommend that
you place this folder outside your MATLAB folders to avoid interfering with toolbox
files.

Copy the following six files from the mbctraining folder into your new working folder:

currtutoptim.m
mbcOStemplate.m
mbcOStutoptimfunc sl.m
mbcOStutoptimfunc.m
optimtut.mat
optimtuteg.mat

Make sure your new working folder is on the MATLAB path; either change Current
Folder in MATLAB to the new working folder, or add the folder to the path as follows:

a On the Home tab, in the Environment section, click Set Path.
b Click Add Folder and browse to your working folder.

¢ Click OK.

d Click Save.

e Click Close.

Step 1: Verify the Algorithm

currtutoptim.m is an example file to verify that fminunc solves the worked example
problem. You can try this at the MATLAB command line.

1

To open the algorithm file in the Editor, either enter open currtutoptim.m at the
command line, or if the Current Folder in MATLAB is your new working folder, then
double-click currtutoptim.m in the Current Folder. You should see the code in the
MATLAB editor.

To verify that fminunc solves the worked example problem, type the following
command at the MATLAB prompt:

bestX = currtutoptim
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After the progress messages complete the workspace output should resemble the

following:
BestX =

23.768 12.78
18.179 12.78
14.261 12.78
12.014 12.78
11.439 12.78
12.535 12.78
27.477 12.78
21.887 12.78
17.969 12.78
15.722 12.78
15.147 12.78
16.243 12.78
31.185 12.78
25.595 12.78
21.677 12.78
19.43 12.78
18.855 12.78
19.951 12.78
34.893 12.78
29.303 12.78
25.385 12.78
23.138 12.78
22.563 12.78
23.659 12.78
38.601 12.78
33.012 12.78
29.093 12.78
26.847 12.78
26.271 12.78
27.368 12.78
42.309 12.78
36.72 12.78
32.802 12.78
30.555 12.78
29.979 12.78
31.075 12.78

The matrix bestX contains the optimal SPK and AFR values that maximize the MBC model
torque (exported from Holliday.mat) at the speed and load points defined in the matrix
data.
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fminunc is the example optimization algorithm that you want to transfer to CAGE for use
in the optimization GUI.

This tutorial shows how to make fminunc available for use in the CAGE optimization
feature.

Step 2: Create a CAGE Optimization Function

Any optimization algorithm you want to use in CAGE must be contained in an optimization
function. A CAGE optimization function consists of two sections.

The first section defines the following attributes of the optimization:

* A name for the optimization
* A description of the optimization
* Number of free variables

* Labels for free variables (if required), so the user can match variables in CAGE to the
required algorithm free variables.

* Number of objectives

» Labels for objective functions, so the user can match models in CAGE to the required
algorithm objectives (you can match in CAGE, so labels do not have to be exact in the
optimization function)

¢ Number of constraints

* Labels for constraints, so the user can match models in CAGE to the required models
in your algorithm constraints

e Number of data sets

» Labels for data sets, so the user can match data sets in CAGE to the required variable
data for your algorithm

* Any other parameters required by the optimization algorithm
The second section contains the optimization algorithm.
Open mbcOStemplate.min the MATLAB editor.

mbcOStemplate.mis an empty CAGE optimization function. The two (currently empty)
sections of the function are options (for defining optimization attributes) and
optimstore (for defining your optimization algorithm). Note that this file can be used as
a template for any optimization function that you write.
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Step 3: Define the Optimization Options

The next step is to define the attributes of your optimization (in Section 1 of the
template).

Open mbcOStutoptimfunc sl.m. In this file, you can see the optimization attributes
that have been defined.

The following is a code fragment from this file:

8-20
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E

ezl with the action inputs

if stremwp (action, 'options'

options = in;
% Add a name

options = setMName (options, 'Tutorial Optimization'):
% Add a description

options = setDescription(options, 'L simple worked example to maximize torgue')

% Set up the free wvariabhles

options = setFreeVariablesMode (options, 'fixed'):
options = addFreeVariable (options, 'afr');
options = addFreeVariable (options, 'spk'):

% Set up the objective functions
options = setCbhjectivesMode (options, 'fixed'):
options = addCbhbjective (options, 'Torgue', 'max'):

% Set up the constraints
options = setConstraintsMode (options, 'fixed']):

% There are no constraints for this example
% 3et up the operating point sets
options = setOperatingPointsMode (options, 'fixed']:
% There are no operating point sets for this example
% Zet up the optiwization parameters
options = addParameter (options, 'Displav',

{'list', {'none', 'final', 'iter'}}, 'none');
options = addParameter (options, 'MaxIter',

{'integer', 'positiwve'}, 200, 'Maximum iterations'):
options = addParameter (options, 'MaxFunEvals',

{'integer', 'positive'}, 1000, 'Maximum function evaluations'):
options = addParaweter (options, 'Toli',

{'nuber', 'positive'}, le-6, 'Variable tolerance');
options = addParameter (options, 'TolFun',
{'nuber', 'positive'}, le-6, 'Function tolerance');

out= options;

elzeif stremwp (action, 'evaluate!’

optimstore = in;

Y

% Put optimization algorithm here
£

The optimization attributes are passed to CAGE via the cgoptimoptions object,
referenced by options in the code in mbcOStutoptimfunc_sl.m. See after the table for
details of the cgoptimoptions object. The cgoptimoptions object has a set of
functions that set the optimization attributes in CAGE. This is where you specify the
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name, description, free variables, objective functions, constraints, helper data sets, and
optimization parameters for the optimization.

For detailed information on all the available functions, see “Optimization Function
Reference” on page 8-31 in the CAGE documentation. The above code has used the
cgoptimoptions object (options) to set the optimization attributes as described in the

following table.

Look through the code to locate the listed Code Section Where Set for each attribute to
see how each of the optimization options is set up.

Attribute

Value

Code Section Where Set

Optimization Name

Tutorial Optimization

Add a name - setName

Description

A simple worked example to maximize
torque

Add a description -
setDescription

Number of Free Variables

Cannot be changed by the user in the GUI
(the mode has been set to ' fixed')

Set up the free
variables -
setFreeVariablesMode

Required Free Variables

This function requires two free variables,
labeled 'afr' and 'spk'. The user
matches these free variable labels to CAGE
variables in the Optimization Wizard.

Set up the free
variables -
addFreeVariables

Number of Objectives

Cannot be changed by the user in the GUI
(the mode has been set to ' fixed"')

Set up the objective
functions -
setObjectivesMode

Required Objective
functions

This function requires one objective
function, which will be labeled 'Torque'

Set up the objective
functions -

has no linear or nonlinear constraints.

in the optimization feature. The user addObjective

matches this 'Torque' label to a CAGE

model.
Number of Constraints Cannot be changed by the user in the GUI |Set up the

(the mode has been set to 'fixed') constraints -

SetConstraintsMode

Required Constraints As the mode is fixed and no constraint Set up the

labels have been defined, this optimization |[constraints - %There

are no constraints
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Attribute Value Code Section Where Set
Number of Helper Data Cannot be changed by the user in the GUI |Set up the operating
Sets (the mode has been set to ' fixed'). point sets -

There are no helper data sets for this
example.

setOperatingPointsMod
e

Optimization Parameters

This function will allow the user to change
five parameters. These will be displayed in
the Optimization Parameters dialog box
and labeled Display, Maximum
iterations, Maximum function
evaluations, Variable tolerance, and
Function tolerance.

Set up the

optimization
parameters -
addParameter

When one of your optimizations is created in the CAGE GUI, CAGE first calls your
optimization function to define the attributes of the optimization. The function call from
CAGE has the form

optionsobj =

<your_optimization_ function>('options', optionsobj)

This is how your optimization function receives the cgoptimoptions object. Note that
your optimization function must support this interface.

Step 4: Add the Algorithm to the Optimization Function

In this step you complete the optimization function by adding your algorithm. To do this, a
few changes need to be made to the code that calls the algorithm, as data (for example,
free variable values, constants, and so on) will now be passed to and from CAGE rather
than from the MATLAB workspace.

1  Open mbcOStutoptimfunc.m.

This file contains the completed optimization algorithm. The following is a code
fragment from this file.

elseif strcmplaction,

'evaluate')

optimstore = in:
optimstore = tutoptimizer (optimstore);
out = optimstore;

A single line has been added, namely
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optimstore = tutoptimizer(optimstore)

This line calls the modified optimization algorithm. Note the syntax of the algorithm:
it must take the form

optimstore = <your optimization algorithm>(optimstore)

2 The local function tutoptimizer can be found at the bottom of the file
mbcOStutoptimfunc.m. Scroll down to view the algorithm, modified for use in
CAGE.

optimstoreis a cgoptimstore object. This is an interface object that allows you to
get data from and set data in the CAGE optimization feature. You can now see how
the optimstore object is used by comparing the modified optimization algorithm,
tutoptimizer, with the original algorithm, currtutoptim, for each of the main
sections of the algorithm.

The following sections illustrate how to convert an existing algorithm for use in CAGE.
Note that in this tutorial example, the code is already modified for you to examine.

Algorithm Section 1

Get the start conditions (x0) for the free variables.
Original code:

x0 passed in from the MATLAB workspace.
Modified code:

x0 = getInitFreeVal(optimstore);

In the original algorithm, x0 is passed into the algorithm from the MATLAB workspace. In
CAGE, we invoke the getInitFreeVal function on the optimstore object to retrieve
x0.

Algorithm Section 2
Perform the optimization (in Section 2 of the template).

Original code (from currtutoptim):

[bestx(i, :), notusedl, notused2, OUTPUT(i)] = fminunc(trqgfunc,
x0, algoptions);
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which calls the following code to evaluate the cost function:
function tq = trgfunc(x)

% Evaluate torque. Note x = [SPK, AFR]
tq = EvalModel(TQMOD, [x(1), N(i), L(i), x(2)1);

% Maximising torque, so need to return -tq
tq = -tq;

end

Modified code:

[bestx, unused, exitFlag, OUTPUT] = fminunc(@trqfunc_new,
x0, algoptions);

which calls the following code to evaluate the cost function:

function y = trgfunc_new(x)
% Evaluate the torque objective function
y = -evaluate(optimstore, x);
end

In performing the algorithm, the only difference between the original and modified code
is how the objective function is evaluated. The original algorithm requires the objective
function (a Model-Based Calibration Toolbox model for torque) to be loaded in and
evaluated as required. In the modified algorithm the objective function (torque) is
evaluated by invoking the evaluate function on the optimstore object. Note that the
inputs to the torque model are passed in to the evaluate function as shown in the
following table.

Original Input Input to Evaluate Function
S X(1)
A X(2)

Algorithm Section 3
Retrieve output data.

Original code:
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Optimal free variable settings are returned through the variable bestX in
currtutoptim.

Modified code:

% Write results to the optimstore
optimstore = setFreeVariables(optimstore, bestx);

% Set termination message
termMsg = OUTPUT.message;
OUTPUT = rmfield(OUTPUT, 'message');

% Set all information in the optimstore and leave
optimstore setExitStatus(optimstore, exitFlag, termMsg);
optimstore setOutput(optimstore, OUTPUT);

In the modified algorithm, the results need to be sent back to the CAGE optimization
feature and not the MATLAB workspace. To do this, optimization results are set in the
optimstore object, which is then returned to CAGE. There are three functions you
should invoke on the optimstore object to return optimization results to CAGE:

* setFreeVariables — Returns the optimal free variable values to CAGE

* setExitStatus — Returns an integer that indicates whether the algorithm
terminated successfully or not (positive is successful). This sets the termination
message.

* setOutput — Returns any diagnostic information on the algorithm to CAGE

Step 5: Register Your Optimization Function with CAGE

The worked example provided is preregistered so you can see it as an option in the
Optimization Wizard when setting up a new optimization. You must register new functions
before you can use them. When you have modified the template to create your own
optimization function, as in this example, you must register it with the Model-Based
Calibration Toolbox product in order to use the function in CAGE. Once you have checked
in your optimization function it appears in the Optimization Wizard.

1 In CAGE, select File > Preferences.

The CAGE Preferences dialog appears.
2 C(Click the Optimization tab and click Add to browse to your file.
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3

Locate the file mbcOStutoptimfunc.m (in the working folder you created) and click
Open.

This registers the optimization function with CAGE.

'} CAGE Preferences x|

File anationsl Iser Information  Optimization I

|Jzer-defined optimization functions;

M arne | Location Add..
mbcOStutoptimfunc— D:\Dphimization

Remove

Test

di

i | >

ak. | Cancel |

You can now test the function by clicking Test. This is a good check for any syntax
errors in your optimization function. This is a very useful function when you use your
own functions; if anything is incorrectly set up the test results will tell you where to
start correcting your function.

You could see an example of this by saving a copy of the worked example file and
changing one of the variable names (such as afr) to a number. Try to check this
altered function into CAGE, and the Test button will return an informative error
specifying the line you have altered.

Click OK to leave the CAGE Preferences dialog. If the optimization function tested
successfully, it is registered as an optimization function that can be used in CAGE,
and appears in the Optimization Wizard.

Step 6: Verify Your New Optimization

1

To verify the algorithm we set up a CAGE session to run the optimization that was
performed in step 1. For this example, the CAGE session has already been set up. Follow
the steps below to run the tutorial optimization in CAGE.

In CAGE, select File > Open Project and load the file optimworkedexample. cag
(unless you already have this project open). This project is in the mbctraining
folder.
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Select File > New > Optimization.

The newly registered optimization appears in the list of algorithm names. Select
Tutorial Optimization from the list. Click Next.

) Dptimization Wizard =1oix]

Algorithm Selection
Select fram the list the algorithm that you wart the new optirmization to use.

Available optimization algorithms:

Mame | Free Yarables | Objectives | Constraints | Operating Paint Sets |
MEI any number 2 or more any number Oorl
foptzan any number 1 any humber Oorl

i] i]

wforkedE xam 2 1

Cancel = Back Mext = Finist

4  Match the variables as shown.

JT=TE

Required Variables
Match each required wvariable in the optirnization to a variable from the Wariable Dictionary.

Optitnization inputs: CAGE variables:
Label | CaGE VWariable | X spark
afr A XM
zpk spark, L
X A
Cancel = Back [Hext = Finish

Click Next.
5 Match the Torque model to the tuttq CAGE model as shown.
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) Optimization Wizard =lol x|

Objectives
Ohjectives are gquantities that the algorithm will attempt to optimize. Select CAGE models to bhe used for each objective,
and whether it should be minimized, maximized or used a2 a helper model for the algorithm.

Optitmization objectives: CAGE models:
Optimization Model | CAGE Model | Tupe i
Torque tuttq I aximize ol ity

Objective type: & Winimize % Maximize  Helper

Cancel = Back [t = Finish

Click Finish.

If you ran the optimization now it would run at one point, the set point of all the
variables. You use the free and fixed Variable Values panes to select operating
points. You can edit points manually or import them. Do one of the following:

+ Ifyou have the previous worked example optimization in your current session, in
the optimization view increase the Number of runs to 36, and then copy and
paste the fixed variable values from the previous optimization.

* Ifyou do not have the previous optimization in your session, select Optimization
> Import From Data Set. The project file contains a data set with N and L
values, and these are automatically selected. Click OK to import.

Now you should have 36 rows in both fixed and free variable panes, and operating
point values in the N and L columns in the Fixed Variables pane. The initial values
for A and spark for each point are the set points in the variable dictionary.

Select Optimization > Set Up. The Optimization Parameters dialog box appears.
Observe the five parameters defined in the tutorial optimization script.

Change the variable and function tolerances to 1e-4, and click OK to close the dialog
box.

Run the optimization and view the results. The output data matrix should resemble
the following. Note that the optimal values for A and SPK are very similar to those
from the original algorithm.
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Run | Accept A spark Targue
1 o+~ 23768 1000 0.2 an7
2 ol 1278 18179 1000 0.3 20.319
3 o+~ 12,75 14 261 1000 0.4 3 567
4 ol 1278 12.014 1000 0.5 42 516
5 o+~ 12,75 11 441 1000 0.5 54 054
B ol 1278 12 534 1000 0.7 B5.313
7 o+~ 12,75 27 476 2000 0.2 9742
& ol 1278 21 887 2000 0.3 20.99
g o+~ 12,75 17.959 2000 0.4 32238
10 H ™~ 12.78 15.722 2000 0.5 43 457
11 o+~ 12,75 15147 2000 0.5 54735
12 H ™~ 12.78 16.243 2000 0.7 B5.954
15 o+~ 12,75 3185 3000 0.2 9.342
14 H ™~ 12.78 25 597 3000 0.3 20,59
15 o+~ 12,75 2 553 3000 0.4 3 839
16 H ™~ 12.78 19.431 3000 0.5 43087
17 o+~ 12,75 15.856 3000 0.5 54336
16 H ™~ 12.78 19.953 3000 0.7 B5.554
19 o+~ 12,75 34 591 4000 0.2 7872
20 H ™~ 12.78 29.305 4000 0.3 1912
21 o+~ 12,75 25385 4000 0.4 30368
22 H ™~ 12.78 23139 4000 0.5 41 B17
25 o+~ 12,75 27 563 4000 0.5 52 A5G
24 H ™~ 12.78 23659 4000 0.7 B4.114
25 o+~ 12,75 35614 5000 0.2 533
26 H ™~ 12.78 33.013 5000 0.3 16.58
27 o+~ 12,75 29,093 5000 0.4 27 A28
26 H ™~ 12.78 26,547 5000 0.5 39.077
29 o+~ 12,75 26.27 5000 0.5 50325
30 H ™~ 12.78 27 367 5000 0.7 B1.574
3 o+~ 12,75 47 321 G000 0.2 172
32 H ™~ 12.78 36.721 G000 0.3 12,969
33 o+~ 12,75 32 801 G000 0.4 2427
34 H ™~ 12.78 30,555 G000 0.5 35 465
35 o+~ 12,75 29.95 G000 0.5 45714
36 H ™ 12.78 .075 G000 0.7 57 962




Optimization Function Reference

Optimization Function Reference

In this section...

“Methods of cgoptimoptions” on page 8-31
“Methods of cgoptimstore” on page 8-33

Methods of cgoptimoptions

You use these functions to set up all your optimization settings in the Options section of

the file. You can set up any or all of these seven attributes:

* Name

* Description

* Free variables

* Objective functions

* Constraints

* Helper data sets

* Optimization parameters

The following methods are available:
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addFreeVariable
addLinearConstraint
addModelConstraint
addObjective
addOperatingPointSet
addParameter
getConstraints
getConstraintsMode
getDescription
getEnabled
getFreeVariables
getFreeVariablesMode
getLinearConstraints
getModelConstraints
getName

getNonlcon
getObjectives
getObjectivesMode
getOperatingPointSets
getOperatingPointsMode
getParameters
getRunlnterfaceVersion
removeConstraint
removeFreeVariable
removeObjective
removeOperatingPointSet
removeParameter
setConstraintsMode
setDescription
setEnabled
setFreeVariablesMode
setName
setObjectivesMode
setOperatingPointsMode
setRunInterfaceVer<ion

Add free variable to optimization

Add linear constraint to optimization

Add model constraint to optimization

Add objective to optimization

Add operating point set to optimization

Add parameter to optimization

Return information about all optimization constraints
Return current usage of constraints

Get current description for optimization function

Get current enabled status for optimization

Return optimization free variable labels

Return current usage of free variables

Get linear constraint placeholder information

Get model constraint placeholder information

Get current name label for optimization function

Get nonlinear constraint information

Return information about optimization objectives
Return current usage of objective functions

Return information about optimization operating point sets
Return current usage of operating point sets

Return information about optimization parameters
Get preferred interface to provide evaluation function
Remove constraint from optimization

Remove free variable from optimization

Remove objective from optimization

Remove operating point set from optimization
Remove parameter from optimization

Set how optimization constraints are to be used
Provide description for optimization function

Set enabled status for optimization function

Set how optimization free variables are used

Provide name label for optimization function

Set how optimization objective functions are used
Set how optimization operating point sets are used
Get nreferred interface to nrovide evaluation function
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Methods of cgoptimstore

The following methods are available:

8-33



8 Writing User-Defined Optimizations

8-34

evaluate
evaluateConstraint
evaluateEqCon
evaluateIneqCon
evaluateNonlcon
evaluateObjective

get

getA

getB

getConstraint
getDataset
getFreeVariables
getlnitFreeVal

getLB

getLcon
getNumConstraint
getNumConstraintLabels
getNumLcon
getNumLconLabels
getNumNonlcon
getNumNonlconLabels
getNumObjectiveLabels
getNumObjectives
getNumRowsInDataset
getObjectives
getObjectiveType
getOptimOptions
getOutputlnfo
getParam
getStopState

getUB

gridEvaluate
gridPevEvaluate
isScalarFreeVariables
nEvaluate

Evaluate optimization objectives and constraints
Evaluate optimization constraints

Evaluate optimization nonlinear equality constraints
Evaluate optimization nonlinear inequality constraints
Evaluate optimization nonlinear constraints
Evaluate optimization objectives

Get optimization properties

Get linear inequality constraint matrix.

Get linear inequality constraint target values.
Return constraint labels

Retrieve data from data set

Get optimal values of free variables

Get initial free values for optimization

Get free variable lower bounds

Return linear constraint labels

Return number of constraints per label

Return number of constraint labels

Return number of linear constraints per label
Return number of linear constraint labels
Return number of nonlinear constraints per label
Return number of nonlinear constraint labels
Return number of objective labels

Return number of objectives per label

Get number of rows in optimization data set
Return objective labels for optimization

Return objective type

Retrieve optimization options object

Get output information for optimization

Get optimization parameter

Current stop state for optimization

Get free variable upper bounds

Grid evaluation of optimization objectives and constraints

Grid evaluation of prediction error variance (PEV)
Return whether all free variables are scalars

Natural evaluation of ontimization obhiectives and constraints
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addFreeVariable

Add free variable to optimization

Syntax

options = addfreeVariable (options, label)

Description

A method of cgoptimoptions. Adds a placeholder for a free variable to the optimization.
The string label is used to refer to the variable in CAGE.

See Also

Topics
setFreeVariablesMode
getFreeVariablesMode
getFreeVariables
removeFreeVariable

Introduced before R2006a
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addLinearConstraint

Add linear constraint to optimization

Syntax

options = addLinearConstraint(options, label, A, B)

Description

A method of cgoptimoptions. Adds a placeholder for a linear constraint to the
optimization. The string label is used to refer to the constraint in the CAGE GUI. Linear
constraints can be written in the form

A(1)X(1) + A(2)X(2) + ... + A(n)X(n) <= b

where X(1) is the ith free variable, A is a vector of coefficients, and b is a scalar bound.

Examples

o°

Add SPK and EGR variables to an optimization

pt addFreeVariable(opt, 'SPK');

pt addFreeVariable(opt, 'EGR');

Add a linear constraint such that 3*SPK - 2*EGR <= 30
opt addLinearConstraint(opt, 'newCon', [3 -2], 30);

o®° O O
nma i

See Also

Topics
getLinearConstraints
addModelConstraint
setConstraintsMode
removeConstraint
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Introduced before R2006a

8-38



addModelConstraint

addModelConstraint

Add model constraint to optimization

Syntax

options=addModelConstraint(options, label, boundtype, bound)

Description

A method of cgoptimoptions. Adds a placeholder for a model constraint to the
optimization. The string label is used to refer to the constraint in CAGE.

boundtype can be set either to the string 'greaterthan' or 'lessthan’'.
bound must be a scalar real.

If boundtype = 'greaterthan’, the model constraint takes the following form:
CAGE model >= bound

Similarly, if boundtype = 'lessthan’, the model constraint takes the form

CAGE model <= bound

Examples

An optimization requires a constraint where a user-defined function must be less than
500. The following code line adds a placeholder for this constraint that is labeled 'mycon':

opt = addModelConstraint(opt, 'mycon', 'lessthan', 500);

See Also

Topics
getModelConstraints
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addLinearConstraint
setConstraintsMode
removeConstraint

Introduced before R2006a
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addObjective

Add objective to optimization

Syntax

options = addObjective(options, label, typestr)

Description

A method of cgoptimoptions. Adds a placeholder for an objective function to the
optimization. The string label is used to refer to the constraint in CAGE.

typestr can take one of four values, 'max', 'min’, 'min/max’, or 'helper"'.

Examples

opt = addObjective(opt, 'newObj', 'max')

Adds an objective function labeled newObj to the optimization and indicates that it is to
be maximized.

opt = addObjective(opt, 'newObj', 'min/max')

Adds an objective function labeled newObj to the optimization and indicates that the user
should be allowed to choose whether it is minimized or maximized from CAGE.

opt = addObjective(opt, 'newObj2', 'helper')

Adds an objective function labeled newObj2 to the optimization. The string 'helper’
indicates that the function is used as part of the determination of the cost function but is
not directly minimized or maximized.
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See Also

Topics
getObjectives
setObjectivesMode
getObjectivesMode
removeObjective

Introduced before R2006a
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addOperatingPointSet

Add operating point set to optimization

Syntax

options = addOperatingPointSet(options, label, vars)

Description

A method of cgoptimoptions. options = addOperatingPointSet (options,
label, vars) Adds a placeholder for an additional operating point set to the
optimization.

The string label is used to refer to the constraint in CAGE. vars is a (1-by-N) cell array
of strings where N >= 1. Each element of vars is a label for a CAGE variable that must
appear in the operating point set that the user chooses.

See Also

Topics
getOperatingPointSets
setOperatingPointsMode
getOperatingPointsMode
removeOperatingPointSet

Introduced before R2006a

8-43



8 Writing User-Defined Optimizations

8-44

addParameter

Add parameter to optimization

Syntax

options = addParameter(options, Label, Type, Value)

options = addParameter(options, Label, Type, Value, DisplayName)
Description

A method of cgoptimoptions.

options = addParameter(options, Label, Type, Value) adds a parameter to
the optimization. The string Label is used to refer to the parameter in the Evaluate
section of your script. You must specify a default value in Value. The table below lists the
parameter types that are supported along with how to specify their Type and Value.

Parameter Type Type Value

Real number "number’ Real scalar
Integer "integer' Integer scalar
Enumerated list {'list', {list items}} One of {list items}
Boolean 'boolean’ true or false

Note: The {list items} cell array for an enumerated list must be a cell array of strings,
one for each list member.

You can restrict a numeric parameter (' number' or 'integer') to a valid range. To do
this, specify a cell array for Type from the following:

Range type Type

Positive {TYPESTR, 'positive'}
Negative {TYPESTR, 'negative'}
User defined {TYPESTR, [a b]}



addParameter

where TYPESTR is either 'number' or 'integer'. Note that the user-defined range type
strictly includes the limits, whereas the positive and negative range types exclude zero.
Furthermore, the default Value must lie in the specified range.

options = addParameter(options, Label, Type, Value, DisplayName)
allows you to add a more descriptive label for the parameter in the CAGE Optimization
Parameters GUI. Note that you still must refer to the parameter by label in the
Evaluate section of your script.

See Also

Topics
getParameters
getParam
removeParameter

Introduced before R2006a
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evaluate

Evaluate optimization objectives and constraints

Syntax

Y = evaluate(optimstore, X)

Description

A method of cgoptimstore.
Evaluate optimization objectives and constraints.

Y = evaluate(optimstore, X) evaluates all of the optimization objectives and
constraints at the free variable values X. X is a (NPoints-by-NFreeVar) matrix where
NPoints is the number of points to be evaluated and NFreeVar is the number of free
variables in the optimization.

Evaluation over data sets is only supported when the free variables are scalar, that is, you
cannot perform evaluation over a data set for "sum" optimizations.

Examples

Y = evaluate(optimstore, X, itemnames)

evaluates the objectives and constraints specified in the cell array of strings, itemnames,
at the free variable values X. The values of the objectives and constraints are returned in
Y, which is of size (NPoints-by-NItems) where Nltems is the number of objectives and
constraints listed in itemnames. Note that the evaluation of Y is scaled onto [-1 1].

Y = evaluate(optimstore, X, itemnames, datasetname)

evaluates the specified objectives and constraints at the operating points in the data set
specified by the string datasetname. X must be a (Nrows -by-NfreeVar) matrix, where
Nrows is the number of rows in the data set.

Y = evaluate(optimstore, X, itemnames, datasetname, rowind)
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evaluates the specified objectives and constraints at the points of datasetname given by
rowind. X must be a (NRows -by-NFreeVar) matrix where NRows is the length of
ROWIND. ROWIND must be a list of integer indices in the range [1
NumRowsInDataset]. Yisa (Nrows-by-NItems) matrix.

See Also

Topics
nEvaluate
pevEvaluate

Introduced before R2006a
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evaluateConstraint

Evaluate optimization constraints

Syntax

Y = evaluateConstraint(optimstore, X)

Description

A method of cgoptimstore.

Y = evaluateConstraint(optimstore, X) evaluates all of the optimization
constraints at the free variable values X. X must be a (NPoints-by-NFreeVar) matrix
where NPoints is the number of points to be evaluated and NFreeVar is the number of
free variables in the optimization. The values of the constraints are returned in Y, which is
of size (NPoints-by-NItems) where NItems is the number of constraints in the
optimization.

If you enable scaling of the optimization items, then the evaluation of Y is approximately
scaled onto [-1 1]. See “Scale Optimization” on page 6-68 for more information on scaling.

Negative values of Y imply X is feasible.

Examples

Y = evaluateConstraint(optimstore, X, itemnames)

evaluates the constraints specified in the cell array of strings, itemnames, at the free
variable values X. The values of the constraints are returned in Y, which is of size
(NPoints-by-NItems) where NItems is the number of objectives listed in itemnames.

[Y, YG] = evaluateConstraint(optimstore, X, itemnames)

also evaluates the gradient of the specified constraints in YG (if itemnames is not
specified, then the gradient of all constraints is returned). YG is of size NFreeVar-by-
NItems-by-NPoints, where NFreeVar is the number of free variables in the
optimization.
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See Also

Topics
evaluateObjective
evaluateNonlcon

Introduced in R2006b
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evaluateEqCon

Evaluate optimization nonlinear equality constraints

Syntax

Y = evaluateEqCon(optimstore, X)

Description

A method of cgoptimstore.

Y = evaluateEgCon(optimstore, X) evaluates all of the nonlinear equality
constraints in the optimization at the free variable values X. X must be a (NPoints-by-
NFreeVar) matrix where NPoints is the number of points to be evaluated and
NFreeVar is the number of free variables in the optimization. The values of the
constraints are returned in Y, which is of size (NPoints-by-NItems) where NItems is
the number of nonlinear equality constraints in the optimization.

If you enable scaling of the optimization items, then the evaluation of Y is approximately
scaled onto [-1 1]. See “Scale Optimization” on page 6-68 for more information on scaling.

Negative values of Y imply X is feasible.

See Also

Topics
evaluateInegCon

Introduced in R2010b
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evaluatelneqCon

Evaluate optimization nonlinear inequality constraints

Syntax

Y = evaluateIneqCon(optimstore, X)

Description

A method of cgoptimstore.

Y = evaluateIneqCon(optimstore, X) evaluates all of the nonlinear inequality
constraints in the optimization at the free variable values X. X must be a (NPoints-by-
NFreeVar) matrix where NPoints is the number of points to be evaluated and
NFreeVar is the number of free variables in the optimization. The values of the
constraints are returned in Y, which is of size (NPoints-by-NItems) where NItems is
the number of nonlinear inequality constraints in the optimization.

If you enable scaling of the optimization items, then the evaluation of Y is approximately
scaled onto [-1 1]. See “Scale Optimization” on page 6-68 for more information on scaling.

Negative values of Y imply X is feasible.

See Also

Topics
evaluateEqCon

Introduced in R2010b
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evaluateNonlcon

Evaluate optimization nonlinear constraints

Syntax

[varargout] = evaluateNonlcon(optimstore, X, ItemNames)

Description

Evaluate optimization nonlinear constraints. A method of cgoptimstore.

Y = evaluateNonlcon(optimstore, X) evaluates all of the nonlinear constraints in
the optimization at the free variable values X. X must be a (NPoints-by-NFreeVar)
matrix where NPoints is the number of points to be evaluated and NFreeVar is the
number of free variables in the optimization.

If you enable scaling of the optimization items, then the evaluation of Y is approximately
scaled onto [-1 1]. See “Scale Optimization” on page 6-68 for more information on scaling.

Y = evaluateNonlcon(optimstore, X, ItemNames) evaluates the nonlinear
constraints specified in the cell array of strings, ItemNames, at the free variable values X.
The values of the nonlinear constraints are returned in Y, which is of size (NPoints-by-
NItems) where NItems is the number of nonlinear constraints listed in ItemNames.

[Y, YG] = evaluateNonlcon(optimstore, X, ItemNames) also evaluates the
gradient of the specified constraints in YG (if ItemNames is not specified, then the
gradient of all constraints is returned). YG is of size NFreeVar-by-NItems-by-
NPoints, where NFreeVar is the number of free variables in the optimization.

See Also

Topics
evaluateConstraint
evaluateObjective
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Introduced before R2006a
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evaluateObjective

Evaluate optimization objectives

Syntax

varargout = evaluateObjective(optimstore, X, ItemNames)

Description

Evaluate optimization objectives. A method of cgoptimstore.

Y = evaluateObjective(optimstore, X) evaluates all of the optimization
objectives at the free variable values X. X must be a (NPoints-by-NFreeVar) matrix
where NPoints is the number of points to be evaluated and NFreeVar is the number of
free variables in the optimization. The values of the objectives are returned in Y, which is
of size (NPoints-by-NItems) where NItems is the number of objectives in the
optimization.

If you enable scaling of the optimization items, then the evaluation of Y is approximately
scaled onto [-1 1]. See “Scale Optimization” on page 6-68 for more information on scaling.

Y = evaluateObjective(optimstore, X, ItemNames) evaluates the objectives
specified in the cell array of strings, ItemNames, at the free variable values X. The values
of the objectives are returned in Y, which is of size (NPoints-by-NItems) where
NItems is the number of objectives listed in ItemNames.

[Y, YG] = evaluateObjective(optimstore, X, ItemNames) also evaluates the
gradien